View Full Version : [ubuntu] GRUB locate disk by uuid, can't mount

June 10th, 2012, 09:31 PM

I have trouble booting my newly installed system.

To avoid another problem with graphics drivers (quite another history) it has been necessary for me to install Ubuntu 12.04 by different means than usual.

I connected the 120gb SSD disk through a SATA-to-USB cable (with external power to the disk, ofcourse) to my laptop. I then opened VirtualBox, mounted the physical SSD disk as a virtual disk[1] (this has previously worked perfect for me) and installed from the newly downloaded .iso of Ubuntu 12.04. I then installed the necessary graphics drivers that was necessary to boot on the intended hardware (the first problem).

I put the harddisk back in the chassis, and when booting i get through grub, but halt with a BusyBox promt. The error seems to be that grub attempts to mount the root partition by a uuid that doesn't exist in /dev/disk/by-uuid.

When i run 'mount /dev/sda1 /root' or 'mount /dev/sda /root' (which exists) i get an 'Invalid arguments'-error.

Now, how do i bootstrap the partition so i can update grub for proper automated booting of the system?

Thank you,

[1] http://www.sysprobs.com/access-physical-disk-virtualbox-desktop-virtualization-software

June 10th, 2012, 09:33 PM
Had you considered a install using the alternative cd?

June 10th, 2012, 09:36 PM
If your Ubuntu installation is on sda1, and set up normally, try this at the grub menu.

Press c to get to the grub prompt if not already there.

set prefix=(hd0,1)/boot/grub
set root=(hd0,1)
linux /vmlinuz ro root=/dev/sda1
initrd /initrd.img

If that doesn't work, I'd recommend booting a LiveCD, installing Boot Repair, and allow it to attempt a fix. Link is in my signature line.

June 13th, 2012, 11:40 AM
Had you considered a install using the alternative cd?

I am not aware of any alterantive CD and have not seen it mentioned anywhere. Can you elaborate? :)

- ath88

June 13th, 2012, 12:54 PM