View Full Version : [SOLVED] 10.04 Wine won't do anything at all

June 10th, 2012, 06:10 AM
When I tried to run winetricks, nothing happened. Tried to run winecfg in terminal, got a message "wine: virtual memory exhausted". Needless to say, I can't run any programs with Wine. Also, my wine folder is empty.

After all that happened, I went to the software center and installed the Wine dummy package, which seems to have changed my version of Wine from 1.3 to 1.2.

Anybody know what's up, and what I should do to get it running? All I was wanting to do was use BGB to get more accurate sounds out of my LSDJ gameboy music tracker, since, after using it on my XP, I'm unsatisfied with the sounds Visual Boy outputs.

June 10th, 2012, 06:14 AM
Theres a fix in this thread that might help:

June 11th, 2012, 05:36 AM
Thanks, but it didn't work. I added myself to user, but it didn't change anything. Still can't do anything with Wine. And some of my key applications were wine compatible =(

Edit: Isn't the .wine/c folder supposed to contain something? Mine is completely empty. Do you think If I copy my wine folder from a backup that I have of another system, it might jog something and get it working? Is all the configuration for wine stored in the .wine folder?

June 19th, 2012, 07:49 PM
I'd still like to get a solution to this.

Is it possible that my swap partition is too big or something? (grasping at straws here... the error message did say something about virtual memory, after all.)

Edit: Under "Users and Groups > Advanced > Permissions" the option "Use Virtualization Console" option is missing.

Edit: WELL THANKS FOR ALL THE HELP GUYS. Found out from WineHQ that I had installed an old (and broken for some reason. Why would an old version of a program break if it hasn't been tampered with? Maybe it's because the dependencies changed or something, I dunno...) version of Wine. I had tried to install versions 1.2 and 1.3 with no luck. I added the official Wine PPA to my repositories, and, even though the package title says it's wine1.3, the version description says 1.4. Weird, but... whatever.

It works now. They need to make the "Updates for this Package not provided by Canonical" With a BIG RED Icon in BIG RED WORDS so newbies don't have to go searching Google to realize that such a thing is very important to the potential functionality of the applications they are installing.