View Full Version : [ubuntu] Excessive Fan or Hard Disk since upgrade to 12.04

June 8th, 2012, 06:55 PM
Since upgrade to 12.04, I have been noticing excessive fan noise in my Dell 1555 laptop. I have dual boot and upon logging in Windows Vista, I don't find any noise and the laptop is calm.

Here is the output of sensors command.

Adapter: Virtual device
temp1: +51.0C (crit = +100.0C)
temp2: +59.0C (crit = +100.0C)
temp3: +79.0C (crit = +100.0C)

Adapter: PCI adapter
temp1: +80.0C

Is there a way to figure out which application is causing it and how can it be prevented?

June 13th, 2012, 09:42 PM
I encounter the same problem, which kind of graphics you have on your computer?

is this helpful?


June 13th, 2012, 09:51 PM
Hopefully you also have windows installed on that laptop.

If so, update the bios. (triple check to make sure this is indeed your model)


If that doesn't help try this.


If that still doesn't help switch to the fglrx driver, should cool your graphics chip down on that model.

June 14th, 2012, 11:03 AM
I installed fglrx-update from synaptic as I was unable to install it from Additional Drivers. Now, the laptop is much less hot and the fan doesn't make noise at all. However, I still have lower battery backup compared to Windows.

Today, I am going to update bios as you guys suggested and see how it works.

But I couldn't understand what is this DSDT thingi. I am not getting any errors as such.

June 14th, 2012, 10:14 PM
I just updated the BIOS and the fan noise is back :(

Then I removed fglrx-updates and installed fglrx to see if that had any effect. After that, I ran
aticonfig --initial to get the proper xorg file.

Surprisingly, the noise was almost inaudible!

However, soon Unity crashed and now upon login all I would get is the desktop without launcher or panel. I could launch terminal by

It seemed like xorg was getting corrupted and I tried
aticonfig --initial, but this time, I was greated with
sudo: aticonfig: command not found.

Now, I am reinstalling fglrx to see if it can help, but can't understanding why Unity is crashing and aticonfig refuses to run.