PDA

View Full Version : [ubuntu] Nvidia + Intel



hozertech
June 7th, 2012, 12:03 AM
I have 3 monitors one is using the onboard Intel i915 and the other 2 are on the Nvidia 550 Ti
I having some issues getting Ubuntu 12.04 to recognize my Nvidia card.
i have purged the drivers and reinstalled but when i run "sudo nvidia-xconfig" i get this

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

and if i restart x the screen res drops to 720x400 and i have to restore the xorg.conf file

here is the xorg.conf i get when i run "sudo nvidia-xconfig"

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 295.53 (buildmeister@swio-display-x86-rhel47-07.nvidia.com) Sat May 12 00:34:20 PDT 2012

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection



if i run "lshw -C video" it sees both graphics adapters -

*-display
description: VGA compatible controller
product: GF116 [GeForce GTX 550 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:16 memory:f6000000-f7ffffff memory:e0000000-e7ffffff memory:ec000000-efffffff ioport:ef00(size=128) memory:e8000000-e807ffff
*-display
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:43 memory:fb800000-fbbfffff memory:d0000000-dfffffff ioport:ff00(size=64)

i have tried the .run file from Nvidia as well and i get the same results.
any idea on how to get this to work? only using 1 monitor sucks...