View Full Version : [SOLVED] Making Canon printer work with 32 bit ubuntu

June 5th, 2012, 12:33 PM
Had some bad hardware luck lately and now trying to get my Canon LBP2900 printer working with an old eeePC with Ubuntu 12.04 (32 bit) installed.

I followed Sivella's excellent tutorial here:

When I run the test with
captstatusui -P LBP2900 I get a connection error. The printer is on and the cables are connected - is this a problem with my printer or in the OS? When I check for /dev/usb/lp0 I notice it doesn't exist either when the printer is plugged in or when it is not. Doing
lsusb results in a list of USB devices that includes the printer.

Any ideas are appreciated.


June 6th, 2012, 04:00 PM

Due to a new cups update, it seems that usblp module is now blacklisted (as it was with 11.10).
So the printer is not mounted in /dev/usb/lp0.

The solution is to cancel this blacklist.

Edit this file : /etc/modprobe.d/blacklist-cups-usblp.conf

Comment (#) the line : blacklist usblp
Here is my file :

# cups talks to the raw USB devices, so we need to blacklist usblp to avoid
# grabbing them
#blacklist usblp Good luck.

June 7th, 2012, 12:54 AM
Works like a charm! Thanks again, Sivella.


July 3rd, 2012, 03:02 AM
I followed your tutorial Sivella to install my LBP3100; it worked well and printed; however; on re-booting, it will no longer work

in a terminal

captstatusui -P LBP3100 gives the message on the screenshot

I should have mentioned I am using Mint13: based on Ubuntu 12.04 and it does not have the file /etc/modprobe.d/blacklist-cups-usblp.conf

so I did not need to blacklist the line "blacklist usblp"

In my first reboot, the file to be printed showed as "processing"

now, on my second reboot, the "to be printed" icon rapidly disappears, as though the page is to be printed, but nothing happens.........

July 3rd, 2012, 04:51 AM
Is ccpd running? You can make sure by typing
sudo service ccpd start in the terminal.

July 3rd, 2012, 10:19 AM
yes; I believe it is running; I also used the command you suggested;

at each time, the icon for document gone to printer shows and then disappears; as though successful; but no printing

July 4th, 2012, 07:14 AM
This is really acting like you have the printer blacklisted. I don't use Mint so I don't know what could be doing this. Have you tried doing a find (or locate) command looking for any files with blacklist in the name?

July 4th, 2012, 09:03 AM
thanks for the suggestion; screenshot enclosed; I used gedit to look through the files: no mention of a printer there

mojo risin
July 4th, 2012, 12:38 PM
I don't have a problem with the printer showing up-- but atm I have a problem with the printer starting pages and then it stops and seems to be stuck after only about 1/6 of the page is printed.

July 4th, 2012, 03:01 PM
pdc - I don't see a likely culprit there either, since Mint apparently handles this issue in a very different way than Ubuntu, maybe you would have more luck finding someone in a Mint forum that can help?

mojo risin - is it a Canon printer? That sounds like a very different problem than was discussed in this thread, may need a thread of its own to attract people who know what they are talking about!


mojo risin
July 4th, 2012, 06:08 PM
Posted a thread in case you are interested at looking at it :lol: