View Full Version : [ubuntu] Asus 900a graphics problem

June 5th, 2012, 11:16 AM
Does anyone know how I can resolve this problem on a Asus eeePC 900a running 12.04

Adapter Description - Tungsten Graphics, Inc -- Mesa DRI Intel(R) 945GME x86/MMX/SSE2
Vendor ID - - Tungsten Graphics, Inc
Device ID - Mesa DRI Intel(R) 945GME x86/MMX/SSE2Driver Version1.4 Mesa 8.0.2
WebGL Renderer - Blocked for your graphics card because of unresolved driver issues.
GPU Accelerated Windows0. - Blocked for your graphics card because of unresolved driver issues.
AzureBackend - skia

(Treat me gently as I spent too many years playing with windows!!)


June 5th, 2012, 02:26 PM
Welcome to the forums!

What is the problem exactly? What are you trying to do that you get the output above?

Intel 945GME is an extremely low-end graphics chipset, don't expect to be playing hi-def video or graphics-intensive games on your EEE netbook. ;)

June 5th, 2012, 08:26 PM
Hi Snowpine and thanks for the reply. I got the message from Firefox browse "Help" trouble shooter information. I noticed that a lot of graphics were missing on several websites. Couldn't find a solution on Firefox website so I assumed it might be a Ubuntu problem.

June 5th, 2012, 09:00 PM
I do not think lack of GPU accelaration would cause Firefox not to load images? What I would do as a troubleshooting step is to right-click on the image that refuses to load, choose "Copy Link Location," open a new tab, and paste the link into the address bar. Does it load when you do it that way?

If you want to send a link to the site I'd be happy to take a look for you. I actually have an EEE myself with the same graphics card. Or maybe the site is just broken? ;)

June 5th, 2012, 10:41 PM
Hi Snowpine

I found this on the Firefox Help (page down to bottom)


The preview won't show all of the link so I've pasted it :-

I still have problems with my graphics card in Firefox

Unfortunately, due to the wide range of possible driver, video card and operating system combinations, hardware acceleration or 3D web graphics (WebGL) may still not work for you in Firefox. In these instances you fix the problems by disabling hardware acceleration and WebGL.
Turning off hardware acceleration

At the top of the Firefox window, click on the Edit menu and select Preferences
Select the Advanced panel
Select the General tab
Uncheck Use hardware acceleration where available.
At the top of the Firefox window, click on the File menu and select Quit. Start Firefox normally.

Disabling WebGL

In the Location bar (http://support.mozilla.org/en-US/kb/Location%20bar%20autocomplete), type about:config and press Enter.

The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page.

In the Filter box, type webgl.disabled
Doubleclick on the webgl.disabled item to switch it to true
At the top of the Firefox window, click on the File menu and select Quit. Start Firefox normally.

I tried disabling as they state but still get blanks

This is a an example
(I'm a bit of a politics nutter!!)
I have found blanks on other sites as well.

June 5th, 2012, 11:09 PM
I don't see any broken images on that site using my Asus EEE 900HA with Intel 945GME graphics.

A couple of suggestions to start troubleshooting would be to view the same page with a different browser (Chrome or Opera for example) and/or view it with another computer on your same network.

June 6th, 2012, 12:50 PM
Hi Snowpine

I checked on my wife's laptop running XP as it has both Firefox and IE installed and all of the links were there with IE but not Firefox. I also installed Midori on the Asus (Ubuntu 12.04) and also get full graphics with it so the problem seems to be exclusively with Firefox and not Ubuntu.

Many thanks for your assistance.


June 13th, 2012, 10:18 AM
Well I finally resolved the graphics problem .

In Firefox
Troubleshooting Information
Reset Firefox (box in top RH corner)

Job done!

How do I add solved?