View Full Version : [SOLVED] After Update, Ubuntu GUI crashes. Boots to TTY.

May 27th, 2012, 12:00 PM
Hello all, and thank you in advance for your help.

I have been running 12.04 since it's release, and haven't had any real issues until now.

I ran an update from the Update Manager today (it had only been a day or two.) And after it completed it said that I needed to restart to complete the changes. For some reason I couldn't get the update manager to come back up, so I couldn't view the patch notes. Thinking nothing of it, I restarted.

However, afterwards GRUB would load up, but it didn't have the option to load with previous kernels like it did before. (I'm guessing there was a kernel update and it removed obsolete kernels.) I booted from the most recent generic, but once I get to the Ubuntu flash screen, the GUI crashes and it boots to TTY. Unfortunately I can't paste any error messages, since currently I'm running off of a live USB, and this is my only machine. I tried booting Unity and it said it didn't exist. I tried booting Ubuntu-desktop, and it said it didn't exist. From the looks of my .xsession-errors file it seems that compiz is the culprit. When I try to run compiz or do any configuration I get the error message "Compiz (core) Fatal: Couldn't Open Display". I don't see how it could be a driver or video card issue, since I've been running fine for quite some time now.

Dmesg didn't really seem to give me much information. I've removed and reinstalled compiz via TTY to no avail. I'm at a loss. Once again, thanks for the help.

May 27th, 2012, 12:19 PM
Hi there there is a cool tool that I would like you to install it is called pastebinit
when you get to tty sign in and follow these instructions

sudo apt-get install pastebinit

lspci -nn | pastebinit
you will get a link at the end of the output please write that down so you can paste it here late with others


lsmod | pastebinit

grab that link and post both of them here.

May 27th, 2012, 02:27 PM
I have the same problem after the update

May 28th, 2012, 03:51 AM
I had the same problem. Turns out it was a AMD driver issue. I uninstalled and re installed and now everything works proper. Someone recommended this on another forum but after several reboots I don't have the page otherwise I would post it. Hope that helps.

May 28th, 2012, 09:11 AM
Thanks for all of the quick responses and help. Josephmills here are my pastebinit links


@Figuratively - I am running an ATI HD5670. Seeing as you said it was an AMD issue for you, I guess that could be it. Was it the fglrx driver for you? Why would the update cause a driver issue, and cause it to malfunction in this fashion?

May 28th, 2012, 09:50 AM
Welp, looks like that was it. I re-installed the fglrx driver and I'm good to go. Not sure why, but the update completely uninstalled it. However, I'm still having issues with compiz being incredibly unstable.