View Full Version : [SOLVED] 12.04 and ndiswrapper modprode "FATAL: Module ndiswrapper not found"

May 26th, 2012, 02:11 PM
Just a heads up for people with ndiswrapper problems (I crawled the Ubuntu forum and didn't really find this; the info was aggregated from several other sites.)

If you're using an older version of ndiswrapper, and you have the gui AND the program interface (and ndiswrapper even shows that the hardware is attached) but when you modprobe, you're getting this:

FATAL: Module ndiswrapper not found

It means you need to install
(And of course, install ndiswrapper-utils-1.9)

None of which appear to be "Dependencies" for ndiswrapper, but without which it simply does not work.

Apologies if this is already posted somewhere, but when I was looking for it, I saw several people asking, but no definitive answers.


P.S. My install was Xubuntu Alternate. Your experience may vary. ; )

June 16th, 2012, 10:41 AM
This post saved me a whole lot of time and frustration. I had the same problem (xfce, ubuntu 12.04 on an old steam-driven Toshiba Satellite laptop), and the solution worked just fine.


Amzer zo
July 11th, 2012, 07:09 AM
Now it works for me as well (Ubuntu 12.04)


August 1st, 2012, 01:43 PM
That helped me too (Linux Mint 13)!
Thank you a lot!

September 10th, 2012, 09:05 AM
worked for linux mint maya too

September 17th, 2012, 05:16 AM
Thanks very much, your suggestion was just what I needed and fixed my issue as well. Your post was much appreciated.

November 11th, 2012, 04:01 PM
I'm running Linux Mint 13 Maya 64bit

I installed ndiswrapper-common 1.57
I get fatal module not found after going to terminal
and inputting sudo modprobe ndiswrapper

I have the file pasted in home/usb. is it suppose to be in usr/src? Because when I try to paste it in there, it says I don't have access rights, even though I'm the only user with admin rights.

Please, I'm very new to linux so you have to break it down preschool style to me. I appreciate the help. BTW, this is all in an attempt to get my netgear n300 usb driver to work.

November 24th, 2012, 12:05 PM
I'm running Mint 14 (MATE) and following the advice give above has NOT helped...I'm still getting the Fatal Error...can't find ndiswrapper module.

I'm at a loss ...

November 26th, 2012, 12:51 PM
Does not seem to work on a Linux Mint 14 (Cinnamon) 64bit either. But I have read on another forum that Ndiswrapper will only work for 32 bit machines or AMD 64 bit machines (i.e. that it does not work on intel 64 bit machines)

January 4th, 2013, 06:40 PM
I'm running Mint 14 (MATE) and following the advice give above has NOT helped...I'm still getting the Fatal Error...can't find ndiswrapper module.

I'm at a loss ...

Me too, and I'm on 32-bit. Hating this cord stretched across the living room...

January 8th, 2013, 07:43 PM
Hi, the same problem, Mint 14 32Bit. Please help

January 27th, 2013, 11:03 PM
You're a saint! Thank you!

February 4th, 2013, 06:00 AM
Hi, the same problem, Mint 14 32Bit. Please help

follow the steps in this bug workaround to install ndiswrapper 1.58rc1 as 1.57 does not seem to install properly in mint 14 - https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645

worked like a charm for me!

March 24th, 2013, 07:35 PM
ok, I am a total noob here so maybe one of you can help me. I am also having the Fatal Module ndiswrapper not found error. I would love to "install" the things listed in the beginning of this thread to fix it, but I do not know how to install them, or where to get them. Thanks.

March 25th, 2013, 12:03 PM
Installing USB G54/N150 Adapter on Ubuntu 12.04

I have Ubuntu 12.04 (32-bit). I am trying to get my Netgear n-150 micro usb adapter to work. I successfully installed ndiswrapper by going to the software center and installing the following:


I no longer receive the “FATAL: Module ndiswrapper not found” error message. Using the ndisgtk application, I tried to install the following windows drivers:


In each case I received an “Invalid Driver” error message. So my question is which specific window driver do I need to install for the micro Netgear n-150 usb adapter? I was thinking that I need to install the windows driver “netrtwlanu.inf”. I am hoping that you can help me.

April 13th, 2013, 09:49 PM
i've done that all and still FATAL: Module ndiswrapper not found

May 17th, 2013, 03:28 PM
Thank you so much for posting this.

I was able to solve my own problem. I have a desktop with a USB adapter and I kept getting the fatal error. The steps are a little different for desktop which I posted here using your instructions for the fatal error.


May 17th, 2013, 03:33 PM
Have you tried checking out these instructions on the ubuntu docs. https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper.
More specifically in step 3.2 #1 they have a list of drivers avail for download.
I posted how I solved my problem: http://ubuntuforums.org/showthread.php?t=2145852&p=12651837#post12651837
But it sounds like you just need the right driver. On the list it has them listed by the first part of the model #which is either some where on the USB or the box. For example I have a N600 Wireless Dual Band USB Adapter but on the side it has WNDA3100 and on the list I found Netgear 3100.

June 7th, 2013, 10:34 PM
Thanks this really helped so much!

June 17th, 2013, 02:11 AM
Ive had the same issue over several of the latest distros of ubuntu, bohdi and mint. All are based on ubuntu, and apparently there is a verdion of the wrapper preinstalled with ubuntu. you have to uninstall it, then compile a new version. uninstall is apparently the key. https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper pay attention to section 4.

June 27th, 2013, 06:18 AM
Works for me, thanks.

The problem seems to be that the dependencies are broken (ndiswrapper-source
and ndiswrapper-dkms are needed but not installed) - who do we prod to fix that?

August 14th, 2013, 01:59 AM
Hello, had the same problem with Ubuntu 13.04, I installed the 2 missing packages like he/she suggestet (via console "sudo apt-get install ndiswrapper-dkms" & "sudo apt-get install ndiswrapper-source").
after that the command "sudo modproge ndiswrapper" still gave me the same error
but after reinstalling ndiswrapper-utils-1.9 ("sudo apt-get install --reinstall ndiswrapper-utils-1.9") everything worked

hope I could help some1