View Full Version : [SOLVED] 12.04 instalation became useless

May 24th, 2012, 03:53 PM
Dear forum,
I hope you can help me with my 12.04LTS issues.
The problem is that with my upgrade to 12.04 I lost the option to boot into other operating systems. This threat http://ubuntuforums.org/showthread.php?t=1978055 gives the details. Unfortunately it's not solved.
But now I run into a much more severe issue. Booting up seems to work ok, no error messages, and I see the boot up screen from Ubuntu 12.04 LTS. However when the boot up is ended I am stuck with a black screen and only my cursor pointer is visible on the screen.
Pressing Esc or Ctr & Alt & del give some response and sometimes I get my screensaver to show on the monitor. When this happens none of the menus show up and can't log on or off nor can I start any of Ubuntu's utilities. I have a shortcut on the screen for Google and this one works but I can't close the session. Lots of the user interface is gone.

I sometimes get an error message stating following: the application compiz has closed unexpectecally /usr/bin/compiz
Not sure if this is creating the problems.

Sometimes the system let me log off using Ctrl Alt Del and then I can select in what mode I want to log on (Gnome, Gnome classic etc.) But selecting one of these all have the same effect. A useless system with only a few shortcuts shown.
BTW I can log in as recovery console but clearly that gives me a text based interface only, which is very difficult for me.

Really looking forward to receiving suggestions and or fixes from the forum!

Any help is welcome!

May 24th, 2012, 04:10 PM
In the grub boot menu, highlight the uubntu entry and hit 'e' for edit. That should show the boot lines.

With the arrows move to the end of the line starting with linux. Before 'quiet splash' add nomodeset.

Press Ctrl + X to boot. See if that helps to boot into a working desktop.

If you had some specific compiz settings they might not work straight away after the upgrade. First see if nomodeset can help, that is usually for video driver issues.

If you can boot to the desktop with nomodeset, open Additional Drivers and see if there is video driver you need to activate. If there is, that might solve it.

May 25th, 2012, 11:35 AM
Hello Darkod,

thanks for the help, highly appreciated. Unfortunately I can't do anything in the Grub boot menu as it does not show itself on the screen. However the good news is that the boot menu is there, albeit invisible and I can start my system using arrow down in a working mode.
The problems (besides the Grub issue) I have is when the system boots up in 12.04 3.2.0-24-generic, it's totally useless. Have no control whatsoever and all menu options are gone.

Now booting my system and pressing the arrow down key 3 times I get a working system, but it's LTS 12.04 3.0.0-16-generic.
Here all seems fine. There is however one difference and that's the video driver. In the 3.2.0-24 installation I did add the recommended NVIDIA accelerated graphics driver. As far as I recall after this driver install the system became useless.

Under the 3.0.0-16 installation this driver is not active and possibly this is why this image does work well.
Any suggestions on how to remove this NVIDIA driver under 3.2.0-24, considering that this image is totally unworkable. Or in other words is there a way I can change the video driver settings in 3.2.0-24 while being in 3.0.0-16?

Looking forward to hearing your suggestions!

And last time I also had issues with the GRUB menu not showing up and I fixed it by changing the resolution to 800x600 in a piece of software called the startup manager (details in thread 1930252). Unfortunately this software does not exist anymore for 12.04 Any other way to change the screen resolution in GRUB?

Again many thanks

May 25th, 2012, 01:15 PM
Hello Darkod,

with a lot of fiddling I managed to un-install the NVIDIA driver under 3.2.0-24. And I have my system back! All functionality is restored.
Clearly the 'recommended' NVIDIA driver created the main problem here.
I do get Compiz errors but they don't seem to interfere with activities on my system.

The only issue left is the GRUB problem. GRUB is there, but it does not show any screen at startup. I tried to change the resolution by Change the value of GRUB_GFXMODE= 800x600 in /etc/default/grub. And afterwards I did run upgrade grub, but it did not fix anything.
I would suggest to close this thread and keep the 1978055 open as that one is about the GRUB issue.

May 25th, 2012, 02:41 PM
Do you have dual boot or only ubuntu?

If you have only ubuntu the grub2 boot menu doesn't show, because there is only one OS so nothing to choose from.

By holding Shift at boot, after the bios POST finishes, you can get the grub2 menu to show.

Otherwise it boots ubuntu directly, the main entry, when there is only ubuntu OS.

May 25th, 2012, 04:36 PM
Hello Darko,

I have on my machine Windows 7 and Ubuntu.
Tried to boot up and hold down the shift key just after the POST finishes but it does not come up with any visible menu.
The annoying thing is that GRUB is there since if after the POST I push the arrow down key 9 times I boot up in Windows 7.
Pressing it 3 times I get 3.0.0-16, doing nothing it goes into 3.2.0-24.
As you can imagine this is a little bit a cumbersome way of working.
I did change the resolution in the /etc/default/grub but that did not do the trick. With 11.0 this did help and made the menu visible just after POST.

I am a little stuck here.
BTW how can I see what version of GRUB I use and would it make sense to upgrade to GRUB2 if I am using the old version?
Again thanks for the support

May 25th, 2012, 06:19 PM
After making the change in /etc/default/grub, did you run update-grub?

sudo update-grub

This is needed to create updated grub.cfg file.

May 25th, 2012, 11:25 PM
This one still has me stumped.
I had been running Ubuntu 11.10 since I it came out and I've been running Ubuntu since 8.04 when I dropped MS. This is on a single system, no multi-boot involved. When I upgraded to 12.04 (using update manager) my system became unstable to the point of useless and then it crashed completely. When I tried to re-install it would reach the point of file system set up and then just stop with a cannot write to the drive error. I completely slicked (blew away ALL the partitions) the HDD and tried to reinstall but it failed at the same point. I then deleted the partition and installed Windows XP on it with no trouble. I did these attempts on two completely different HDD with the same results. My system is a 32 bit and all the hardware was the same as the original running 11.10 except for the second HDD attempts. SO, now I’m running Windows XP just fine except I HATE MS ANYTHING!!!!! I WANT MY UBUNTU BACK!!!!!! ](*,)](*,):confused::confused::confused::confused:

May 26th, 2012, 01:53 AM
When the system is booting up (from a live CD if not the actual install), one of the first screens you see has a little keyboard and a man at the bottom. As soon as this appears, hit any key and you should be able to select language. From there, hit [F6] and there should be a popup menu allowing you to toggle "nomodeset" for this session. Use [ESC] to close the menu when done and proceed with the boot. That should get you into a working non-blackscreen desktop (even if that of a live CD) and from there you can at least play with things.

I'm thinking Ubuntu have made a mistake in upgrading the graphics to hi-res on the boot loader. It's not Nvidia friendly and there are a lot of people getting black screens thinking their graphics drivers are bad and trying to "fix" them blind.

May 26th, 2012, 09:08 AM
Coming back to Darko's question, I did run the sudo update grub command after changing the menu.lst file. It executed without any problem, however the result is still an invisible GRUB menu at start-up.
With respect to the other comments I believe that one should be very reluctant upgrading to 12.04 in combination with using the recommended NVIDIA driver.

I welcome any input or suggestion on getting the GRUB menu visible


May 26th, 2012, 09:20 AM
Hold on, what menu.lst file? menu.lst was used in grub1, not in grub2. Are you still using grub1 or maybe a mix of grub1/grub2?

Ubuntu comes with grub2 since 9.10.

If you look in your /boot/grub folder, what files do you have?

May 28th, 2012, 11:31 AM
Problem solved. Reinstalled GRUB and played with the menu.lst file which finally gave me the GRUB menu back after the POST.
Thanks for the help!

June 2nd, 2012, 12:24 AM
I welcome any input or suggestion on getting the GRUB menu visible

Try holding the [Shift] key.