View Full Version : [SOLVED] 12.04: Chromium believes (incorrectly) it is not default browser

May 23rd, 2012, 12:52 AM
After upgrading 11.10 --> 12.04, Chromium insists on nagging at each start that it is not the default browser. It is the default browser:

~/.local/share/applications$ cat mimeapps.list

[Default Applications]

The default is functional: clicking on a link in email starts Chromium.

However, chrome://settings/browser shows Chromium as not being the default. Clicking on Make Default appears to set it as default, but restarting reverts back to not being the default.

Strange and annoying.

May 23rd, 2012, 01:03 AM
Solved (but without a real cause:effect relationship). While composing the original message, the last thing I did was to click "Make Chromium Default Browser." Contrary to the past weeks' experience, this time the setting stuck. Huh....

Only thing I can think of is that one of the recent updates has fixed this effect for me, and I didn't discover that it was fixed until I decided to post about it. Typical.