View Full Version : [ubuntu] 12.04 desktop x64 and Raid1 arrays

May 18th, 2012, 01:51 PM
Tried both alternate as live CD, both seem to fail when using either software raid as fake raid.
That is with 1 ext4 partition as root+boot and 1 swap with 2 disks mirrored.
The guides on the wiki seem outdated too.
Why has it to been pita to do this on Linux anyway? It's 2012, this has been childs play on Windows for ages.

May 18th, 2012, 02:01 PM
Does it show any particular error?

Usually with software raid it works very good. Note that in that case you need the sata mode in bios to be AHCI, and possibly to remove any traces of raid meta data from the disks so it's not confused whether you are trying to use fakeraid or software raid.

Can you explain more where exactly is the software raid failing for example? If you don't plan to dual boot it's better to go with the software raid anyway.

May 18th, 2012, 02:14 PM
The system is a HP workstation that only gives the option between RAID and IDE mode on the BIOS side.
I did take the disks out of the fake array before switching to IDE, then with the alternate install disk, I created 2 partitions, one ext4 for \ (root) w. boot flag and another for swap after which I added them to MD arrays. (followed a guide with images) https://help.ubuntu.com/community/Installation/SoftwareRAID
After installation, disk removal and reboot I just get a blank black screen, which means that the installation did not mount something correctly.
That is p.i.t.a, with Win 7 it would have been up running even without a lot of additional steps.
I'm currently giving it another go, tried something different this time instead of following wiki and guides.

May 18th, 2012, 02:17 PM
A black screen might mean video issue too. Do you have nvidia by any chance?

May 21st, 2012, 07:44 AM
A black screen might mean video issue too. Do you have nvidia by any chance?
Negative,ATI, although issue concerns dev mount point, can install and run the distro with a single hdd.

EDIT: Got it to work now after a failed faikeraid installation.
The installation did detect my two disks as a single disk this time :o