View Full Version : [ubuntu] Apt-Cache fails on the clients

May 16th, 2012, 06:19 PM
Server: Ubuntu 12.04 running apt-cache as shown in this doc:

Client: Ubuntu 12.04 (And hopefully 11.10 clients) With 01proxy method to use apt-cache.

Appears to be a issue with apache since I get a 403 error, and also can't verify the apt-cache with server:3142

Ign http://us.archive.ubuntu.com oneiric-proposed/universe Translation-en_US
Ign http://us.archive.ubuntu.com oneiric-proposed/universe Translation-en
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/oneiric/partner/source/Sources 403 Access to cache prohibited

W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/oneiric/main/source/Sources 403 Access to cache prohibited

May 17th, 2012, 01:59 PM
I'm having the same issue. The server running apt-cacher was recently upgraded from 11.10 to 12.04 after which I started getting this error. Clients are still running 11.10... I was hoping to be able to upgrade the clients using the cached packages from the server, but I'm getting this same error.

May 17th, 2012, 04:29 PM
Ok, still no solution, so I installed the apt-cacher on a 11.10 client system. Setup DNS to point apt.mydomain.com to that system...

Once I get this fixed on the 12.04 server, I'll just change the DNS entry for apt.

May 31st, 2012, 07:09 PM
Ok - seems like I've sorted it. In my /etc/apt-cacher/apt-cacher.conf, I commented out the 'group' and 'user' settings which by default use www-data. Once I commented them out and restarted apt-cacher service, the client was no longer having the access prohibited error.

Hope that helps anyone else having the same issue.

June 15th, 2012, 11:06 AM
I have the same problem,
your solution don't solve my problem,
i solve it with
uncomment "allowed_hosts = *" in apt-cacher.conf

July 30th, 2012, 08:41 PM
Tried both of the apt-cacher.conf fixes above (group, allowed hosts) and neither one solves my problem.

July 30th, 2012, 10:15 PM
Mine is now working. In /etc/apt-cacher

apache.conf:Alias /apt-cacher /usr/share/apt-cacher/apt-cacher-cgi.pl
apache.conf:<DirectoryMatch /usr/share/apt-cacher/>
apache.conf: Options ExecCGI
apache.conf: AddHandler cgi-script .pl
apache.conf: AllowOverride None
apache.conf: order allow,deny
apache.conf: allow from all

apt-cacher.conf:allowed_hosts = *

October 27th, 2012, 11:35 AM
Don't forget to check your allowed_hosts configuration in /etc/apt-cacher/apt-cacher.conf file.
cf: http://www.debuntu.org/how-to-set-up-a-repository-cache-with-apt-cacher
Perhaps default settings change with an upgrade.

November 1st, 2012, 02:17 PM
Thank Agone!

i solve it with
uncomment "allowed_hosts = *" in apt-cacher.conf