View Full Version : [ubuntu] 12.04 upgrade issues

May 9th, 2012, 12:51 PM
I was trying to upgrade from 11.10 to 12.04. Basically it completely ruined my system. Somehow I got back most of it. Currently I have Windows 7 running in sda. Failed Ubuntu 12.04 at sdb. I'm able to dual boot into both Windows and Ubuntu without any problems. But Ubuntu is completely broken that it doesn't even have the network, display is not working etc.
I'm trying to boot using my old 11.10 installable DVD and manually mounted the Ubuntu partition (sdb), and tried to run a apt-get upgrade after chrooting, but it fails. Is this even possible to fix it this way?
I get error like "Failed to fetch http://au.archive.ubuntu.com/ubuntu/pool/main/u/update-manager/update-manager-core_0.152.25.9_amd64.deb Something wicked happened resolving 'au.archive.ubuntu.com:http' (-5 - No address associated with hostname)".
But I'm able to ping au.archive.ubuntu.com and able to browse it using the browser. Could someone please help me to get out of this mess?

May 9th, 2012, 01:25 PM
Hold on. Did the upgrade process finish completely or it was stopped (power failure, freeze, etc)?

If it got stopped in any way, you can try entering again with chroot and:
dpkg --configure -a

That will finish off configuring any pending packages.

May 9th, 2012, 01:45 PM
Thanks for the quick reply. The upgrade finished successfully and asked me to reboot. When I clicked the reboot nothing happened for a while. Guess I waited for about 30 minutes. Couldn't hear anything on my hard disk. Even the reset didn't work. So I had to power off the machine and then started and after that only I ran into this problem. Let me try your suggestion and then update.

May 9th, 2012, 02:00 PM
OK, I have executed "sudo dpkg --configure -a" and it immediately returned to the command prompt. And all the given problems remain.

May 9th, 2012, 02:18 PM
Sorry, I'm out of ideas. If the upgrade finished, it might be one of those cases where it simply went wrong.

Maybe someone else has more ideas and can give you some commands to troubleshoot.

PS. Did you try changing the default server for updates? I know you said you can ping it, and updates don't work. It's worth trying with another server.

May 10th, 2012, 02:40 AM
No worries darkod. Thanks once again for your help anyway. May be I'll give it another try by changing the repositories. Currently there are entries for past 3 or 4 distros. May be it needs some cleaning.
For every upgrade I seem to run into some sort of problem and finally I solve it by re-installing. This time I was desparate to break it but it was not to be it seems. Unless someone has any idea I'm doing a fresh install today evening.

May 10th, 2012, 02:48 AM

sudo apt-get -f install

Personally I back home and clone my OS to have a full backup.