PDA

View Full Version : [ubuntu] Unusable desktop after 11.10 -> 12.04



samuelpenn
May 5th, 2012, 06:38 PM
I have a Lenovo Z570-1 laptop, which cam pre-installed with
Ubuntu 11.10 and 12.04 BETA (two partitions). Both worked fine.

I've tried upgrading the 11.10 install (my main installation, and
the one with all my data and configuration on) to 12.04 LTS, and
now the install seems to be somewhat borked.

It boots, but the login screen has broken icons on the top right,
and a black backdrop (it was an image in my home directory). I
can login, but what I get is a black screen, a time at the top
right (which works correctly) and a set of blank icons down the
left hand side (as per standard Unity, except they are blank).

The mouse doesn't work. Ctrl+Alt+T doesn't give me a terminal
session. Alt-F1 (etc) gives me a blank screen instead of a
console login.

The beta 12.04 install still works, it's just the 11.10 install
that is broken.

Home directory in 11.10 was encrypted before the install, but
otherwise it's a pretty standard Unity setup.

I'd very much like to recover this without having to do a
re-install. Does anyone have any ideas what to try?

Thanks,
Sam.