PDA

View Full Version : HOWTO: Broadcom 4318 Wireless Cards



Pages : [1] 2 3 4 5 6 7 8

compwiz18
June 15th, 2006, 02:10 PM
Hardy

This process is vastly simplified in Hardy. The easiest way to do it is to open the Hardware Drivers program (go to the System menu in the top left corner of the screen, and click Administration, and then Hardware Drivers) and check the Broadcom B43 wireless driver box, and reboot.
Done. :KS

A couple of notes about that procedure:

It installs the b43 driver, which is semi-open source. The b43 driver works decently and will cover most peoples' wireless needs, and is easy to setup. However, you can also choose to use ndiswrapper, which will provide you with a slightly faster connection. For information on how to set that up, see http://ubuntuforums.org/showthread.php?t=766560.

Those of you using WEP may also want to note:

However, you may want to mention that there seems to be a bit of a bug with the way NetworkManager handles WEP + DHCP.

(See here https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/139812)

The bug made me (and I suspect may make others) think that their card isn't working, when in fact it is.

To work around and get WEP going, you can do the following:

sudoedit /etc/network/interfaces
add the line
iface wlan0 inet dhcp

then, to get the network up, do the following (replacing $ESSID and $KEY with the proper ESSID and key):

sudo iwconfig wlan0 essid $ESSID key $KEY sudo ifup wlan0

About

The information below is for versions of Ubuntu older then Hardy (Gutsy, Feisty, Edgy, Dapper)

This HOWTO is for people who have a Broadcom 4318 Wireless card in their laptop. This card can sometimes be a bit ;) difficult to setup, so I have provided a working method (for me, anyway).

To check if you have a Broadcom 4318 Card, open up the terminal (click the Applications button, then Accessories, and then Terminal) and run (just copy and paste the code from the code boxes throughout the HOWTO )

lspci | grep Broadcom\ Corporation
If your output looks similar to

0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
or you can see the string BCM4318 in the output, then this should work for you.

Please note that this was really designed to be run on a [I]very fresh install, right after Ubuntu has come up for the first time. It is mostly likely to work then. If you have tried other attempts at making this card work, I have no promises for you, but it only takes two minutes, so it is worth a shot (most people can get it to work, even on a not-so-fresh install).

The point of this HOWTO is to make it as simple as possible (not to educate people - if you want to know how this works, open the script and read it) for people who have just installed Ubuntu for the first time, so I wrote a script and have provided a set of drivers that worked for me. Not all drivers will work with ndiswrapper, so please use the ones I have provided.

The script requires no internet connection after it is downloaded...all required files are on the CD you installed Ubuntu with, and the package manager should recognize this.

Feisty and Gutsy

If you post for help, please post the log file, which can be found on your Desktop after you run the script.

You have two options (I'll try and outline them for you):


Use the native bcm43xx driver. This driver is open source and included with the kernel. It can not run at any speed higher then 11mbps, is some what flaky, and supports promiscuous mode. Requires user to be somewhat close to the access point. Is a bit easier to install.

To use the native bcm43xx driver:
Download http://ubuntuforums.org/attachment.php?attachmentid=30328&d=1177147133 and double click it to install. Reboot. Enjoy wireless. (this should work, but if for some reason it fails, see the troubleshooting)
Use ndiswrapper. ndiswrapper is open source, however the driver is not. It can run at 54mbps, is stable, and does not support promiscuous mode. I have had some trouble with it and hidden networks. Supports a large distance from the access point.

If you aren't sure what to use and just want wireless, I suggest ndiswrapper (option 2) See section Dapper and Edgy (and Feisty/Gutsy with ndiswrapper) below.

Dapper and Edgy (and Feisty/Gutsy with ndiswrapper)


Put the CD that you installed Ubuntu with in the CD drive.
Download this file (http://ubuntuforums.org/attachment.php?attachmentid=48087&d=1193544558) to your Desktop (the Firefox default, so if you haven't changed it, that's where it went/will go).
Open a terminal (click the Applications button, then Accessories, and then Terminal)
Change the current directory to the desktop (copy and paste the following commands exactly into your terminal by right clicking anywhere on the terminal and clicking paste)

cd ~/Desktop
Extract the compressed file

tar -xf bcm4318*.tar.gz
Run the script, which will install ndiswrapper on your system, and set it up.

sudo ./ndiswrapper_setup
Use the internet (you will have to open the System menu at the top of the screen, go to Administration, and then click Networking. Configure the interface eth1 or wlan0, and connect to your wifi network)
If you are an Acer user, you will need to use the acerhk driver (http://ubuntuforums.org/showpost.php?p=2999631&postcount=1595).
If it doesn't work, reboot.
If that doesn't work, read the troubleshooting section below.
If you still can't make it work, try reading this post (http://ubuntuforums.org/showpost.php?p=1189681&postcount=105) by The Raven, which is so long I can't even fit it in here without doubling the length of the post =D>



Troubleshooting


If the normal Feisty method fails, try the Edgy/Dapper method. It also has support for Feisty using ndiswrapper.
Try
sudo ndiswrapper -a 14e4:4319 bcmwl5 and then

sudo rmmod bcm43xx
sudo rmmod ndiswrapper
sudo modprobe ndiswrapper

If the light doesn't come on, try:

sudo apt-get install ndiswrapper-utils-1.8 ndiswrapper-utils-1.1 ndiswrapper-utils ndiswrapper-common
If you are using 64bit Edgy Eft and the 2.6.17-10-generic, make sure you are NOT using the 2.6.17-10-generic kernel as it doesn't work (after running the script, you will be warned if there is a problem). If you need help finding a different kernel, check here (http://ubuntuforums.org/showpost.php?p=1705658&postcount=668).
If you have issues with Network Manager, make sure that all lines in /etc/network/interfaces that have anything except the word (interface) LO in them are commented out (have a # in front of them) or do not exist (the installation script should have removed them)
If you are having issues, try running, in this order, one at a time:


sudo rmmod bcm43xx
sudo rmmod ndiswrapper
sudo modprobe ndiswrapper
sudo ifdown eth1
sudo ifup eth1
sudo dhclient

If you get the error "The NetworkManager applet could not find some required resources. It cannot contine.", run:


sudo gtk-update-icon-cache -f /usr/share/icons/hicolor/

If you are using Edgy, try enabling the Universe and Multiverse, then run the script again.
If, when you turn your computer on, Network Manager asks for your password, and then sits there and twirls, but doesn't connect, and eventually times out, and THEN will connect, try removing wifi radar (or another wireless manager if you have one)

sudo apt-get remove wifi-radar
OR

sudo apt-get remove NAME-OF-YOUR-WIFI-MANAGER
Try reading this post (http://ubuntuforums.org/showpost.php?p=1189681&postcount=105), which is incredibly long and very helpful
If you want to know how to remove it, either (a) read the script and undo what it does, or (b) post a message here and I will write an undo script for you, or (c) reinstall Dapper.
Make sure that the card is enabled in the BIOS.
If you've got a HP dv8000 series that doesn't work quite right, or even if you don't and have run out of ideas, try http://www.ubuntuforums.org/showpost.php?p=1553528&postcount=432


Mirrors

There are all obsolete (but I'll leave them here in case anyone needs them for any reason):
32-bit: http://www.box.net/public/hp6kr9np9o
64-bit: http://www.box.net/public/sxt8yivhef
32-bit with network manager: http://www.box.net/public/xsu1aa260d
64-bit with network manager: http://www.box.net/public/n9xc7jjxxj
32-bit drivers for Edgy: http://www.box.net/public/9ru8h47pdd
64-bit drivers for Edgy: http://www.box.net/public/x1qqgyu1yb
32-bit setup for Edgy: http://www.box.net/public/drxcbfej8l
64-bit setup for Edgy: http://www.box.net/public/oy219x8mlz





Posting for help

If you post for help here, please attach the log file, which will be on your Desktop after you run the script, to your post. Make sure you wrap your log file in

log-file-goes-here tags, which makes reading the log file much easier.


Updates


EDIT: This was updated on June 20, 2006 to make the size smaller, and include ndiswrapper so that an internet connection is not required. Also, some steps were removed from the installation process.
EDIT: This was updated on June 21, 2006 to add a 64-bit version (thanks redmoth!) and to make a few minor changes.
EDIT: This was updated on June 22, 2006 so that now it supports network manager AND WPA encryption (use WPA supplicant) -thanks magomago!
EDIT: This was updated on June 28, 2006 to add some troubles and answers from the thread, up to page 11. I'm not promising I got everything, but most of it.
EDIT: This was updated on July 7, 2006 to include a GTK enabled C++ application that will automatically install the drivers WITHOUT use of the terminal. If you run the program from a terminal, additional output will be visible. This requires internet access, but looks really pretty :P
EDIT 2: That didn't work out, so I removed it. If you still wanna give it a go (you need gtkmm installed), download the bcm4318.gtk.tar.gz attachment.
EDIT: This was updated on August 7, 2006 to include a new and improved i386 (NOT AMD64) script that will actually work on the LiveCD now, I believe. Thanks iandefor!
EDIT: This was updated September 2, 2006 with some awesome new features. The network-manager-gnome setup should now actually work correctly on a fresh install. The script that includes network-manager-gnome will automagically connect to the internet using your nearest wifi hotspot or an ethernet connection if you're plugged in. The 64bit drivers are also updated and should work right now (I can't say if they do, as I don't have a 64bit Ubuntu to test them on)
EDIT: This was updated September 3, 2006. All versions of the program are now distributed under the GPL.
EDIT: This was updated September 21, 2006 to include a link to another howto for HP dv8000 series laptops.
EDIT: This was updated September 30, 2006 to include directions for Edgy.
EDIT: This was updated October 4, 2006 to include scripts for Edgy.
EDIT: This was updated October 28, 2006 so that there is only one script, which takes care of all arches and versions.
EDIT: This was updated March 13, 2007 to add a link to the Feisty installation information. Sorry, no script yet.
EDIT: This was updated April 20, 2007 to add the script for Feisty support, in case the .deb method fails.
EDIT: This was updated July 2, 2007 with an updated script (thanks LowMemory!)
EDIT: This was updated April 18, 2008 with instructions for Hardy.

Comments and suggestions are appreciated.

tabgilbert
June 16th, 2006, 03:30 AM
>The point of this HOWTO is to make it as simple as possible....

You achieved your goal.....thank you very much......

revilot
June 16th, 2006, 04:30 PM
Getting ready to try this. Does it install ndisrapper from the ubuntu install cd or do I need to be connected to the internet? Thanks.

revilot
June 16th, 2006, 07:02 PM
Ok...I tried this out. Had to connect with my wired NIC and enable the extra repositories to det ndiswrapper. My light didn't light up so I thought it didn't work, but when I rebooted it came on. I get the green bars in the toolbar but I can't laod any websites. Firefox just sits there and says something like locating page or loading page, something like that. I've got WEP setup on my router and properly entered in network properties and everything. I'm not sure why I can't view any sites. Any ideas?

Thank for this script. This is the closest I've come to getting wireless to work on my laptop (compaq v2508wm). I feel like I'm one step away from getting it to work completely.

Any help is appreciated.

**EDIT

I rebooted back into Ubuntu and now it's working. I'm not sure what happened but I'm posting from Ubuntu now thanks to compwiz18. Much appreciated. Only took me about a week to get it working ;).

Now I'm scared to install all the updates it's telling me are available for fear it will screw something up.

compwiz18
June 17th, 2006, 11:39 AM
I updated the guide to reflect comments and questions, so now it should be easier to use.

Sakol
June 17th, 2006, 10:45 PM
Thanks so much for the help! I was slightly discouraged when my wireless stopped working after I upgraded Breezy to Dapper, but it's working perfectly now.

spesheled1
June 18th, 2006, 07:59 AM
This did the trick with my Dell Inspiron B120 laptop. Thanks for the great info!:-P

szweda83
June 19th, 2006, 02:58 AM
My Presario V2000 works with these drivers... Thanks for your help!
-Brad

biggreensupreme
June 19th, 2006, 03:15 AM
Got mine working but can't see it in network manager. Anyway to use something other than wep? Maybe because it is marked as eth1 instead of wlan in network settings?

compwiz18
June 19th, 2006, 04:34 AM
Got mine working but can't see it in network manager. Anyway to use something other than wep? Maybe because it is marked as eth1 instead of wlan in network settings?

I couldn't figure out how to make network manager work. But if someone did with this script, and posts the instructions here, I will add the steps to the script so that it is automatically configured as well.

teryret
June 19th, 2006, 06:22 AM
Your method looked really promicing, it got me much closer than the others in that ndiskgtk now acknowledges that the hardware is present and it gets an IP address. Unfortunately I still can't get online (or even ping out), even on a wire. If I disable eth1 (formerly wlan0) eth0 suddenly starts working again. Any ideas? If it helps, this wasn't the first thing I tried to make it work.

I appreciate the help in advance.

compwiz18
June 19th, 2006, 11:38 AM
Your method looked really promicing, it got me much closer than the others in that ndiskgtk now acknowledges that the hardware is present and it gets an IP address. Unfortunately I still can't get online (or even ping out), even on a wire. If I disable eth1 (formerly wlan0) eth0 suddenly starts working again. Any ideas? If it helps, this wasn't the first thing I tried to make it work.

I appreciate the help in advance.

Can you run iwlist eth1 scan in a terminal, and also iwconfig? And post the results please? As for eth0 suddenly working when you disable eth1, try changing the default gateway interface:
http://static.flickr.com/67/170368610_10d2b4619c.jpg?v=0
by selecting eth0...that might fix it.

Hope this helps.

teryret
June 19th, 2006, 12:53 PM
Good to call me on the default gateway, because sometimes it is the simple stuff, but this time I think it was just me going faster than the computer could apply changes, and it got bogged down. That part is working now.

As for the output of those two commands, they look to the untrained eye to be symptoms of a correctly configured card. The only problem is that it just doesn't like to ping anywhere or look at any website. Since I most recently enabled eth1
I have sent 9 packets according to the connection properties... that seems low given the number of times I submitted http requests to test it.



matt@matttop:~$ iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:0F:3D:37:DB:7B
ESSID:"KeepOff"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:0/100 Signal level:-80 dBm Noise level:-256 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

matt@matttop:~$ iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"KeepOff"
Mode:Managed Frequency:2.437 GHz Access Point: 00:0F:3D:37:DB:7B
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:100/100 Signal level:-83 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

matt@matttop:~$


Edit: and one other observation, it's reading out at 100% signal quality, regardless of whether I'm a meter from the WAP or my current position of across the house in the basement (where Windows tells me the signal is weak).

compwiz18
June 19th, 2006, 12:58 PM
teryret - it looks like you have it configured right...do you have some sort of MAC filtering enabled, or something else? static ips?

teryret
June 20th, 2006, 01:17 AM
Nope, no security whatsoever, and it does get a valid IP from DHCP, it just doesn't know what to do with it. Plus, the laptop is dual booting with vista and it works flawlessly (same MAC, and usually the same IP too).

Even if there were some sort of filtering going on, wouldn't the counter show more than just 9 packets sent?

Edit: Also, why would iwconfig and iwlist disagree about the link quality?

compwiz18
June 20th, 2006, 01:56 AM
Now I'm having the same problem. Connects, gets an IP, but won't download any pages. I can ping the router though, at 192.168.1.1 . Works great in XP, but just won't work in Ubuntu. On the other hand, I have 128 bit encryption...this might be part of the problem. Should probably turn that off before I try to fix this.

If there is someone else out there who knows how to fix this, speak up :D Any help is appreciated.

teryret
June 20th, 2006, 02:51 AM
Great, I'm conceptually contageous, the mere thought of this type of problem causes it... Quick, to the placebo store, I heard they just found a cure.

In any case, mine is back to not letting me online when I have the wireless card turned on, despite eth0 being plugged in and the default gateway.

I don't think the encryption matters, because I've currently got the box over at a friend's house and his 64 bit WEP is doing the same thing as my unencrypted wlan and your 128 bit one.

s2k
June 20th, 2006, 03:03 AM
Nope, no security whatsoever, and it does get a valid IP from DHCP, it just doesn't know what to do with it. Plus, the laptop is dual booting with vista and it works flawlessly (same MAC, and usually the same IP too).

Even if there were some sort of filtering going on, wouldn't the counter show more than just 9 packets sent?

Edit: Also, why would iwconfig and iwlist disagree about the link quality?


Ok now i am having the exact same problem. ](*,)

revilot
June 20th, 2006, 03:05 AM
Mine is still working, but one thing I've noticed is sometimes when I boot up it hangs on configuring network devices. It finally turns my wireless light on but when it boots up it won't connect. I have to reboot, then it has connected everytime (knock on wood). I've broken the connection twice now by screwing around with different things trying to learn Linux, but I just run this script again and it fixes it.

If anyone would like me to post any settings I'd be glad to. Just tell me what you'd like to see and I'll do my best. Keep in mind my experience with Linux is about 1 week old.

s2k
June 20th, 2006, 03:18 AM
....but I just run this script again and it fixes it....


What is this "script"? :confused:

teryret
June 20th, 2006, 03:25 AM
Ok now i am having the exact same problem. ](*,)

Muahhahahahaha, now you will all taste my disease! It's like spoiling a movie, you can't unlearn it!

I'm going to try the 2.6.17 kernel thanks to the /. story, I'll let you guys know how it goes.

s2k
June 20th, 2006, 03:34 AM
Ok i think i have a new finding. when i have a wired connection to my router and im viewing a site such a google images and i disconnect the plug from my laptop i notice that if i click links in the same site the page loads and packets are being sent and recived on the wireless connection. But i cannot go to sites such as yahoo.com, gamefaqs.com.....

revilot
June 20th, 2006, 04:39 AM
What is this "script"? :confused:

Maybe I should have said this "procedure".

teryret
June 20th, 2006, 08:42 AM
Yeah, I'm way too much of a noob to deal with 288 warnings/errors. 2.6.17 is going to have to remain a mystery for the time being.

Great news, I got it! My steps were fairly simple.
Step 0: Make sure it's plugged in (to the wired lan).
Step 1: Format the hard drive and re-install from the Dapper 6.06 disk.
Step 2: Run the script from the tarball per your instructions in the first post
Step 3: Enable eth1 in the Networking admin tool.
Step 4: sudo apt-get install network-manager-gnome
Step 5: Reboot.

Edit:
Step 6: Install automatix and begin running it.
Step 7: Notice that it gets stuck mid download (side effect of a fickle signal and an installer that doesn't retry anything) and attempt to jump start it by pressing the "enable/disable wlan" button on the keyboard twice. Noting that the software connection strength meter dropped to zero when I pressed it the first time then never came back.
Step 8: Disable then re-enable eth1 in the Network admin tool, noting that the signal strength meter returned to it's normal (albiet probably incorrect) 100%. Also noting that it won't surf the internet... or ping out... but it did have a good IP and a signal.
Step 9: Cry, then simultaneously pray and reboot.
Step 10: Wonder why gnome locks on bootup.
Step 11: GOTO step 0.

s2k
June 20th, 2006, 02:02 PM
Yeah, I'm way too much of a noob to deal with 288 warnings/errors. 2.6.17 is going to have to remain a mystery for the time being.

Great news, I got it! My steps were fairly simple.
Step 0: Make sure it's plugged in (to the wired lan).
Step 1: Format the hard drive and re-install from the Dapper 6.06 disk.
Step 2: Run the script from the tarball per your instructions in the first post
Step 3: Enable eth1 in the Networking admin tool.
Step 4: sudo apt-get install network-manager-gnome
Step 5: Reboot.

Edit:
Step 6: Install automatix and begin running it.
Step 7: Notice that it gets stuck mid download (side effect of a fickle signal and an installer that doesn't retry anything) and attempt to jump start it by pressing the "enable/disable wlan" button on the keyboard twice. Noting that the software connection strength meter dropped to zero when I pressed it the first time then never came back.
Step 8: Disable then re-enable eth1 in the Network admin tool, noting that the signal strength meter returned to it's normal (albiet probably incorrect) 100%. Also noting that it won't surf the internet... or ping out... but it did have a good IP and a signal.
Step 9: Cry, then simultaneously pray and reboot.
Step 10: Wonder why gnome locks on bootup.
Step 11: GOTO step 0.

THANK YOU!!!111
im not sure exactly what i just did but it seemed to have worked. Im using automatix right now over my wireless connection...=D> .....but i hope to god this works when i restart:confused:

compwiz18
June 20th, 2006, 02:24 PM
Edit: Didn't see the third page, some of this is repeated.
Edit 2: You can edit /etc/modules and add ndiswrapper to the bottom...I will update the script to do that automatically. This fixed a few problems, such as running the dumb thing at every boot.


I WIN :D
Ok, so it appears that there was an update maybe? that everyone downloaded that broke it. Anyways, running dhclient fixed it for me :D

I did, in this order, all as superuser



modprobe ndiswrapper
[push wifi button on computer - it didn't light up, pushing it fixed it]
ifdown eth1 [where eth1 is the network interface]
ifup eth1
dhclient


If your ISP gave you DNS servers you have to use, add them in the network manager under the DNS tab.

Otherwise, it should work :D

s2k
June 20th, 2006, 03:02 PM
YAY!! It works.

mike4ubuntu
June 20th, 2006, 03:49 PM
Thanks, it works.

I had to run dos2unix on the ndiswrapper_setup script file for some reason. Not sure if anybody else had to do that. I also had to execute

$ sudo ifdown eth0
to stop the wired lan port since it was set as the default gateway. After that it seems to work fine.

Not why the wl_apsta.o nor bcmwl5.sys don't don't work directly. I'm going to try to keep working with that too to see if I can get it to work. I think there actually included in the 2.6.17 kernel.

The Network Manager Applet doesn't seem to work now. Possibly because the wireless lan is now identified as wlan0 instead of eth1. I can live with that for now.

Has there been any discussion on somehow making netowrking automaticlly select the best lan for the gateway?

?????
June 20th, 2006, 06:57 PM
This works great.. been using it for about a week with no problems.. but you could make it even easier by including ndis with the script ;)

compwiz18
June 20th, 2006, 07:46 PM
That would be nice...but there is a ~800kb size limit on files, and the drivers are rather large - about 75% of that. Maybe I'll try later...
EDIT: It is updated. Have fun.

compwiz18
June 21st, 2006, 12:22 AM
OK, I updated the script. I removed extra driver files that you don't need, added ndiswrapper to the tarball so you don't need an internet connection to install, had the script automatically add ndiswrapper to /etc/modules (this should load it at startup, fixes a couple problems), AND I updated the steps to make it easier to install :D

redmoth
June 21st, 2006, 02:38 AM
I followed the instructions after downloading the newest tarball (jun 20,2006) for a Compaq v2000 with the BCM4318 wireless chipset. Keep in mind that this laptop does have an AMD Turion64 processor, though I do not know if this will make a difference. However, after running the script, the wireless light did not light up...so I rebooted, but it did not help. I verified that after the reboot the ndiswrapper was loaded as a module using

modprobe -l |grep ndiswrapper

also i verified that that ndiswrapper loaded a driver using

ndiswrapper -l the output of which was

bcmwl5 driver present, hardware present

after the reboot, the wlan0 interface (which was previously there) does not show up in the Network Interface Manager, and only eth0 (the wired interface) remains. Also, the iwconfig command does not indicate any interfaces that have any wireless extensions, nor does it show up in ifconfig.

Im a bit lost...Any ideas as to what to try next? I am going to attempt to look at the windows installation that is on the laptop, then see if I can get a copy of the files it is using as a driver for the chipset, then hopefully, get ndiswrapper to install those...

Any suggestions extremely welcome!

thanks,
-rob

compwiz18
June 21st, 2006, 02:50 AM
I have a v2000 too...it worked for me. Are you using the 64bit version of Ubuntu? Oh yeah...also, pushing the button worked for me..it lit up and then everything was good.

xolot1
June 21st, 2006, 02:53 AM
your script worked flawlessly for one reboot, now im having trouble.



after the reboot, the wlan0 interface (which was previously there) does not show up, and only eth0 (the wired interface) remains. Also, the iwconfig command does not indicate any interfaces that have any wireless extensions, nor does it show up in ifconfig.
-rob

i may have the same problem (but im a slight newbie, so i may be confusing errors). my eth1 interface does not show up under my gnome-netstatus-applet, and nm-applet only shows my wired network. network settings does show eth1, and it being active; and iwconfig also shows eth1 as present. so probably a different error. however, my network is wpa encrypted, so ill just throw that in the mix too. suggestions?

compwiz18
June 21st, 2006, 03:13 AM
Also try sudo rmmod bcm43xx maybe?

zany
June 21st, 2006, 03:43 AM
i have a compaq v2000 running ubuntu amd64...

here's a couple concerns i have:

a) does this work for amd64 installs of ubuntu?
b) when i run ndiswrapper, it states that bcmxx is not found in /proc/modules, how do i fix that?exit

c)i get a lot of line xx: ndiswrapper: command not found errors

thanks for your help

compwiz18
June 21st, 2006, 03:47 AM
i have a compaq v2000 running ubuntu amd64...

here's a couple concerns i have:

a) does this work for amd64 installs of ubuntu?
b) when i run ndiswrapper, it states that bcmxx is not found in /proc/modules, how do i fix that?exit

c)i get a lot of line xx: ndiswrapper: command not found errors

thanks for your help
a - not sure, i have 32 bit on a 64 bit processor
b & c - try running sudo apt-get install ndiswrapper before running the script, not sure about those 2

xolot1
June 21st, 2006, 03:59 AM
Also try sudo rmmod bcm43xx maybe?

b) when i run ndiswrapper, it states that bcmxx is not found in /proc/modules, how do i fix that?

bcm43xx does not exist in /proc/modules. (just trying to add data, my experiences since i cant really help in any other way.)

redmoth
June 21st, 2006, 04:18 AM
okay! I thought about it for just a second and looked at the output of

dmesg
and saw that up near the top when ndiswrapper is loaded that it gave an error noting that the driver is not a 64 bit driver. So I googled for it, and found a Suse post regarding a similar situation for another user for 64bit Suse. Some guy with the awesome nic GenericHuman pointed towards the 64bit drivers for the bcm4318 chipset at linuxant here:

http://www.linuxant.com/driverloader/drivers.php

what i ended up doing (after reading the script in the original attachment of this thread, and discovering that it removes any previous installations of the driver) was just repackaged the 64 bit drivers in the tarball, and reran the script according to the instructions in the original post of this thread...

needless to say I am proudly using the laptop to post this message now.

I will attach the tarball that I have recreated TO BE USED ONLY FOR 64 BIT INSTALLS WITH THE BCM4318 CHIPSET!

man, many thanks to compwiz18 for the superbly written script, and all the real groundwork!! thank you, thank you!!

-rob

zany
June 21st, 2006, 04:29 AM
thanks guys..

i'm going to keep cracking at this

it says that bcmwl5: driver present, hardware present but won't show up in network manager in ubuntu

also says

Forcing parameter IBSSGMode|0 to IBSSGMode|2 repeated several times..

looks like the driver got installed though,

not sure what the next step is...

redmoth
June 21st, 2006, 04:39 AM
zany, if you are using ubuntu64, then you want to use the attachment that i posted a few minutes ago. the drivers that are bundled in the attachment compwiz18 uploaded are 32bit only drivers and you will find that the output of dmesg will show you that it does not like that...

first, unload the driver that you installed with compwiz18's script by typing:

ndiswrapper -e bcmwl5

then use the instructions from compwiz18 with the attachment that i uploaded a few minutes ago...i _think_ that will work for you

-rob

sbergman27
June 21st, 2006, 05:48 AM
Just want to say thanks for the great script!

I would also like to add that I spent a lot of the day messing with the bc43xx driver and then ndiswrapper. And I now realize that one of the main problems was a user headspace error. In System-.Administration->Networking->Wireless Connection->Properties, the essid comes up blank by default. You have to click the drop down and select the essid and *then* activate.

airrob
June 21st, 2006, 06:31 AM
I have a Dell Latitude D610 with a Dell 1370 wireless card, which is based on the Broadcom 4318 chipset. I believe I have enabled the wireless card. However, my network runs with WPA2 encryption, but it seems that this driver only supports WEP, which is not good enough for me. How do I go about enabling at least WPA, ideally WPA2, in Ubuntu 6.06?

Sphearion
June 21st, 2006, 08:48 AM
Dell latitude 110L worked flawlessly, just ran the script and rebooted came back up no problems connected right up to my WAP..

:-({|= =D> =D> =D> =D>

zany
June 21st, 2006, 01:31 PM
redmoth,

thanks for your help. i downloaded the x64 driver but it says invalid driver. Still doesn't list the device in network devices. any ideas? i might re-install ubuntu amd64 if i get the chance...but any ideas would be greatly appreciated.

thanks,

zany.

compwiz18
June 21st, 2006, 02:01 PM
I'm gonna take the 64-bit tarball and stick it in my post so that people don't have to read the thread.

1richard
June 21st, 2006, 03:55 PM
I Have HP zv 6000 and the 4318 chip. I tried these directions and cannot get my wireless to work, it ndiswrapper it and driver loaded hardware present, iwconfig does not see it is listed as eth0 at times.

luckyjim
June 22nd, 2006, 12:17 AM
I need to thank you so much! I've had my Compaq Presario for three weeks and couldn't get my wireless to work. It's been driving me insane (and turning back to XP was NOT an option ^_~) Thanks again for taking the time to help out all us unfortunates with the Broadcom 4318.

xolot1
June 22nd, 2006, 12:27 AM
I have a Dell Latitude D610 with a Dell 1370 wireless card, which is based on the Broadcom 4318 chipset. I believe I have enabled the wireless card. However, my network runs with WPA2 encryption, but it seems that this driver only supports WEP, which is not good enough for me. How do I go about enabling at least WPA, ideally WPA2, in Ubuntu 6.06?

check out the dapper wiki
https://help.ubuntu.com/community/WifiDocs/WPAHowTo
tho wireless is not currently working on my laptop, it did for a day, and i got it working by following the directions on that wiki (wpa_supplicant, etc).
goodluck!

xolot1
June 22nd, 2006, 01:03 AM
i tried running your script again, and this time copied down the output displayed in my terminal:



./ndiswrapper_setup
Installing ndiswrapper...
(Reading database ... 108580 files and directories currently installed.)
Preparing to replace ndiswrapper-utils 1.8-0ubuntu2 (using ndiswrapper.deb) ...
Unpacking replacement ndiswrapper-utils ...
Setting up ndiswrapper-utils (1.8-0ubuntu2) ...

Extracting the drivers...
Deleting temporary files...
Changing driver permissions...
Changing working directory...
Removing previous attempts to use ndiswrapper, if any...please ignore errors in this section...
Driver bcmwl5a is not installed.Use -l to list installed drivers
Removing default driver...
ERROR: Module bcmxx does not exist in /proc/modules
Installing driver through ndiswrapper...
Installing bcmwl5
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Installed ndis drivers:
bcmwl5 driver present, hardware present
oem3 invalid driver!
modprobe config already contains alias directive

Modprobing ndiswrapper...
Moving back to original working directory...
Deleting more temporary files...
Blacklisting bcm43xx...
Adding ndiswrapper to /etc/modules, so it should load on boot...
Installation completed.
Please check the wifi light on your computer.
If it is on, installation was successful.
If it is not, reboot. If it is still not, try pressing the wifi button.
If it doesn't work, please post on the forums for help.


the light did not turn on right away, but after running the script, by pressing the button it would turn on, and now that ive rebooted, it is on.


willi@willi-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

willi@willi-laptop:~$



willi@willi-laptop:~$ iwlist eth1 scan
eth1 No scan results



willi@willi-laptop:~$ sudo su
root@willi-laptop:/home/willi# modprobe ndiswrapper
root@willi-laptop:/home/willi# ifdown eth1
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:14:a5:7a:4b:fc
Sending on LPF/eth1/00:14:a5:7a:4b:fc
Sending on Socket/fallback
root@willi-laptop:/home/willi# ifup eth1
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:14:a5:7a:4b:fc
Sending on LPF/eth1/00:14:a5:7a:4b:fc
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
mount: wrong fs type, bad option, bad superblock on //DSM-G600/HDD_a,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

root@willi-laptop:/home/willi# dhclient
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:14:a5:7a:4b:fc
Sending on LPF/eth1/00:14:a5:7a:4b:fc
Listening on LPF/eth0/00:0f:b0:fb:28:61
Sending on LPF/eth0/00:0f:b0:fb:28:61
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
bound to 192.168.0.102 -- renewal in 292622 seconds.
root@willi-laptop:/home/willi#



willi@willi-laptop:~$ modprobe -l | grep ndiswrapper
/lib/modules/2.6.15-25-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko
willi@willi-laptop:~$ ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present
oem3 invalid driver!
willi@willi-laptop:~$


willi@willi-laptop:~$ sudo rmmod bcm43xx
ERROR: Module bcm43xx does not exist in /proc/modules
willi@willi-laptop:~$


System->Admin->Networking shows eth1 as active.
nm-applet shows only my wired network.
gnome-netstatus-applet shows only eth0 (wired) and lo connections.

my home network is a wpa-personal, but it was configured correctly with wpa_supplicant, etc. as it worked for a day before. im also in range of my neighbors network, which is not encrypted.

suggestions?

black math
June 22nd, 2006, 01:46 AM
This worked great! If this was ebay id leave A++++++++++++ in the feedback comment. Would it be possible to configure WPA support into the script? Since I got the card working im messing with WPA_supplicant now to fully secure the network.

compwiz18
June 22nd, 2006, 02:21 AM
Try removing the oem driver that ndiswrapper shows she you run
ndiswrapper -l
by running

ndiswrapper -e oem3

Hope that helps.

Also, if someone would be willing to give me working directions for wpa encryption, I'll put that into the script. It seems to be a highly requested feature.

airrob
June 22nd, 2006, 06:55 AM
Just update GNOME Network Manager, as described here - http://en.magenson.de/2006/06/11/ubuntu-dapper-drake-and-wpa-encrypted-wireless/

However, while that makes the little network icon in the top right work, System -> Administration -> Network still seems not to work. Interesting.

magomago
June 22nd, 2006, 10:34 AM
Hi guys I'm wondering if you can give me a hand. i have an Acer Aspire 3624WXMi and I have the 4318 broadcom card. I've tried several guides but can't seem to get it installed.

After reading all the variety of guides, I figured hat NDIS wrapper was my best chance at getting this setup. i tried a few of them but none of them seem to be working. I got my wireless blinking...but gnome nework manager doesn't see anything. In fact, left clicking says "no network devices found"...BUT i'm using my hardwired ethernet to type this (From the same laptop) so atleast that should appear.

Here are some read outs:


amarry@amarry-laptop:~$ modprobe -l |grep ndiswrapper
/lib/modules/2.6.15-25-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko

amarry@amarry-laptop:~$ ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present
oem3 driver present, hardware present



Can anyone give me a hand? My wireless card light IS blinking...but I can't connect. I try to pick the right ESSID and then I insert my WPA key into the WEP key area....but I can't get anythng to work

Anything is appreciated. thanks!

compwiz18
June 22nd, 2006, 12:59 PM
Hi guys I'm wondering if you can give me a hand. i have an Acer Aspire 3624WXMi and I have the 4318 broadcom card. I've tried several guides but can't seem to get it installed.

After reading all the variety of guides, I figured hat NDIS wrapper was my best chance at getting this setup. i tried a few of them but none of them seem to be working. I got my wireless blinking...but gnome nework manager doesn't see anything. In fact, left clicking says "no network devices found"...BUT i'm using my hardwired ethernet to type this (From the same laptop) so atleast that should appear.

Here are some read outs:


amarry@amarry-laptop:~$ modprobe -l |grep ndiswrapper
/lib/modules/2.6.15-25-386/kernel/drivers/net/ndiswrapper/ndiswrapper.ko

amarry@amarry-laptop:~$ ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present
oem3 driver present, hardware present



Can anyone give me a hand? My wireless card light IS blinking...but I can't connect. I try to pick the right ESSID and then I insert my WPA key into the WEP key area....but I can't get anythng to work

Anything is appreciated. thanks!

I could be wrong because I don't use WPA, but I think you have to use a different program to use WPA encryption, the key doesn't go in the WEP key field.

black math
June 22nd, 2006, 03:25 PM
I could be wrong because I don't use WPA, but I think you have to use a different program to use WPA encryption, the key doesn't go in the WEP key field.

Thats correct, you have to use wpa_supplicant. Ive tried the steps here
http://en.magenson.de/2006/06/11/ubuntu-dapper-drake-and-wpa-encrypted-wireless/
but it didnt work for me.

xolot1
June 22nd, 2006, 05:55 PM
Try removing the oem driver that ndiswrapper shows she you run
ndiswrapper -l
by running

ndiswrapper -e oem3

Hope that helps.

Also, if someone would be willing to give me working directions for wpa encryption, I'll put that into the script. It seems to be a highly requested feature.


Just update GNOME Network Manager, as described here - http://en.magenson.de/2006/06/11/ubu...pted-wireless/

However, while that makes the little network icon in the top right work, System -> Administration -> Network still seems not to work. Interesting.

thank you very much. wireless is working great now.
very nice job compwiz.

MarkSheely
June 22nd, 2006, 07:40 PM
I had my wireless working before using other methods, but both times it stopped working. I just ran your script, and my wireless works again.

I had to do two things - 1), set wlan0 as the default in my system->administration->networking, and 2) download and use Wireless Assistant, since the applet in the top panel is pretty useless.

Thanks so much!
-Mark
marksheely@gmail.com

mshen10
June 22nd, 2006, 07:43 PM
hey guys. I run the tar file. Everything installed fine. I rebooted my laptop and I get eth1 idle. nothing is happening. can someone help me out?

I have a Dell Insprion | B130. There is no light for me to see if the wireless card is on.

mshen10@hacker-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID: off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management: off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

mshen10@hacker-laptop:~$ iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:09:5B: DF:A1:F6
ESSID:"HanShih"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-46 dBm Noise level:-256 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

i also installed network manager, rebooted and i get no network connection for the network manager.

magomago
June 22nd, 2006, 08:30 PM
Compiz1, How do I get that thing to appear? Just to be same i removed t oem3 driver and just left the bcmwl5 (spelling?) driver. I get my blinking light as always, but for some reason network manager only sees the wired connection (wierd...before it used to see nothing). So because I don't see the wireless networks the whole wpa thing is useless to me. But if I go into networking and configure eth1 I can see my network.

Any idea on what gives? Im thinking of starting a clean slate and directly using your instructions that it fixes it..

mshen10
June 22nd, 2006, 08:33 PM
hey magomago I get the samething that you get.

magomago
June 22nd, 2006, 09:00 PM
mshen10, i'll reboot rightn ow (luckily this is a new pc so the only thing i have setup is compiz but that was straighforeward) and see if that fixes it...i'm worried some other guides i tried earlier fubared this one

mshen10
June 22nd, 2006, 10:00 PM
ya. no good. Im just gonna wait for compiz to reply

magomago
June 22nd, 2006, 10:59 PM
ya. no good. Im just gonna wait for compiz to reply
I figured it out!!! I'm posting right now with it...and although I rebooted I don't think it is needed at all and probably beter for those who have their pcs already loaded...give me about 15 minute and i'll get it up

the funny part is that its just syntax errors:mrgreen:

mshen10
June 22nd, 2006, 11:07 PM
ahh ok. I hope it works for me.

compwiz18
June 22nd, 2006, 11:14 PM
ahh ok. I hope it works for me.

Try running sudo modprobe ndiswrapper...might fix it. If not, wait for a reply from the other person having this problem.

Hope that helps.

magomago
June 22nd, 2006, 11:19 PM
Note: I'm going try to make this as similar to the original post as possible so it is more seamless. This method will allow you to use your 4318 broadcom chip with WPA network

The first few parts are ripped right from the original post, and all credit goes to compwiz18 who is a whiz :) I'm just an engineer that applied some logic to figure why a few files were empty.

That and by making it exactly the same, he can easily integrate the WPA aspect of it

http://


This HOWTO is for people who have a Broadcom 4318 Wifi card in their laptop. This card can sometimes be a bit difficult to setup, so I have provided a working method (for me, anyway). This should also fix problems that cause the card to stop working when you upgrade from Breezy to Dapper.

There is another thread for people who have other Broadcom wifi cards, which can be found here.

To check if you have a Broadcom 4318 Card, open up the terminal (click the Applications button, then Accessories, and then Terminal) and run (just copy and paste the code from the code boxes throughout the HOWTO [in the terminal, this is done by right click anywhere and clicking paste, ctrl+v doesn't work])

lspci | grep Broadcom\ Corporation

If your output looks similar to:


0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

or you can see the string BCM4318 in the output, then this should work for you.

The point of this HOWTO is to make it as simple as possible (not to educate people - if you want to know how this works, open the script and read it) for people who have just installed Ubuntu for the first time, so I wrote a script and have provided a set of drivers that worked for me. It is important to note that not all drivers will work as expected, so please use the ones I have posted. If you have any problems, please feel free to post them, and help will be given.

This script requires no internet connection after it is downloaded.

Process

http://www.ubuntuforums.org/attachment.php?attachmentid=11584&d=1150897000Download this item
Open a terminal (click the Applications button, then Accessories, and then Terminal)
#
# Change the current directory to the desktop (copy and paste the following commands into your terminal [to paste in the terminal, right click and click paste, ctrl+v doesn't work] my edit: actual cntl+shift+v does ;))

cd ~/Desktop
Extract the Compressed File

tar -xf bcm4318.tar.gz
Run the script, which will install ndiswrapper on your system, and set it up.

sudo ./ndiswrapper_setup
Reboot the computer. Now your wireless light SHOULD be on :)
Lets get the network manager installed!

sudo apt-get install network-manager-gnome
Now let us edit the CORRECT file

sudo nano /etc/network/interfaces
in this area comment out (put a '#' in front of each line) anything that doesn't have 'lo' in it. For example this is what my interfaces file looks like after commenting


auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp


#iface eth1 inet dhcp

#auto eth2
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

#auto wlan0
#iface wlan0 inet dhcp


Restart....now the network manager SHOULD have the other networks up :D Connect to your network and insert your WPA key...YAAAAAAAAAAAAAAAAY

Note: Thanks a lot to compwiz18 for providing the entire first part. The second part comes entirely from http://en.magenson.de/2006/06/11/ubuntu-dapper-drake-and-wpa-encrypted-wireless/ however they are wrong in the file to edit...there is no "networks" folder...it must be the network folder. checking the directory by doing ls /etc shows this. All I did was put he two together


IF you have tried many guides, just make sure that only the driver we want is installed

do


sudo ndiswapper -l


you SHOULD get just



bcmwl5 driver present, hardware present


if you get anything else like "oem3" remove it by doing



sudo ndiswrapper -e NAME_OF_DRIVER

You may want to restart.

By the way I have no idea if all those restarts are necessary...I'm guessing the first restart isn't necessary, but I put it there because that is how I ended up doing it.

Thanks all, and I hope this helps you guys!


eidt:

compwiz18 feel free to integrate this guide straight up into the original...as i wrote it to make integration easier. Also, insert the caveat that if they have tried many methods they need to remove any other rogue drivers.

compwiz18
June 22nd, 2006, 11:27 PM
Oki doki, will do :D Thanks for writing that.

EDIT: AWESOME!!! Didn't realize that it used network-manager till I tried it :D I'd been wanting to do that for a while. Anyway did that, get the new packages from the first post for automatic setup.

mshen10
June 22nd, 2006, 11:44 PM
thanks. isn't it gedit? I did add the # in. I restarted and my network manager now lets me add wireless network. but how do i connect?

oh ya, when i go into my network settings it says all my network connection is not configure.

compwiz18
June 22nd, 2006, 11:53 PM
You can click on the network name, and the program will try to connect. Enter your key and start praying it works (it doesn't always for me :P)

mshen10
June 23rd, 2006, 12:01 AM
lol i did. no good. It could be that my WEP is interfering

ok it's no good :(. it's not working for me.

magomago
June 23rd, 2006, 12:34 AM
you have a wep setup AND a wpa setup? Now i'm confused....

Your router is setup as WPA and has a key, right?

mshen10
June 23rd, 2006, 12:37 AM
it's WEP the encryption is 64 bit. I blieve it's hex

linux_author
June 23rd, 2006, 01:09 AM
- thank you very much for posting this HOWTO... it has saved me a LOT of time researching a 32-bit wifi driver for my HP L2000 (Lance Armstrong notebook)...

- i have KANOTIX64 running on the laptop with wifi working via the 64-bit Broadcom 4318 driver required by the laptop, but wanted to test the notebook with a 32-bit USB thumbdrive distro (which requires, obviously, a 32-bit driver)...

- btw, i used this HOWTO's approach and driver with Slax 5.1.6, ndiswrapper 1.15, kernel 2.6.16...

- kudos to the author!

teryret
June 23rd, 2006, 02:41 AM
Restart....now the network manager SHOULD have the other networks up :D Connect to your network and insert your WPA key...YAAAAAAAAAAAAAAAAY

I love how often 'should' is synonymous with 'won\'t'. For some reason without modifying the /etc/network/interfaces tab (ie leaving them all uncommented) NetworkManager is enabled to manage the wired lan, and no combination of commenting lines in that config file will enable it to talk to the wireless lan. Of course, some combinations of comments will prevent it from managing the wired lan, but that's not quite the same.

Any idea where I should start on this?

compwiz18
June 23rd, 2006, 03:03 AM
Restart....now the network manager SHOULD have the other networks up :D Connect to your network and insert your WPA key...YAAAAAAAAAAAAAAAAY

I love how often 'should' is synonymous with 'won\'t'. For some reason without modifying the /etc/network/interfaces tab (ie leaving them all uncommented) NetworkManager is enabled to manage the wired lan, and no combination of commenting lines in that config file will enable it to talk to the wireless lan. Of course, some combinations of comments will prevent it from managing the wired lan, but that's not quite the same.

Any idea where I should start on this?
Sounds like you already tried this, but comment out every line without lo in it? That's what worked for me.

teryret
June 23rd, 2006, 03:19 AM
Sounds like you already tried this, but comment out every line without lo in it? That's what worked for me.

Yeah, I tried that one (especially because that was the way the directions indicated to do it :p ). The most promicing combination is to comment out eth1 but leave wlan0 uncommented, it at least lets NetworkManager see that there's a wireless adapter and a wireless network, but it won't join it.

Edit: it also seems to be regenerating settings, namely when I edited the file before the most recent reboot I took note of exactly what was commented and what wasn't, but now that I look into the file again two of the commented lines now have duplicates that are not commented.

My sneaking suspicion is that wlan0 is the real network adapter, but ndiswrapper is binding a driver/firmware over it and calling the combination eth1, and as such giving NetworkManager the ability to talk to wlan0 really won't help. I wonder if there's a way to simply put a layer of abstraction on top of eth1 and then give that to NM...

I also wonder what would happen if I just rename the file... one way to find out, brb.

Edit 4: Don't try that. It stops gnome from booting.

black math
June 23rd, 2006, 04:07 AM
Ok I tried what magomago said and installed network-manager-gnome and then uncommented those lines out. Am I blind because I dont see where you open network manager at. How do you get to network manager to put your WPA key in?

compwiz18
June 23rd, 2006, 04:09 AM
Ok I tried what magomago said and installed network-manager-gnome and then uncommented those lines out. Am I blind because I dont see where you open network manager at. How do you get to network manager to put your WPA key in?

Nope, not blind. There is no button to make it go. Press alt+f2 and type in nm-applet or restart the computer.

black math
June 23rd, 2006, 04:18 AM
Nope, not blind. There is no button to make it go. Press alt+f2 and type in nm-applet or restart the computer.

Ok tried that and still nothing came up. If I look at the process list I can see nm-applet in there sleeping. This is something probaly pretty simple and im just overlooking something.

teryret
June 23rd, 2006, 04:25 AM
Ok tried that and still nothing came up. If I look at the process list I can see nm-applet in there sleeping. This is something probaly pretty simple and im just overlooking something.

It's an innocent looking icon by the clock, click it once and it pulls up a radio button list of interfaces.

Silver Bullet
June 23rd, 2006, 05:38 AM
Very good job....

I was using fwcutter successfully but could't get farther than 15 feet from my wireless router and would lose connection. Decided to try your script with ndiswrapper (I have successfully used ndiswrapper before as well but you made it very simple) and it works just like it is suppose to.
=D> \\:D/

Edit: For anyone else wanting to use this with Kubuntu 6.06. After running the script the only thing I personally had to do was disable eth0, open KDE Wireless Assistant, click on my wireless network and enter my WEP key.... Simple as that.

Again....great work!!

black math
June 23rd, 2006, 12:08 PM
Arrgggh I still cant get network manager to work correctly. To make sure im doing this right I attached an image to make sure im clicking the right thing. If this is the right thing then I choose lo from the drop down and it doesnt see my network. I dont see a place to enter the WPA key. http://img145.imageshack.us/img145/3493/untitled2hs1.jpg
http://img68.imageshack.us/img68/5830/untitled18gt.jpg

compwiz18
June 23rd, 2006, 01:16 PM
Oops, that is the wrong button. Try this: right click on the empty area on one of the panels, click add to panel, and then choose notification area. Now look for http://img73.imageshack.us/img73/4561/notconnected4cu.png or http://img236.imageshack.us/img236/9972/wifi3hr.png in the notification area that you just added. LEFT click that. LEFT click on the wireless network you want to connect to, and go :D

fnorrell
June 24th, 2006, 04:38 PM
Awsome - worked 1st try, no problems! You made my day.

Gateway MX6025 Laptop

THANK YOU THANK YOU THANK YOU

akb
June 25th, 2006, 01:34 AM
it works like a charme here... at least in general. but it doesnt come up on boot automagically... is there any way to do so? i already have all that wpa_supplicant stuff configured. /etc/wpa_supplicant.conf, /etc/network/interfaces and all that... but it doesnt come up automatically. i always have to call the adapter manually.

well, i checked few minutes ago. ndiswrapper is loaded, the acer_acpi is enabled, needed for my acer, but wpa_supplicant and dhclient arent called automatically. any hints?

Raistlin355
June 25th, 2006, 02:30 AM
Thanks a lot!!!!! This didn't work exactly perfect, and I had to read through all the pages in the thread, but it DID work, so not my built-in wireless card work perfectly with WEP Encryption and just for fun I set up WPA and it works too!!! Acer 3004WLCI Laptop 8)

The only thing that is kind of annoying is a startup it is now asking for a keychain password, I tried all the system passwords I have, none worked but I hit 'Deny" and it goes away and the wireless works and it also asks for the WEP passphrase all the time, but I can live with this so long as the wireless works!!!!!

Also has anyone done this and updated the system? I'm wondering if it'll still work after an update? Thanks Alot!!!!

compwiz18
June 25th, 2006, 02:31 AM
Um...no...sorry. Like I said, I don't use wpa_supplicant, but if you do figure out how, post it here. I'd like to know. :D Good luck.

compwiz18
June 25th, 2006, 02:34 AM
Hm...well at one point, it should've asked you to enter a password for the keychain thingy. Just out of wondering, what gave you trouble and made you read the whole thread? Hm...Well, good luck.

zany
June 25th, 2006, 02:50 AM
ok, so i re-installed ubuntu and booted into the liveCD, i noticed that my wireless card (eth1) is listed there, it will activate but does not seem to connect...i run iwconfig, it says 'accent point: invalid' for eth1.

i am using Ubuntu-amd64, what should i do next? ndiswrapper isn't installed, but i'm not sure which route to take...

compwiz18
June 25th, 2006, 05:06 AM
Well, that is because the bcm4318 driver will make you able to activate it, but then you won't be able to use it. Isn't that great?

zany
June 25th, 2006, 02:29 PM
great, wonderful.

Raistlin355
June 25th, 2006, 03:02 PM
Hm...well at one point, it should've asked you to enter a password for the keychain thingy. Just out of wondering, what gave you trouble and made you read the whole thread? Hm...Well, good luck.

Well, I followed the instructions down to the letter, and it didn't work right away so I started reading the thread, and what Magomago did on page 7 seemed to help get it working, although it doesn't look like that would do anything. My best guess is that in commenting out the lines '/etc/network/interfaces' it stopped a hardware/driver conflict that was happening without the lines being commented out.

oskie
June 25th, 2006, 04:55 PM
It worked for me on my AMD Turion 64 presario 2000 but only in 32 bit and not 64 despite trying the other scripts. I was debating whether to use 32 or 64 and this issue kind of sealed the deal. Thanks for this useful and easy to use How To. Haven't gotten around yet to enabling WPA encryption. This is next on my list of to dos.

compwiz18
June 25th, 2006, 06:21 PM
Whether the 64-bit version works depends on whether you downloaded the 64-bit version of Ubuntu...it sounds like you downloaded the 32-bit version, so the 64-bit on wouldn't work.

zany
June 25th, 2006, 10:39 PM
yeah, i have a compaq presario v2424nr with a turion64 processer, i am hoping to get the bcm4318 driver workin' under ubuntu-amd64

i guess i'll go through the how-to again...

plailopo
June 27th, 2006, 08:29 AM
Hi everyone,
I tried the script for install driver, but nothing, so I tried to reboot et voilą the light wireless is up. The connection is very good!

At the second reboot the light is off... the connection is off :confused: :confused:

I tried to reinstall, unload and load module ndiswrapper.. but nothing ](*,)

help me
thank
P

The Raven
June 27th, 2006, 10:07 AM
I just got my Presario V2000 up and on wireless.
It got AMD Sempron Mobile 32 bit Architecture with scalable graphics and virtual
surround sound. Now it has wheels and wings, sweet!!!!

It's sad that I had Red Hat v.7, SUSE Linux v.8&9, Mandrake, blah, blah, blah...now I got Ubuntu with an NDISWrapper installer and I finally got on line wirelessly. It only took four years to get my freedom with Linux.

Ubuntu was the first Linux Distro I got on-line with ever and I did from the
"Live CD" I burned that day, after I find that the Ubuntu ISO image I downloaded and burned before it was corrupted.

Nothing but bad Karma around this deal, but I noticed that we're starting to make headway with Linux and thus winning over the misfortune that has shrouded Linux for over two decades is right around the corner. This installer, and that is what it is, is one of the most incredible things that I have seen for my O.S. to date.

It is a script but it has the spiritedness and prowess of a full blown installer, as most installers are nothing more than scripted files anyway. You should package that idea with an I.D. as a configurable installer to include in compiled source
binary distros man. You are there brother.

I seriously do not know how to thank its creator enough. I think you got a life dude, it's just everyone else that can't see it.

Excellent.

Ran into this way and that way instructions for NDISWrapper and not a single set of instructions yielded anything but frustration for me. I was seriously contemplating the fact of trying to create my own installer or tossing Ubuntu in the pile next to R.H. and SUSE, and then I found this thread.

I'm in the process of compiling some instructions for this script, I'm thinking a PDF, with a decent layout as I am pretty impressed with the knowledgability of all of you that have posted on this thread.

You all are literally what Linux is about, and that's the #@$! truth, period!

Fire fox seems to load slow on my system, but once the page is basically set it flies.

It has got something to do with the way it caches pages and web server/web page settings. It crawls a bit when I run of off my ethernet connection in Ubuntu. I myself set the cash high so that pages that I frequent load faster.

The speed problem that seems to be reported regarding this script and the driver install is reliant upon a lot of variables more attributed to the O.S. settings and browser configuration. The fact that there will be lag when you utilize "plug-in" components like NDISWrapper is inevitable and unavoidable without serious consideration.

A point to ponder regarding O.S. configurations on AMD systems:

AMD 64 chipsets are completely compatible with all 32 bit
architectures, end of story. So don't worry bout 64 vs. 32 because your
wasting your time. The AMD 64 chip has instruction sets in it's cache to
identify your O.S. when you install it. The 64 chip will initialize and set the
32bit instruction set for a 32 bit O.S. or the 64 bit instr. set for a 64 bit O.S.
64 bit systems can run your 32bit software, but a 32bit system will
never run 64 bit soft anything. The instructions strings for a 64 bit sys is
twice as long as a 32 bit sys. You'd bottleneck your processor and lock
your system. Essentially you should run the 64 bit O.S. because then
you could run all of your 32 bit software as-well-as your 64 bit software
having an optimized system configuration. Running a 32 bit O.S. on a 64 bit
system is wasting your resources and the money you spent on that chip.

CPU's aren't free and they don't come cheap.

compwiz18
June 27th, 2006, 02:02 PM
Hi everyone,
I tried the script for install driver, but nothing, so I tried to reboot et voilą the light wireless is up. The connection is very good!

At the second reboot the light is off... the connection is off :confused: :confused:

I tried to reinstall, unload and load module ndiswrapper.. but nothing ](*,)

help me
thank
P
Hi,

Try sudo gedit /etc/modules and removing ndiswrapper on all the lines it occurs.

Hope that helps.

selex
June 27th, 2006, 07:44 PM
thanks for your HOWTO; but it's not working for me:

My pc (laptop): Amilo A 1650

First problem: ndiswrapper.deb from bcm4318x64.tar.gz says me: Error: Wrong architecture 'i386'. So I do 'sudo apt-get install ndiswrapper-utils'

True Problem : 'ndiswrapper -l' returns
Installed ndis drivers:
bcmwl5 invalid driver!

I have tried with the driver from ndiswrapper's wiki but it didn't results ](*,) . Have anybody an idea?

rogijero
June 27th, 2006, 09:27 PM
Thanks for the awesome guide, it got my compaq v2312 up and running in no time.
my only issue is that there isnt a signal strength meter in the top left menu bar. anyone know why or what i can do? im only asking because at school wireless access is poor, and it's good to know when you are about to lose an access point. thanks

black math
June 27th, 2006, 10:16 PM
Is there a way so that when you reboot it will automatically connect to the wpa network? Everytime I restart I have to specify the SSID and then the wpa key. Is there a way around having to do this?

davea88
June 27th, 2006, 10:23 PM
I modified the setup to do dpkg --force-architecture -i ndiswrapper.deb
which gets ndiswrapper installed. On amd64, kubuntu 6.06, hp laptop
I used the tar.gz for -64 (in earlier message).
The architecture of ndiswrapper being i386, the machine being amd64.
ndiswrapper does work, but see below:

avea@davea-laptop:~/Desktop$ ndiswrapper -l
Installed ndis drivers:
bcmwl5 invalid driver!

BTW: each run of the setup script adds a *new* ndiswrapper
line to /etc/modules...

Anyway, I now, I think, get a new blue light on the laptop,but
NetworkSettings does not show the wlan0.
suggestions?
And thanks for all these hints... Really appreciated.

punkybouy
June 28th, 2006, 02:22 AM
Super job. Where did you find that version of the inf file? Even the one from Belkin site did not work.

The Raven
June 28th, 2006, 03:13 AM
Here are some compiled logical steps that I retrieved from several posts in this thread and a few other places regarding the identification, maintenance, and installation of wifi hardware and/or firmware:


Steps:

---------------------------------------------------------------
Conventions:

UN = your user name
CN = your computer's name.

Notes: = side-bar elaboratives to explain a step
Warning: = Warnings are just that; you had better read them.


Tip:

You do not retype your UN@CN, just the code after
the $.

UN@CN:~$ and UN@CN:~/Desktop$ are place holders merely
referencing that you should see a prompt in the terminal's
window where UN is your user account's name @ your computer's
name, both of which were assigned when you installed and
configured your Linux O.S. distro.


Warning: Do the steps in order and stick to the
procedure, don't add any steps unless you know
what it is that you are doing here.
---------------------------------------------------------------

---------------------------------------------------------------

1.)Open your terminal (obviously).

---------------------------------------------------------------

2.)UN@CN:~$ lspci | grep Broadcom\ Corporation
A.)Press the Return/Enter key



You should now see the following output return in your terminal's display:

0000:05:02.0 Network controller:Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g
Wireless LAN Controller (rev 02)


If this is what your terminal command returns in the display you have nothing to worry about.

Proceed to the next step.

---------------------------------------------------------------

4.)UN@CN:~$ echo blacklist bcm43xx | sudo tee -a /etc/modprobe.d/blacklist
A.)Press the Return/Enter key


Your terminal will process the command and notify you that the 43xx driver file has been
successfully 'blacklisted'.


Warning:
This will 'blacklist' an older version of the 43 driver series known as 43xx, which is
pre-installed with UBUNTU Dapper Drake and possibly other Debian based Linux Distros.
The 43xx driver will conflict with some other drivers in the 43xx genre. A lot of problems
concerning oddly behaving cards could have something to do with the exclusion of this
step, so just do it!

It's better to be safe than sorry.

----------------------------------------------------------------

5.)If you haven't already done so, go ahead and move your 'bcm4318[1].tar.gz' package
to your desktop (a.k.a.- shell, be it Gnome ,KDE; etc.)

----------------------------------------------------------------

6.)UN@CN:~$ cd /home/UN/Desktop
A.)Press the Return/Enter key



You should now see the following output return in your terminal's display:


UN@CN:~/Desktop$


This output is telling you that the Desktop directory is your active directory and all actions
will be initiated starting at this point.

-----------------------------------------------------------------

Note: It works the same way a browser navigates through a web site.
(Investigate this topic on your own as it is beyond the scope of this block of instruction.)

The UN@CN:~/Desktop$ is your new base directory that you will be working out of. It stream-
lines the process of file access. If you are going to working with a lot of files on your
desktop you make the Desktop your base directory and the terminal will assume on your behalf
that you will be doing all of your work in the Desktop "directory." This saves you time, in
that, you do not have to write out the complete file path to every object on your desktop, just
a command of execution and the file that the command will take action(s) upon.

------------------------------------------------------------------

7.)UN@CN:~/Desktop$ tar -xf bcm4318[1].tar.gz
A.)Press the Return/Enter key


You should now see the output return in your terminal's display stating that the 'bcm4318[1].tar.gz'
package is effectively being decompressed and extracted to the desktop. Once the terminal notifies you
that the process of extraction was successfully completed and you see the prompt:

UN@CN:~/Desktop$

...proceed to the next step.

-------------------------------------------------------------------

8.)UN@CN:~/Desktop$ sudo ./ndiswrapper_setup
A.)Press the Return/Enter key

You will now witness the installation execution step by step as it is carried out automatically by the
terminal. When the terminal returns a message stating that the installation was successfully completed
you will be queried again with the terminal prompt:

UN@CN:~/Desktop$

...proceed to the next step.

--------------------------------------------------------------------

9.)System menu on your Desktop toolbar at the top of the screen,then:

Administration > Networking, click the wireless connection of the 'Connections' tab and click
the 'Properties' button. Click the "Enable This Connection check Box Radio Button", set your
ESSID id to the active network name that you will use to access your router for wifi, and set
your configuration to DHCP to automatically obtain IP addresses, just like in Windows.

Warning:

Make sure that your wireless lan is activated, only after inspecting the properties of your
wlan connection setup properties, this will prevent wasted time, stupid questions, and people
feeling stupid for asking stupid questions because they didn't pay attention to detail.


Setting up WEP is simple, but you can consult your router's user/set-up documentation for the
exact specifications of performing such a procedure.

A.)Click "OK"

...and wait for the process to complete the update to your configuration settings.



I have a Linksys 54G Wireless Router myself, and I use the router default for wifi which is
"linksys," without the quotations, the ethernet ESSID is "Linksys."

---------------------------------------------------------------------

10.)Click "OK" of your "Network Settings" dialog window.

...and wait for the process to finalize your configuration settings.

---------------------------------------------------------------------

11.) Open your browser and surf to a web page like Google.

Click the Google search text entry field, in the upper right corner of Firefox, and press
the Retern/Enter key on your key-board and wait for Firefox to open Google's default
Home Page.

Close your browser and proceed to the next step...

---------------------------------------------------------------------

12.)UN@CN:~/Desktop$ ndiswrapper -l
A.)Press the Return/Enter key



Your terminal should return the following output in it's display:


bcmwl5 driver present, hardware present


At the terminal prompt:


UN@CN:~/Desktop$

...proceed to the next step.

---------------------------------------------------------------------

13.)UN@CN:~/Desktop$ sudo -i
A.)Press the Return/Enter key
B.)Key in your administrator password
C.)Press the Return/Enter key

14.)UN@CN:~/Desktop# modprobe ndiswrapper
A.)Press the Return/Enter key

Now push the wifi network connect/disconnect button on your computer...

- it should come on/light up, or turn off as the case may be. If
you turned it off, turn it back on now.

15.)UN@CN:~/Desktop# ifdown eth1
A.)Press the Return/Enter key

16.)UN@CN:~/Desktop# ifup eth1
A.)Press the Return/Enter key

17.)UN@CN:~/Desktop# dhclient
A.)Press the Return/Enter key

18.)UN@CN:~/Desktop# iwconfig
A.)Press the Return/Enter key
B.)Verify that the output displays
the correct settings for
your wifi network.

19.)Close the Terminal utility, and browse/surf as desired.



indicis: compwiz18
naught 101

P.S. Let me know how it works, as this will aid me in correcting and/or adding info to help out Compwiz18 in getting you all on-line effectively.

Raistlin355
June 28th, 2006, 03:50 PM
I have come up with a new problem. I have had my wireless working for about a week now and haven't had any trouble after I got it working. I'm using the gnome-network-manager and can even connect to other networks while I'm driving around. The problem is the only network I cannot connect to is at my work!! I can pull an IP but thats it, no network shares, or internet. Has anyone experienced this and if so what solutions did you use?

Centaur5
June 28th, 2006, 06:19 PM
This script did not work on my HP Pavilion ze2000. The card has always detected and showed up as eth1 ever since I installed Dapper but it would always say in iwconfig "ap: invalid" so I tried multiple things trying to get that working. The only way I could bring my wireless up was to manually configure everything using iwconfig and dhclient ifconfig afterwards but after installing this script eth1 doesn't even show in network manager, iwconfig, or ifconfig. Instantly after installing the script I was able to see the available access points in network manager but it failed to get an IP address so I rebooted but ever since eth1 doesn't come up. Any help would be appreciated. Also after reading through this thread I tried sudo modprobe ndiswrapper but that gave an error saying FATAL: Module ndiswrapper not found.

Raistlin355
June 28th, 2006, 08:41 PM
Got it to work, I'm typing this from my Ubuntu Laptop from work!!! YYYYAAAAAA

ffderrick
June 28th, 2006, 09:23 PM
Thank you very much for your good work.
I've been fighting wireless on dapper for a couple of days.
I'm using an Hp dv5003cl laptop and your method worked for me.
I'm currently using Ubuntu as my stable OS and Archlinux testing as my playground. I was able to get wireless working easily in Arch, so having trouble with Dapper got me really frustrated.
Thanks again.

Navalynt
June 28th, 2006, 09:42 PM
I've followed all the steps but after rebooting I keep getting the error "The NetworkManager applet could not find some required resources. It cannot contine". On the bright side at least the wifi light is coming on now!

Navalynt
June 28th, 2006, 09:55 PM
Just found the answer I was looking for, had to run:

sudo gtk-update-icon-cache -f /usr/share/icons/hicolor/

This fixed the problem, it seems to work great now!

compwiz18
June 29th, 2006, 03:23 AM
Super job. Where did you find that version of the inf file? Even the one from Belkin site did not work.
It's my own special one. Actually, to be honest, all I know is that 95% of the ones I tried didn't work (this includes ones on the CD, and downloaded from the Compaq website), and that the one that did came from a post somewhere on this site.

VON_CAPO
July 2nd, 2006, 01:26 AM
The Raven said:
"P.S. Let me know how it works, as this will aid me in correcting and/or adding info to help out Compwiz18 in getting you all on-line effectively."

BRAVO!!! It works perfectly!!! \\:D/ \\:D/ \\:D/

Thank you so much. :D

Also I would like to congratulate compwiz18, who started this thread. BRAVO!!!

WorkingOnGoingLinux
July 2nd, 2006, 05:57 AM
Compuwiz...
Many thnaks for this How To. worked perfectly for me on a HP6100
I've screwed with this thing for hours. Your advice worked first time..

LegoManiac
July 4th, 2006, 07:41 AM
Is there a way to bring up the wifi without rebooting?

I'm using a live CD and have the driver/script tarball copied onto a USB stick. Even if I have to reinstall wifi every time I boot from the live CD, I'm okay with that. The only problem is that the current procedure requires rebooting, which with a live cd environment means "start over".

compwiz18
July 4th, 2006, 02:02 PM
Is there a way to bring up the wifi without rebooting?

I'm using a live CD and have the driver/script tarball copied onto a USB stick. Even if I have to reinstall wifi every time I boot from the live CD, I'm okay with that. The only problem is that the current procedure requires rebooting, which with a live cd environment means "start over".
Try the one that doesn't include network manager. When it tells you you should reboot, don't. The go to System / Administration / Networking. Configure the card. It should work, if you're lucky. I've never tried it with the live CD though. Tell me how it works.

Hope that helps.

Predilications
July 6th, 2006, 04:46 AM
Thanks Compwiz for starting this thread it has been a great help!

Before running your script (the default one that includes network manager) I uninstalled network manager and network manager gnome (both of which I had installed during previous attempts to get my broadcom wifi card working) to get a fresh start.

After running the script there was no icon in the top right of my screen and the wifi would not connect. Synaptic showed that network-manger was installed but not network-manager-gnome. So, with synaptic, I installed nework-manager-gnome, and this got the wifi card working.

So there seem to be two things, network-manager and network-manager-gnome, that need to be installed.

aly35
July 6th, 2006, 12:33 PM
Great thread, although none of the solutions so far have helped me.

Ive tried numerous solutions including using different versions of the bcm43xx driver and also different versions of ndiswrapper. My current issue is that when I ran the script that compwiz18 posted on the first page of this thread, my wireless device vanished...

It doesnt show up in either 'ifconfig' or 'iwconfig'


# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.




# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0A:E4:EF:A7:72
inet addr:192.168.0.7 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20a:e4ff:feef:a772/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1491 errors:0 dropped:0 overruns:0 frame:0
TX packets:1630 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1628224 (1.5 MiB) TX bytes:186602 (182.2 KiB)
Interrupt:66 Base address:0x2400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:13507 errors:0 dropped:0 overruns:0 frame:0
TX packets:13507 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1056605 (1.0 MiB) TX bytes:1056605 (1.0 MiB)


im running Ubuntu Dapper 6.06 64bit version on an Acer Aspire 5024WLMi with a AMD Turion processor

Any ideas??

noday42
July 6th, 2006, 05:43 PM
I'm not using a broacom wireless card...but rather a linksys usb wireless adapter

I'm having a lot of trouble connecting to my wireless network...as in, I can't even do it. Here are my iwlist:
wlan0 Scan completed :
Cell 01 - Address: E2:C5:A8:9D:49:F1
ESSID:"linksys"
Protocol:IEEE 802.11b
Mode:Ad-Hoc
Frequency:2.462 GHz (Channel 11)
Quality:0 Signal level:0 Noise level:0
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Extra:bcn_int=100
Extra:atim=1

and iwconfig:
wlan0 IEEE 802.11g ESSID:off/any Nickname:"linksys"
Mode:Auto Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=2 Mb/s
RTS thr=2347 B Fragment thr=2346 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

when I go into the network manager, no matter what I do, it sets the gateway default device to my wired network card, not the wireless. Any help would be appreciated!

Paulo Wageck
July 6th, 2006, 07:39 PM
worked for me like a charm.
thanks!!!! doesnt work with kismet i have heard.. anyone tried?
any successfull attempts?
thanks!!!!

compwiz18
July 6th, 2006, 08:19 PM
Um...try deactivating the bad interface...e.g. the wired one. I think that helped me...

aly35
July 7th, 2006, 04:37 AM
Um...try deactivating the bad interface...e.g. the wired one. I think that helped me...

Nope that didnt work, even when the wired device is disabled/deactivated, the wireless one still doesnt show up.

zshadow
July 7th, 2006, 05:03 AM
Is it possible to get this working on a LiveCD? I tried both archives (one with and without net manager) but no go. Installs successfully but requires me to reboot so that the card becomes active which of course I cannot do.

compwiz18
July 7th, 2006, 03:46 PM
Try not rebooting...it may still work.

JonAre
July 7th, 2006, 06:54 PM
I've got mye 4318 working, but when I suspend or hibernate the laptop the adapter no longer has an IP adress when it wakes up. I have to poke it back into life by running:

sudo ifdown eth1
sudo ifup eth1

How do I make the system run these commands automatically upon wakening? With the proper privileges?

compwiz18
July 7th, 2006, 07:02 PM
I'm pretty sure there is a file somewhere for this purpose; I do not know what it is called. If you find out, post it here. I would like to know.

Tiede
July 7th, 2006, 07:24 PM
I just used this script to try and fix my 4318 card, and I am almost home. I can see the available access points, even network manager shows the right essids, but it won't connect. The icon just spins around until it's timed out...
I am sure it must be something small... I am using windows now and can't give my iwconfig et al, but I am going to switch back to ubuntu ASAP and update this post accordingly.
In the mean time, does any one have any suggestion about where the problem may lie... I have tried commenting out everything not pertaining to the lo interface in /etc/network/interfaces to no avail.

compwiz18
July 7th, 2006, 07:29 PM
Do you have some sort of encyption on your router? Or another wifi manager, such as gtk-wifi?

Tiede
July 7th, 2006, 07:35 PM
No. I read all of your first post and I made sure I did not have any other wifi-managers present. I only have network-manager and network-manager-gnome present. I used the first link. (The one specifically designed for network manager).

compwiz18
July 7th, 2006, 07:43 PM
Well...did you try iwlist and iwconfig?
If anywhere you see something about Access Point: Invalid, beware. This is a problem.

Tiede
July 7th, 2006, 07:47 PM
Ok. I'll be on the lok out for that. but I remember doing so when I was on dapper and iwlist wlan0 scan gave me the right essids, iwconfig showed everything waws fine... But maybe I overlooked it. Since I just finished what I was doing in windows, I am going to switch to dapper for a sec, run iwlist and iwconfig and post the outcomes here. Is there any other outputs you may need before I go?
Thanks for your help so far.

JonAre
July 7th, 2006, 07:59 PM
I'm pretty sure there is a file somewhere for this purpose; I do not know what it is called. If you find out, post it here. I would like to know.

This is a bit of a hack, but I created a shell script called bcmrestart in /usr/bin:



#!/bin/sh

sudo ifdown eth1
sudo ifup eth1


and made it runnable (sudo chmod +x bcmrestart). Then I added the command "bcmrestart" in /etc/acpi/resume.sh. And voila, the bleedin' card seems actually work after beeing suspended!

Feel free to point better ways to do this, or more natural places to put it.

Tiede
July 7th, 2006, 08:13 PM
Well...did you try iwlist and iwconfig?
If anywhere you see something about Access Point: Invalid, beware. This is a problem.
OK. I am just back from dapper. Here are the outputs I got:

user@ubuntuforums:~$ iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:02:2D:51:02:48
ESSID:"StaffWireless"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.442 GHz (Channel 7)
Quality:0/100 Signal level:-53 dBm Noise level:-256 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:02:2D:8E:A2:86
ESSID:"PublicWireless"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-51 dBm Noise level:-256 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Extra:bcn_int=100
Extra:atim=0

--------------

user@ubuntuforums:~$ sudo iwconfig
wlan0 IEEE 802.11b ESSID:"PublicWireless"
Mode:Managed Frequency:2.462 GHz Access Point: 00:02:2D:8E:A2:86
Bit Rate:11 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-59 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

--------------

user@ubuntuforums:~$ sudo iwlist wlan0 ap
wlan0 Interface doesn't have a list of Peers/Access-Points


--------------
This is the only thing I found a odd. but maybe I am wrong...


user@ubuntuforums:~$ sudo iwlist wlan0 power
wlan0 Current mode:off

compwiz18
July 7th, 2006, 08:52 PM
OK. Well, I checked on mine, and mine says that the current power mode is off too. So that's fine. After you log in to Dapper, try running sudo dhclient. If it doesn't work, run it again. Sometimes I have to run it ten times before I can get mine to work. Check to see if the internet works after every run.

zshadow
July 7th, 2006, 11:34 PM
Try not rebooting...it may still work.

I did, but the card still shows up as not active.

Anyone get it working on a livecd?

compwiz18
July 7th, 2006, 11:41 PM
Did you try pressing the activate button?

zshadow
July 7th, 2006, 11:55 PM
yeah I did, it came up as active then, but when I pressed ok and went back in the network dialog box, it showed up as not active. I'll give it another go and see..

compwiz18
July 8th, 2006, 12:52 AM
You could try sudo ifdown NAME_OF_INTERFACE, then sudo ifup NAME_OF_INTERFACE, the sudo dhclient, in that order.

Hope that helps.

zshadow
July 8th, 2006, 02:59 AM
You could try sudo ifdown NAME_OF_INTERFACE, then sudo ifup NAME_OF_INTERFACE, the sudo dhclient, in that order.

Hope that helps.

still a no go :( Do you think its because the livecd tries to load the incompatible drivers on bootup? Would it be possible to add ndiswrapper and the drivers to the livecd so it'd load them on bootup instead?

compwiz18
July 8th, 2006, 03:55 AM
I just tried the livecd with this...still had the same problem. I don't know what to say...anyone else tried this and got it to work?

LegoManiac
July 8th, 2006, 09:17 AM
I got the wireless working on a Live CD version of Ubuntu (nUbuntu6.06)

OS: nUbuntu 6.06 LiveCD
Model: HP ze2000 AMD Turion 64
Chipset: BCM4318 AirForce One 54g

nUbuntu has ndiswrapper already installed, but the same version of ndiswrapper is packaged with the driver referenced at the beginning of this thread.

do this first:

> rmmod bcm43xx (the script runs incorrect command "rmmod bcmxx")
> ifdown eth0 (optional)

follow the rest of the instructions in that thread:

> sudo sh
> tar -xvzf bcm4318*.tar.gz
> sh ndiswrapper_setup

use iwconfig to configure the wifi settings:
> iwconfig wlan0 channel 6
> iwconfig wlan0 essid "networkname"
> iwconfig wlan0 mode managed

use ifconfig or dhclient to set IP information:
> ifconfig wlan0 192.168.1.2 netmask 255.255.255.0

if a default route is missing, make sure to add it back:
> route add default gw 192.168.1.1

ageros
July 8th, 2006, 06:05 PM
Just got this working, on a side note I had to have both eth0 and eth1 enabled for the wireless connection to work. Is there a utility that can be used to simply scan and connect to network similar to the built in ms utility? I move around a lot and obviously don't know the ESSID of every network I come into contact with, and would like a utility I can use to scan the area and select the proper one.

compwiz18
July 8th, 2006, 06:32 PM
Did you try Network Manager? That is my favorite, but gtk-wifi actually works quite well too.

Jakykong
July 8th, 2006, 10:41 PM
Nice how-to ... only one problem... it doesn't have any info for Kubuntu! :( this is a how-to for ubuntu... but you see, i don't use gnome, so the network manager won't work. Also the one without the network manager didn't work for whatever reason. So far everyone wants to use ubuntu.... is there ANYONE who could re-write this for Kubuntu?

edit:
ack... stupid mistake. I forgot to extract the tarball without network manager so i reapeated the things that didn't work...

compwiz18
July 9th, 2006, 12:04 AM
So did you get it to work then, or does it still not work? Sorry, but I can't tell from your post.

zshadow
July 9th, 2006, 12:08 AM
Got it working with the LiveCD now, thanks =)

yjsoon
July 9th, 2006, 07:24 AM
I managed to get it to restore the session, but I keep having to manually re-enter my SSID (it's not broadcast) and WEP key. Awfully frustrating. Anyone managed to get network-manager or anything to automatically recognise hidden SSIDs?

dworourke
July 10th, 2006, 03:34 AM
After downloading 64 bit with Network Manager then running the script.My wlan interface disappeared. Restarted, ran script again with same results. "iwlist" and "iwconfig" indicate no wlan interface.
Have an HP zv6000 laptop 64bit AMD with Broadcom 4318 wlan.
Before the script was run had the wlan in list, it just would't work.

TIA, David

compwiz18
July 10th, 2006, 03:57 AM
Yep. So go to /etc/network, and find the file named interfaces.backup.bcm4318 or something similar to that (I don't remember the exact name, but it has backup and bcm* in it). Rename that to /etc/network/interfaces and then your interface will reappear, hopefully.

willbert
July 10th, 2006, 03:22 PM
I have the same problem as dworourke, after running the script and rebooting i dont have wlan0 or eth1 in network manager. I have also tried renaming interfaces.backup.bcm4138 to interfaces and the wireless hasnt returned. Any other ideas?

OvERKiLL
July 10th, 2006, 06:26 PM
I have similar problems, after tweaking around endless ammounts of stuff, i got it to here, it says the driver and hardware are bolth working, but nothing shows up!
http://img131.imageshack.us/img131/1071/screenshot5nl.th.png (http://img131.imageshack.us/my.php?image=screenshot5nl.png)
I have been trying to get into linux for years, but it has never been able to support any of my last 4 laptops wireless cards! it is just so frustrating. if this will not work, i am going to just go back to windows... I have been trying for years and it is not worth it.

compwiz18
July 10th, 2006, 07:04 PM
I have similar problems, after tweaking around endless ammounts of stuff, i got it to here, it says the driver and hardware are bolth working, but nothing shows up!
http://img131.imageshack.us/img131/1071/screenshot5nl.th.png (http://img131.imageshack.us/my.php?image=screenshot5nl.png)
I have been trying to get into linux for years, but it has never been able to support any of my last 4 laptops wireless cards! it is just so frustrating. if this will not work, i am going to just go back to windows... I have been trying for years and it is not worth it.
Can you run sudo iwlist and sudo iwconfig in the Terminal and post your output please?

semkirk
July 11th, 2006, 02:03 AM
I have a Thinkpad 600 (266 Mhz PII) and just picked up the Linksys WPC54G card and the instruction at http://ubuntuforums.org/showpost.php?p=1105667&postcount=218 worked like a charm. Thanks to all who've noodled the various solutions to getting this card to work! Kudos all!

OvERKiLL
July 11th, 2006, 03:09 AM
Usage: iwlist [interface] scanning
[interface] frequency
[interface] channel
[interface] bitrate
[interface] rate
[interface] encryption
[interface] key
[interface] power
[interface] txpower
[interface] retry
[interface] ap
[interface] accesspoints
[interface] peers
[interface] event

overkill@overkill-laptop:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

Max Roswell
July 12th, 2006, 02:19 PM
One question before I try this.

I tried the bcm43xx approach, and almost got it working. Can see networks but can't connect.

Before I try your ndiswrapper approach, is there anything I need to do to remove the bcm43xx stuff, or can it stay where it is?

compwiz18
July 12th, 2006, 05:57 PM
One question before I try this.

I tried the bcm43xx approach, and almost got it working. Can see networks but can't connect.

Before I try your ndiswrapper approach, is there anything I need to do to remove the bcm43xx stuff, or can it stay where it is?
I had the same problem with that; could see networks, but couldn't connect.

Anyway, nope, just run the script, reboot, and you'll have internet :D

Max Roswell
July 12th, 2006, 09:19 PM
If that's true, and it works, I'm sending you a pizza. Seriously.

As a side note, has anyone figured out WHY this particular Broadcom card is so troublesome? What makes it different from the other cards that do work?

damion1974
July 12th, 2006, 10:26 PM
admin@ubuntu:~$ sudo iwlist
Password:
Usage: iwlist [interface] scanning
[interface] frequency
[interface] channel
[interface] bitrate
[interface] rate
[interface] encryption
[interface] key
[interface] power
[interface] txpower
[interface] retry
[interface] ap
[interface] accesspoints
[interface] peers
[interface] event
admin@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g ESSID:"wireless" Nickname:"Broadcom 4318"
Mode:Managed Access Point: Invalid Bit Rate=1 Mb/s
RTS thr:off Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extension


Please help. I have been trying to get this to work for 2 days now.
In the network connection say wireless but win i click on properties it show my wireless card, my networkcard (which works fine win i connect it to the router) and my modem. I click on the wireless card set it properties and try to activate it. It hangs for a few than says active in window. I close it reopen it and its back to an deactive state. In networking tools "lo" loop-back address and etho network card show up but NO wireless card. I have tryed to use the Fn key to turn on the wireless, rebooted, tryed a few things but wireless light has never come on unless i reboot into xp. In Xp everything works fine.

Also have Gateway 7510GX

* Processor: Mobile Athlon 64 3700+ Processor, 2.4 GHz, Socket 754, 1MB L2 Cache, 90nm San Diego Core (includes SSE3 instruction set), 1600MHz HyperTransport
* Motherboard Chipset: ATI Radeon Xpress 200 (RS480) Chipset, SB400 Southbridge, Conexant AC'97 Audio Controller, AC'97 Modem Controller
* Graphics: ATI Mobility Radeon X600 Graphics, 128MB Dedicated VRAM on a 128-bit bus, 128MB Shared HyperMemory, PCI Express x16 Bus, Core 400MHz, memory 260MHz (520MHz Effective)
* Memory/RAM: 1024MB DDR333 PC2700 SDRAM, Two 512MB Samsung modules, 2.5-3-3-7 timings, Expandable to 1.5GB
* Hard Drive: 100GB 4200rpm Hard Disk, Fujitsu MHU2100AT, 8MB Cache, UATA-100 Interface
* Screen: 15.4" WXGA UltraBright Display (1280x800x32)
* Optical Drive: Dual-Layer DVD+/-RW Drive from LG Electronics, Write Speeds: 2.4x Dual Layer DVD+R, 8x DVD+/-R, 4x DVD+/-RW, 24x CD-R, 10x CD-RW, Read Speeds: 24x CD-ROM, 8x DVD-ROM, 3x DVD-RAM (I can't find any confirmation of whether or not this unit can write to DVD-RAM, but I believe it can. The comparable model on LG's website can, but I can't confirm this one)
* 6-in-1 Media Reader: Secure Digital, Multimedia Card, Memory Stick, Memory Stick PRO, Compact Flash, Micro Drive
* Wireless: Broadcom 802.11g Wireless Ethernet Adapter
* LAN: Marvell Yukon PCI-E 10/100 Wired Ethernet Controller
* Ports: 4x USB 2.0, 1x 4-pin FireWire (IEEE1394), 1x S-Video Out, 1x VGA Out, 1x Mic, 1x Headphone, 1x Type II PCMCIA
* Windows XP Home with SP2
using linux-ubuntu 6.06 amd64 version

Still havent got this working but found some info from anouther site about my Gateway 7510gx. http://freewebs.com/ronserver/linux7510gx.html
He didnt get it working either.

Max Roswell
July 13th, 2006, 01:36 AM
I am 99.9 % there!

So I followed all the steps in the top post. Everything worked as advertised. Got the icon in the upper right, it could find wireless networks, everything looked good.

But...it wouldn't connect.

I cursed.

I rebooted into Windows, so I could get online and come here and see what's what. I copied all the troubleshooting stuff to a text file on my shared partition.

I rebooted back to Ubuntu, and now the Network Manager icon WASN'T giving me any wireless networks.

I cursed again.

I went to System > Administration > Networking

My wireless card was there, and it said it was active. I went into its properties. The ESSID from when I tried to get on was still there. I opened Firefox, just to see.

And here I am, connected.

BUT...it looks like network manager's screwy. It still says there are no wireless connections. Actually, it doesn't even list "Enable Wireless" as an option.

EDIT: I've taken my laptop to work, to try to get on the wireless network here. I find that in Administration > Network, I can see the SSID for the network, but I'm unable to get connected at all. I enter the SSID, and the password (in the WEP field), and then it says it's activating the device, but no luck.

I'm going to start over from the beginning and see what I can do.

SECOND EDIT: Okay. So I re-ran the script, rebooted, and everything's working fine. Detected the wireless network, let me send the key, and I'm surfing like a giddy schoolboy. I did NOT go into Administration > Network, and like the man said, I don't intend to. I ain't gonna mess with success.

Compwiz - PM me your pizza address!!!

matteov
July 13th, 2006, 02:26 AM
Have Acer Aspire 3002 with Broadcom 4318. After trying four other configuration instructions, I found your script and ran it. It works perfectly and I want to thank you for that. Network manager shows both wireless wlan and ethernet etho and allows me to switch from one to the other.
My only confusion is that in system/administration/networking, it shows Wireless, Ethernet and Modem connections and they all indicate "not configured".
It all started working before I got to that part of your instructions. I'm not inclined to change anything there since both networks are working. Does Network Manager preclude the need to configure there?
Again, thanks for your script.

Max Roswell
July 13th, 2006, 02:48 AM
EDIT: Post is irrelevant now.

electrocutioner
July 13th, 2006, 04:04 PM
Looks like you have been doing a great job with this,and will make quite a name for yourself compwiz!

Anyways,I have been having the exact same problem as overkill-I wonder if this is a recent bug from a recent change to the scripts you provided?

I am using a compaq r4225ca (r4000-canadian version)with an AMD athlon 64 processor running AMD64 dapper.
It's running on 2.6.15-23-amd64-generic kernal.

I used to run suse 10 on this laptop and was able to compile ndiswrapper and find a working 64 bit driver for the card.

Anyways,I have installed dapper over suse for a try-I had the wireless working briefly with no security on my lan.when i restored wep and stopped broadcasting my ssid I lost it.

At this point (yesterday) I found your post and ran the script while on the wired lan for the 64 bit driver with network manager.It wiped out any reference to eth0 (or whatever one displayed the wireless.)

I ran the commands that you told overkill to run,and have the same results as he posted.

compwiz18
July 13th, 2006, 04:27 PM
Network Manager makes the default network configuration box (the one under system - administration - networking) not work, so don't use it (unless, of course, you have some reason you would want to :P )

electrocutioner
July 13th, 2006, 04:55 PM
Yes,I did notice that-but the only option that network manager seems to be giving is wired network as well....
I also attempted to run the other 64 bit package that is provided,and I did it with an insecure wireless lan.

compwiz18
July 13th, 2006, 05:28 PM
First: I'm just wondering. I have VMware on this computer, and it sometimes makes my network connection funny - i.e. It connects to the network, but can't use the internet for anything. Running sudo dhclient multiple (10) times or so usually fixes the problem...anyone else have the same issue?

Anyone who is having this problem and has VMware installed, try running sudo dhclient many times, until it says that eth1 is bound to some ip...

Second: @electrocutioner - the workingness of the 64-bit driver is debatable...if you have the driver you used in suse then maybe try that?

electrocutioner
July 13th, 2006, 06:36 PM
I found this driver by 'Satsuma' at planet amd a few months back-I remeber trying several variations with this laptop and linuxant,this was the only one that ever worked-it also ran under ndiswrapper under suse and briefly under ubuntu..
is this the same one you were using?

compwiz18
July 13th, 2006, 06:40 PM
I found this driver by 'Satsuma' at planet amd a few months back-I remeber trying several variations with this laptop and linuxant,this was the only one that ever worked-it also ran under ndiswrapper under suse and briefly under ubuntu..
is this the same one you were using?
Nope, the one I'm using came from the Acer website, I believe. Try that one, if it works, I may just update my post :)

electrocutioner
July 13th, 2006, 07:09 PM
I will try it when I get home-do I just replace the inf files in the folder that you provided and run the same script?

Oh yes,BTW?The inf from the acer website never did work on this laptop...

FooAtari
July 13th, 2006, 09:32 PM
Anyone here using a PCI card? i use an Asus WL-138G PCI Adapter, should it still work or is this more for laptops?

Thanks

FooAtari
July 13th, 2006, 10:52 PM
Loosing the will to live....

I seem to be having limited success with The Ravens guide here (http://www.ubuntuforums.org/showpost.php?p=1189681&postcount=105)

But I have a couple of problems...

1. The network manager is not loading at start-up. There is an error relating to network manager when intalling(?) ndiswrapper.

2. I got as far as Step 11 with no problems (or so i thought, it would appear i have a Network Manager problem) and was able to get google, and I'm sure it was access via wireless...

I then got to step 14, but then it came to this step:

"Now push the wifi network connect/disconnect button on your computer..."

I have an Asus PCI adapter and as far as i can tell there is no button...

i tried to go to step 15) UN@CN:~/Desktop# ifdown eth1

And got the following result:

"ifdown: interface eth1 not configured"

Well it is configured in Networking under System menu.

So i thought it was maybe because I had not turned wireless off and on, so I restarted PC. No connection at all, both eth1 and eth0 were deactivated, activated eth1, still not internet connection.

Tried ifdown eth1 again and got same error.... ](*,)

I think i am just a few steps away from getting my wireless card working, any suggestions. PLEASE!

(im on the verge of buying a new, supported, PCI Adapter)

aldegaz
July 14th, 2006, 03:07 AM
Hi...

At last I found a good how to for (rev 02) bcm43xx cards. Also I got my hardware present driver present, wich I didnt before.

Although I see my "eth1" connection and is recognized and everything, it stays idle. I am currently using a pcmcia card to get a wireless connection. I dont have any wireless radar. Any ideas?

Let me paste here my iwlist/iwconfig:

Usage: iwlist [interface] scanning
[interface] frequency
[interface] channel
[interface] bitrate
[interface] rate
[interface] encryption
[interface] key
[interface] power
[interface] txpower
[interface] retry
[interface] ap
[interface] accesspoints
[interface] peers
[interface] event


lo no wireless extensions.

eth0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"kkkkk"
Mode:Managed Frequency:2.462 GHz Access Point: 00:11:95:78:6B:C6
Bit Rate:36 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=24/94 Signal level=-71 dBm Noise level=-95 dBm
Rx invalid nwid:558 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth1 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

kappolo
July 14th, 2006, 11:06 AM
Hi,
i've a big problem trying to run my Broadcom 4318 wireless card on an AMD Turion64x2 with Ubuntu. I tried to run the script posted in the first post, but this is the result:


root@kpelaptop:/home/kappolo# ndiswrapper -i Desktop/drivers/bcmwl5.inf
Installing bcmwl5
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2

root@kpelaptop:/home/kappolo# ndiswrapper -l
Installed ndis drivers:
bcmwl5 invalid driver!

root@kpelaptop:/home/kappolo# dmesg
[...]
[ 238.798440] ndiswrapper version 1.8 loaded (preempt=yes,smp=yes)
[ 238.810322] ndiswrapper (load_wrap_driver:112): loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'

root@kpelaptop:/home/kappolo# cat /var/log/syslog
[...]
Jul 14 11:35:32 localhost kernel: [ 238.798440] ndiswrapper version 1.8 loaded (preempt=yes,smp=yes)
Jul 14 11:35:32 localhost loadndisdriver: loadndisdriver: load_driver(340): coudln't find valid drivers files for driver bcmwl5
Jul 14 11:35:32 localhost loadndisdriver: loadndisdriver: load_driver(361): couldn't load driver bcmwl5
Jul 14 11:35:32 localhost loadndisdriver: loadndisdriver: load_driver(361): couldn't load driver bcmwl5
Jul 14 11:35:32 localhost kernel: [ 238.810322] ndiswrapper (load_wrap_driver:112): loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'


What can I do? Please help me i'm going crazy ](*,)

kappolo
July 14th, 2006, 12:38 PM
If anyone is interested in, i've resolved my problem :-k .

The only thing to do is using this drivers (ftp://ftp.support.acer-euro.com/notebook/ferrari_4000/driver/winxp64bit/80211g.zip) for ndiswrapper instead of using the old ones.

compwiz18
July 14th, 2006, 01:57 PM
Do you have 64bit Ubuntu? Because I'm not sure the 64bit drivers in my post work...

compwiz18
July 14th, 2006, 02:05 PM
@aldegaz: Can you run sudo iwlist eth1 scan please? Can you actually see the network you are trying to connect to, but it won't connect? Can you actually connect to the network, but can't surf the web?

aldegaz
July 14th, 2006, 04:13 PM
compwiz thanks so much for the help.

eth1 gave "no scan results". I cant see the network that I am trying to connect to. I cant connect to the network therefor I cant surf the web.

With the pcmcia card, I can see a whole list of networks available and I can choose where to connect.

The network manager gives me a "No network connection".

electrocutioner
July 14th, 2006, 08:53 PM
Ok,I just now had a chance to try the other driver,but before I had a chance to do anything,the wifi light on the laptop came on when I booted.I had rebooted several times before,and this is the first time this happened.Which is very weird,because the only thing different is that the new 64 bit driver is sitting in a folder in the desktop,uninstalled.
I just ran iwconfig,and suddenly I am showing paramaters on eth1(obviously,as it is now working,I am currently typing from a wireless access.) I even went into into terminal to see if I was hacking in my sleep,but there are no new commands that I forgot that I ran.:rolleyes:
I really hate this,because,it makes it very difficult to determine what I did to get it working,and I would really like to contribute a solution to somebody else,other than saying it was automagically fixed.
Anything I should check for a clue on what happened?I am going away for the weekend,but will check back when I get home.
Lemme just try a quick reboot and see if the magic goes away....
yep,still works-even if I boot into the old kernel...
Now , am I going to have to enter my password into the keyring holder every time I log into the wep secured lan?

compwiz18
July 14th, 2006, 09:05 PM
Sadly enough, yes, you do. One of the most annoying things. You can try wifi-radar (sudo apt-get install wifi-radar) if you have a problem with this (I use wifi-radar) The only downside is wifi-radar doesn't automatically connect at boot.

EDIT: I take that back, it does automatically scan and connect to wireless networks at when you boot; you just have to add /etc/init.d/wifi-radar start to the /etc/rc.local file on a new line, this starts the wifi radar service on boot. I like it better then network manager now :D that I was inspired to go figure out how to make it start automagically :D

aldegaz
July 14th, 2006, 09:18 PM
Hey compwiz...dont forget about me! I was before!

compwiz18
July 14th, 2006, 09:28 PM
@aldegaz: your turn. Does the PCMCIA card use ndiswrapper or not?

aldegaz
July 14th, 2006, 09:34 PM
nope, it just worked out the box

Now, I notice that with Network Manager I cant seem to connect to anything... it just sits there trying and trying...

One of the reasons I am asking for help, is that I searched and found a lot of "how to's" in the forums but every single one of them pointed out that (rev 02) cards wouldnt work.

I did tried however to install ndiswrapper with my drivers etc.. But I would always get "drivers installed, hardware not present".

I even managed to find people over the internet with the same laptop as mine, but with the (rev 03) card. Still no luck with them. Plus, I dont have any linux friend where I live since I just moved here.

Except for YOUR script, it made a diference, by stating (rev 02) would work, and your script made ndiswrapper work with the drivers you supplied.

And to make a long story short, I just feel this time I am only a small step away from returning this ugly PCMCIA card, get my $40 back and buy another Ubuntu book to keep learning to help others.

Thanks for the help... I hope I can still receive the answers from compwiz18.

aldegaz
July 14th, 2006, 09:40 PM
nope it doesnt. The pcmcia card worked out of the box

grrrr I double posted

how do I delete this one?

sublimeprogie
July 15th, 2006, 01:18 AM
ok, i did this to the work, and i thought it went great, but then when i restarted my computer i went to the networks settings gui and my wireless card no longer appeared in it, it did before this.

i dont know what to put for the interface name since it isnt picking up, but here are my wi config

lo no wireless extensions.

eth1 no wireless extensions.

sit0 no wireless extensions.

i think that the wireless use to be under the lo one. i am not positive though.

i cannot connect, (obviously)

FooAtari
July 15th, 2006, 02:29 AM
Any chance of chucking some assistance my way. :p

Last few posts I put cover my main problems....

Its also a PCI card in a a PC not a PCMCIA card, will this cause any problems?

Thanks

compwiz18
July 15th, 2006, 02:58 AM
@sublimeprogie: Your wireless card is eth1. lo is the loopback interface (not sure what the point of it is though)

sublimeprogie
July 15th, 2006, 03:23 AM
ya but ubuntu is telliing me that my ethernet is on eth1 but it wasnt like that before

Patrick Bowen
July 15th, 2006, 03:31 AM
This also got me up and running on a Gateway MX6121 laptop.

Great work. Thanks!

compwiz18
July 15th, 2006, 03:42 AM
@sublimeprogie: What was eth1 before you ran the script?

aldegaz
July 15th, 2006, 04:05 AM
I dont mean to be pushy...but is there any reason why I am not getting some help? If my problem is too hard or there is no solution, I would much appreciate someone letting me know.

I have answered 3 times with the questions I have received.

thanks

compwiz18
July 15th, 2006, 04:19 AM
@aldegaz: I'm sorry, there are a lot of messages, and I lose track sometimes. But anyway, run ndiswrapper -l and tell me what it says. Can you also run sudo ifconfig and post the results? Also lspci | grep Broadcom\ Corporation and dmesg | grep ndiswrapper and dmesg | grep bcm43xx??? Good luck. And post all the results. Thanks.

aldegaz
July 15th, 2006, 05:03 AM
Ok, no problem, thanks again for the help.

ndiswrapper -l

Installed ndis drivers:
bcmwl5 driver present, hardware present


sudo ifconfig

ath0 Link encap:Ethernet HWaddr 00:13:F7:29:2E:A6
inet addr:192.168.15.105 Bcast:192.168.15.255 Mask:255.255.255.0
inet6 addr: fe80::213:f7ff:fe29:2ea6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1541 errors:1368 dropped:0 overruns:0 frame:1368
TX packets:1400 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:200
RX bytes:889523 (868.6 KiB) TX bytes:226508 (221.1 KiB)
Interrupt:169 Memory:def00000-def10000

eth0 Link encap:Ethernet HWaddr 00:03:25:2B:E8:C5
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:193

eth1 Link encap:Ethernet HWaddr 00:14:A5:47:05:26
inet6 addr: fe80::214:a5ff:fe47:526/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:177 Memory:e00f6000-e00f8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:372 (372.0 b) TX bytes:372 (372.0 b)


lspci | grep Broadcom\Corporation

0000:01:06.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
0000:01:09.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)


dmesg | grep ndiswrapper

[17179592.936000] ndiswrapper version 1.8 loaded (preempt=yes,smp=no)
[17179593.008000] ndiswrapper: driver bcmwl5 (Broadcom,02/11/2005, 3.100.64.0) loaded
[17179593.016000] ndiswrapper: using irq 177
[17179594.024000] wlan0: ndiswrapper ethernet device 00:14:a5:47:05:26 using driver bcmwl5, 14E4:4318.5.conf

And lastly dmesg | grep bcm43xx didnt gave me any results

Max Roswell
July 15th, 2006, 12:46 PM
Well, a few days later, everything's still working. I heartily endorse this script!

Two questions:

1. I know that one glitch is that network manager always shows 100% signal strength. Is there an alternate command or something I can use to find my actual signal strength?

2. I find myself strangely tempted to just press the wireless button on my machine, just to see what it does, but it was so much trouble getting this working, that I'm scared to, in case it screws wireless up permanently. Am I being needlessly dumb here?

Again, thanks Compwiz. You get my vote for Forum Guru of the Year.

futureman
July 15th, 2006, 12:59 PM
This how to did not work for me, I'm getting rather frustrated with this. I'm running Ubuntu Dapper for AMD64, i guess my main problem with it is that the script did not work at all, after running it ndiswrapper wasn't even installed, much less any drivers. I would post the output from running the script but have no way of getting it out of linux unless i wrote it all by hand (i'm in xp right now). It did say something about the ndiswrapper package being for i386 not amd64, and there was an error with the network manager install, can't remember exactley what, it's past my bedtime.

Here's some other noob questions i had about it

1. Are these instructions for the tar with network manager or without?

2. in the lspci info, the "0000:05:02.0" doesn't have to match exactley does it?

3. Does it matter if the wireless connection in Administration > Networking is eth1/0 or wlan0, i read somewhere it has to be wlan0, mine is eth1.

4. WEP, if my router uses no security i don't need to touch this right?

Ok, i've been working on this all night and should be asleep, so excuse errors or extra stupid comments.

futureman
July 15th, 2006, 01:02 PM
oh yes, i also have no connect/disconnect buttons on my adapter, just an antenna, i guess i skip that step?

Max Roswell
July 15th, 2006, 01:15 PM
3. Does it matter if the wireless connection in Administration > Networking is eth1/0 or wlan0, i read somewhere it has to be wlan0, mine is eth1.


I don't think it matters. Mine is eth1, and it's working fine. Wish I could answer your other questions.

compwiz18
July 15th, 2006, 01:35 PM
3. Does it matter if the wireless connection in Administration > Networking is eth1/0 or wlan0, i read somewhere it has to be wlan0, mine is eth1.

It can be either.

aldegaz
July 15th, 2006, 02:10 PM
yay! I hope you dont forget me this time... (thanks again)

compwiz18
July 15th, 2006, 03:28 PM
@futureman:


This how to did not work for me, I'm getting rather frustrated with this. I'm running Ubuntu Dapper for AMD64, i guess my main problem with it is that the script did not work at all, after running it ndiswrapper wasn't even installed, much less any drivers. I would post the output from running the script but have no way of getting it out of linux unless i wrote it all by hand (i'm in xp right now). It did say something about the ndiswrapper package being for i386 not amd64, and there was an error with the network manager install, can't remember exactley what, it's past my bedtime.

can you run apt-get --version and uname -a and post the outputs here? This will help determine the problem, I believe.


-----IGNORE-----
OK. So you downloaded the AMD64 version of Dapper? Then you need the AMD64 version of the script, which can be found here (http://ubuntuforums.org/attachment.php?attachmentid=11658&d=1151022196) (includes network manager). If you installed the i386 version, it probably won't work.
---END IGNORE---


1. Are these instructions for the tar with network manager or without?

They work for both.


2. in the lspci info, the "0000:05:02.0" doesn't have to match exactley does it?

Nope, as long as you see bcm4318 in there somewhere.


3. Does it matter if the wireless connection in Administration > Networking is eth1/0 or wlan0, i read somewhere it has to be wlan0, mine is eth1.

Nope, doesn't matter a bit. Mine has been both.


4. WEP, if my router uses no security i don't need to touch this right?

Nope, don't touch it.


oh yes, i also have no connect/disconnect buttons on my adapter, just an antenna, i guess i skip that step?

Yep.


Ok, i've been working on this all night and should be asleep, so excuse errors or extra stupid comments.

Hope it starts working, I know they can be a royal pain.

compwiz18
July 15th, 2006, 03:46 PM
@Max Roswell:


1. I know that one glitch is that network manager always shows 100% signal strength. Is there an alternate command or something I can use to find my actual signal strength?

Well, I'm not positive, but if you run iwlist [NAME_OF_INTERFACE] scan (swap [NAME_OF_INTERFACE] with the name of your wireless card) and find the Signal level: ?? part, look at the number where my question marks are. Like I said, I'm not sure though.



2. I find myself strangely tempted to just press the wireless button on my machine, just to see what it does, but it was so much trouble getting this working, that I'm scared to, in case it screws wireless up permanently. Am I being needlessly dumb here?

:D :D :D BUTTONS!!! Yes, I pressed it. And it still works :D Just be careful, you may have to restart the computer if you press it to find the networks again. And if you do, make sure you turn it back on, cause the computer ain't gonna.

compwiz18
July 15th, 2006, 03:51 PM
@aldegaz: It does work for revision 2 cards. When I run lspci | grep Broadcom\ Corporation, I get:


0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

the same as you. Is this your first attempt at setting the card up, or have you tried other methods? (forgive me if you already told me this)

Also, when I run dmesg | grep ndiswrapper, I get nothing. Can you run cat /etc/network/interfaces and post the output, please?

Hope this helps...

aldegaz
July 15th, 2006, 06:22 PM
I have tried before to set up the card, but ndiswrapper wouldnt recognize the hardware.
With your script, has been the first time I had the card recognized with ndiswrapper.

network interfaces:
auto lo
iface lo inet loopback

auto ath0
iface ath0 inet dhcp
wireless-essid kkkkk

auto eth0
iface eth0 inet dhcp
wireless-essid kkkkk

farno
July 16th, 2006, 07:26 AM
good howto.
is anybody able to help me here http://www.ubuntuforums.org/showthread.php?t=215261&highlight=wireless+acer
?
thanks

compwiz18
July 17th, 2006, 01:56 PM
@aldegaz: Can you add


auto eth1
iface eth1 inet dhcp
wireless-essid kkkkk

to the bottom of your /etc/network/interfaces file?

sublimeprogie
July 17th, 2006, 05:38 PM
@sublimeprogie: What was eth1 before you ran the script?

I think it was still ethernet, i am almost positive that the wireless was eth0

i also noticed after trying again that there actually was some errors that i was missing, here is what the code looks like after i run the ndswrapper (or whatever it is called exactly)


dpkg: error processing ndiswrapper.deb (--install):
package architecture (i386) does not match system (powerpc)
Errors were encountered while processing:
ndiswrapper.deb
Extracting the drivers...
Deleting temporary files...
Changing driver permissions...
Changing working directory...
Removing previous attempts to use ndiswrapper, if any...please ignore errors in this section...
ERROR: Module ndiswrapper does not exist in /proc/modules
./ndiswrapper_setup: line 14: ndiswrapper: command not found
./ndiswrapper_setup: line 15: ndiswrapper: command not found
Removing default driver...
ERROR: Module bcmxx does not exist in /proc/modules
Installing driver through ndiswrapper...
./ndiswrapper_setup: line 19: ndiswrapper: command not found
./ndiswrapper_setup: line 20: ndiswrapper: command not found
./ndiswrapper_setup: line 21: ndiswrapper: command not found
Modprobing ndiswrapper...
FATAL: Module ndiswrapper not found.
Moving back to original working directory...
Deleting more temporary files...
Blacklisting bcm43xx...
Adding ndiswrapper to /etc/modules, so it should load on boot...
Removing excess entries from your network interfaces file...
Installing network-manager-gnome...
dpkg: error processing nm-i386.deb (--install):
package architecture (i386) does not match system (powerpc)
Errors were encountered while processing:
nm-i386.deb
Installation completed.
Please restart your computer.


can i please have the script to remove this, it seems that it has blacklisted my card all together or somehthing to that likes and i would like to try something else. also, has anyone else had success on this script with a mac cause that seems to be where stuff went wrong.

aldegaz
July 17th, 2006, 07:22 PM
I added the text to interfaces. I still get the Network Manager with a (!) sign and a "No network" text when I put the cursor on top.

When I click it, it only gives me the Wired Network option. Even after rebooting, and even if I take out the PCMCIA card.

compwiz18
July 17th, 2006, 08:34 PM
@sublimeprogie: Your problem is that you have a PowerPC...the script was written for an i386 processor...which a PowerPC is not. There is no removal script, but it is pretty easy to undo. Edit /etc/modules and remove the ndiswrapper line. Edit /etc/modprobe.d/blacklist and remove the bcm43xx line. That should uninstall it.

aldegaz
July 17th, 2006, 10:55 PM
This happened with networking restart:


Listening on LPF/ath0/00:13:f7:29:2e:a6
Sending on LPF/ath0/00:13:f7:29:2e:a6
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 13
DHCPOFFER from 192.168.15.1
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPACK from 192.168.15.1
bound to 192.168.15.105 -- renewal in 994310559 seconds.

Iandefor
July 18th, 2006, 01:01 AM
Damn... that's the first thing that's worked so far \\:D/. Thanks!

I've seen a few things that could be improved in the script, so I might look at that a little more closely sometime soon.

sublimeprogie
July 18th, 2006, 07:48 AM
@sublimeprogie: Your problem is that you have a PowerPC...the script was written for an i386 processor...which a PowerPC is not. There is no removal script, but it is pretty easy to undo. Edit /etc/modules and remove the ndiswrapper line. Edit /etc/modprobe.d/blacklist and remove the bcm43xx line. That should uninstall it.

k, thanks for the clarification, does anyone know of some steps to get a power pc wireless to work, this is where i was pointed last, but it seems like i am another step into the forest. at least i am learning stuff along the way though.

if anyone knows of a successful process i would appreciate it though, this house is pretty much completely wireless dependent and in order to use internet on the linux side i have to sit like 3 feet from my fridge where the modem is.

sublimeprogie
July 18th, 2006, 05:30 PM
@sublimeprogie: Your problem is that you have a PowerPC...the script was written for an i386 processor...which a PowerPC is not. There is no removal script, but it is pretty easy to undo. Edit /etc/modules and remove the ndiswrapper line. Edit /etc/modprobe.d/blacklist and remove the bcm43xx line. That should uninstall it.

can somone please tell me how to make a read only file writeable, i tried changing the permissions but it still wouldnt let me edit.

aldegaz
July 18th, 2006, 06:02 PM
you have to place "sudo" command to get the permission.

Just type: sudo gedit /etc/modprobe.d/blacklist

compwiz18
July 19th, 2006, 05:51 PM
@Iandefor: I'm glad it worked. It is my first script, so it is bound to have problems - for instance, it should probably check if you sudo'ed it before it attempts to run.

aldegaz
July 19th, 2006, 05:57 PM
compwiz... you never managed to answer my last reply:


Default Re: HOWTO: Broadcom 4318 Wireless Cards
I added the text to interfaces. I still get the Network Manager with a (!) sign and a "No network" text when I put the cursor on top.

When I click it, it only gives me the Wired Network option. Even after rebooting, and even if I take out the PCMCIA card.

compwiz18
July 19th, 2006, 06:01 PM
This happened with networking restart:
Listening on LPF/ath0/00:13:f7:29:2e:a6
Sending on LPF/ath0/00:13:f7:29:2e:a6
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 13
DHCPOFFER from 192.168.15.1
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPACK from 192.168.15.1
bound to 192.168.15.105 -- renewal in 994310559 seconds.
When you say that, what do you mean? and is that with the PCMCIA card or the one that we are trying to make work?

d_b
July 19th, 2006, 08:55 PM
Hello,

Compwiz: thanks to your guide, I managed to get my Broadcom 4318 (Acer Aspire 3620) to work! I can connect to wireless networks and go online if I configure it through the Gnome Networking tool.

However, I can't get Network Manager to cooperate. I removed everything but lo from my /etc/network/interfaces. I can see wireless networks in the Network Manager applet, but choosing one just causes NM to swirl for a while (maybe 10 min) then time out.

ndiswrapper -l


Installed ndis drivers:
bcmwl5 driver present, hardware present

dmesg | grep ndiswrapper


[4294691.756000] ndiswrapper version 1.8 loaded (preempt=yes,smp=no)
[4294691.835000] ndiswrapper: driver bcmwl5 (Broadcom,02/11/2005, 3.100.64.0) loaded
[4294691.843000] ndiswrapper: using irq 177
[4294693.003000] wlan0: ndiswrapper ethernet device 00:16:ce:0c:18:0c using driver bcmwl5, 14E4:4318.5.conf


iwconfig


lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:11 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

cat /etc/network/interfaces


auto lo
iface lo inet loopback


If feel like I'm getting close.. I mean the wireless works, but Network Manager is so convenient that getting this to work as well would be great. Any help is much appreciated!

compwiz18
July 19th, 2006, 09:11 PM
I use wifi-radar, that works great too.

Are you using the traditional managed network, or is it ad-hoc? If it is ad-hoc, we will have to do a little work. and while you are at it, can you run sudo iwlist eth1 scan?

d_b
July 19th, 2006, 10:19 PM
I use wifi-radar, that works great too.

Are you using the traditional managed network, or is it ad-hoc? If it is ad-hoc, we will have to do a little work. and while you are at it, can you run sudo iwlist eth1 scan?

Nice! wifi-radar does work flawlessly. I think I'm going to stick with this for now.. Thanks a lot!

Btw, sudo iwlist eth1 scan returnes the expected long list of nearby access points, all managed mode networks with varying signal strengh intensity. All of them are open as well. I can see about 12 of them so I won't paste this here.

I won't waste your time further since wifi-radar works for me, unless you have a quick idea why Network Manager isn't playing along.

d.

smokeyd
July 20th, 2006, 12:38 AM
Hey compwiz18, it works nicely on my acer travelmate 2420. Thanks!

I've got only one small annoyance.
I've added the original bcm43xx to the blacklist and added ndiswrapper to /etc/modules, and that does work. But when I startup the laptop, it can't find any network.
When I rmmod ndiswrapper and modprobe ndiswrapper, all networks are found. I have to do this everytime I startup the laptop, just remove and add the kernel module. But then it works perfectly. Thanks again!

compwiz18
July 20th, 2006, 01:11 AM
Nice! wifi-radar does work flawlessly. I think I'm going to stick with this for now.. Thanks a lot!

Btw, sudo iwlist eth1 scan returnes the expected long list of nearby access points, all managed mode networks with varying signal strengh intensity. All of them are open as well. I can see about 12 of them so I won't paste this here.

I won't waste your time further since wifi-radar works for me, unless you have a quick idea why Network Manager isn't playing along.

d.
No idea, sorry. But wifi-radar is written in Python, so if you any programming experience at all, it is not to hard to open the executable and edit the source...you can make it do whatever you want, it there is something you have a problem with.

compwiz18
July 20th, 2006, 01:19 AM
Hey compwiz18, it works nicely on my acer travelmate 2420. Thanks!

I've got only one small annoyance.
I've added the original bcm43xx to the blacklist and added ndiswrapper to /etc/modules, and that does work. But when I startup the laptop, it can't find any network.
When I rmmod ndiswrapper and modprobe ndiswrapper, all networks are found. I have to do this everytime I startup the laptop, just remove and add the kernel module. But then it works perfectly. Thanks again!
That's weird.

But you can add those 2 lines to /etc/rc.local (all commands here are run as the superuser, so don't worry about that).

So add


rmmod ndiswrapper
modprobe ndiswrapper

aldegaz
July 20th, 2006, 01:51 AM
that would be the card that I am trying to get to work (rev 02)

futureman
July 20th, 2006, 12:16 PM
I am still unable to get this to work, here's what you asked for.

__________________________________________________ _______________
apt-get --version
apt0.6.43.3 Ubuntu2 for linux amd64 compiled on Apr 18 2006 19:47:31
Supported modules:
*Ver: Standard.deb
*Pkg: Debian dpkg interface (priority 30)
S.L: 'deb' Standard binary tree
S.L: 'deb-src' Standard Debian source tree
Idx: Debian Source Index
Idx: Debian Package Index
Idx: Debian dpkg Status file

uname -a
Linux mike-desktop 2.6.15-23-amd64-generic #1 SMP PREEMPT Tue May 23 13:45:47 UTC 2006 x86_64 GNU/Linux
__________________________________________________ _______________

and when i run this script from bcm4318x64.tar.gz
__________________________________________________ _______________
sudo ./ndiswrapper_setup
THIS IS THE 64-BIT VERSION OF THE SCRIPT. IF YOU DON'T HAVE 64-BIT UBUNTU THIS SCRIPT WILL NOT WORK
Installing ndiswrapper...
dpkg: error processing ndiswrapper.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while preocessing:
ndiswrapper.deb
__________________________________________________ _______________

any ideas??

TFrog
July 21st, 2006, 03:51 AM
Between the information in various Ubuntu wiki articles I was able to get my Compaq Presario R4125US Broadcom BCM4318 equipped laptop up and running wirelessly in Kubuntu. My only problem at this point is to get it to connect on boot to my network that runs WPA-PSK security. I can get it to connect with Knetworkmanger after boot but will not automatically connect to my network. Minor pain but would be nice if I could avoid this. Any help would be appreciated. I've had more response here than in the Kubuntu forums so maybe you kind folks could help out again.

compwiz18
July 21st, 2006, 04:29 AM
I am still unable to get this to work, here's what you asked for.

__________________________________________________ _______________
apt-get --version
apt0.6.43.3 Ubuntu2 for linux amd64 compiled on Apr 18 2006 19:47:31
Supported modules:
*Ver: Standard.deb
*Pkg: Debian dpkg interface (priority 30)
S.L: 'deb' Standard binary tree
S.L: 'deb-src' Standard Debian source tree
Idx: Debian Source Index
Idx: Debian Package Index
Idx: Debian dpkg Status file

uname -a
Linux mike-desktop 2.6.15-23-amd64-generic #1 SMP PREEMPT Tue May 23 13:45:47 UTC 2006 x86_64 GNU/Linux
__________________________________________________ _______________

and when i run this script from bcm4318x64.tar.gz
__________________________________________________ _______________
sudo ./ndiswrapper_setup
THIS IS THE 64-BIT VERSION OF THE SCRIPT. IF YOU DON'T HAVE 64-BIT UBUNTU THIS SCRIPT WILL NOT WORK
Installing ndiswrapper...
dpkg: error processing ndiswrapper.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while preocessing:
ndiswrapper.deb
__________________________________________________ _______________

any ideas??
My bad. Looks like a script error. Open up the package manager (Synaptic) and install ndiswrapper-utils (or apt-get install ndiswrapper-utils). Then try running the script again.

futureman
July 21st, 2006, 10:48 AM
I do not have any internet connection in linux, i have to use xp, how would i get that package in xp, ndiswrapper-utils, so i could put it on a cd?

futureman
July 21st, 2006, 11:58 AM
Wow, I got it to work, I had to download the 64 bit version of ndiswrapper, and use drivers off the list on the ndiswrapper home page ( the drivers in the tar from this how to wouldn't work for me), then I did a fresh install of Ubuntu and pointed your script to use the drivers and ndiswrapper i downloaded, it didn't work at first and I almost gave up, but decided to reboot, after that it worked fine.

Thanks compwiz for having this how to and keeping up with it. Might want to look into the 64 bit version of your script a little though.

electrocutioner
July 22nd, 2006, 02:34 AM
hi, electro again-
I re-installed 6.06 32 bit version this time (too many proggs i needed not ready for 64amd)
anyways,using your 32 bit script gets me up and running,but not with wep.
also,im network manager doesn't twirl when it connects,andim not getting any 'keychain'coming up to ask me for my key(maybe need to turn something on?)
I have tried entering keys manually,editing etc/networks/interfaces-both with just lo appearing as your script writes it,and with my network info

heck,i even tried entering my keys with hyphens every 4 digits like a few postings have suggested....

here is my info

this is what i get from % iwconfig

eth0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

and from :~$ iwlist eth0 scan
eth0 Scan completed :
Cell 01 - Address: xx:xx:xx:xx:xx:xx
ESSID:"xxxxxxxxx"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.452 GHz (Channel 9)
Quality:0/100 Signal level:-75 dBm Noise level:-256 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

here is my interfaces script

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp
wireless-essid xxxxxxxxx
wireless-key xxxxxxxxxx


thanks for the help


EDIT----k Its running wep now.
had to install wifiradar and select the right settings.strangely,it wants 'mode' to be set as blank even though it lists it as 'managed'in wifiradars display.
oh well,on to wpa next!

btw great work compwiz!I set up everything very quickly using your scripts.one note though,there are some dependencies that are not present on a fresh install with updates applied...namely
dhcdbd
libnl1-pre6
libnm-util0

it would be very easy to miss that if you didn't understand what errors the script was generating.

basherbob
July 24th, 2006, 05:16 AM
Awsome tutorial. However I came across this problem when I was trying to install the wraaper:

basherbob@basherbob-laptop:~/Desktop$ sudo ./ndiswrapper_setup
THIS IS THE 64-BIT VERSION OF THE SCRIPT. IF YOU DON'T HAVE 64-BIT UBUNTU, THIS SCRIPT WILL NOT WORK.
Installing ndiswrapper...
dpkg: error processing ndiswrapper.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
ndiswrapper.deb
Extracting the drivers...
Deleting temporary files...
Changing driver permissions...
Changing working directory...
Removing previous attempts to use ndiswrapper, if any...
./ndiswrapper_setup: line 15: ndiswrapper: command not found
./ndiswrapper_setup: line 16: ndiswrapper: command not found
Removing default driver...
ERROR: Module bcmxx does not exist in /proc/modules
Installing driver through ndiswrapper...
./ndiswrapper_setup: line 20: ndiswrapper: command not found
./ndiswrapper_setup: line 21: ndiswrapper: command not found
./ndiswrapper_setup: line 22: ndiswrapper: command not found
Modprobing ndiswrapper...
Moving back to original working directory...
Deleting more temporary files...
Blacklisting bcm43xx...
Installation completed.
Please check the wifi light on your computer.
If it is on, installation was successful.
Please make sure to exit superuser mode by typing exit.


Even though I downloaded this file "bcm4318x64.tar.gz" it complains I have the wrong package architecture. hhhmmm

Iandefor
July 24th, 2006, 05:21 AM
@Iandefor: I'm glad it worked. It is my first script, so it is bound to have problems - for instance, it should probably check if you sudo'ed it before it attempts to run. Not a bad thought. I've been sitting on my improvements pretty much since I made that post. I'll re-post them after double-checking everything soon.

Iandefor
July 25th, 2006, 12:55 AM
You were missing a hash-bang... so I fixed that. I also added a check to make sure the user is running a Broadcom Wireless 4318 chipset, the ability to log the results of most of the commands, and a question at the end to see if the user wants to reboot.

EDIT: D'oh! The first version I uploaded was bad... here's the good version :).

hollowhead
July 25th, 2006, 11:12 AM
This looks very useful and I will give it a try. I tried running my brand new dapper CD off the CD w/o install. It gave an error message about the wifi card (which is this model) on boot something about a broadcom 43xx.wrf file not being found. But both the network manager and device manager correctly see it as a broadcom 4318 (eth1). When I install will I need to to do the howto or will a full install set it up with out recourse to the above?

homestudio54
July 25th, 2006, 05:30 PM
I can never thank you enough!

I'm a newbie to linux and was about to give up and go back to windows when i can't make my wireless card to function for two days.

through countless switching of linux distro's, attemping to follow forum tips, i stumbled upon your thread. i just followed your instructions abd voila! my card worked.

thank you very much.

have to learn to play dvds in totem. :D

mrojas73
July 26th, 2006, 05:32 AM
Ho do you revert from this, I didn't realize that my card was recognized and I followed this guide and now the card is gone, not showing under networking.

Thanks

beetlejuice321
July 27th, 2006, 04:07 AM
My System:

Kubuntu 6.06 Dapper

Compaq V5105 (AMD 3300+)

Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) 000:06:02.0 0280: 14e4:4318 (rev 02)



Hey this is just an FYI of what worked for me!

I did end up using the latest version of ndiswrapper (however any version will probably work).

And thanks for the drivers comwiz18! I got several copies to load appropriately. From both here (http://ubuntuforums.org/showthread.php?t=197102) and here (http://ndiswrapper.sourceforge.net/mediawiki/index.php/List)

But after installing ndiswrapper. And running...

sudo rmmod bcm43xx
ndiswrapper -i (your driver)
modprobe ndiswrapper

(“lsmod” verified ndiswrapper loaded)


Nothing seemed to work. I even tried your script here (http://ubuntuforums.org/showthread.php?t=197102).

I could see my wireless network card using KDE Network-Manager when I used an appropriate driver. But connecting/activating it always caused the system to hang! For a week I couldn't figure things out!

Then one day, I pushed that damn little "wireless antenna" button on top of my keyboard (windows activates this feature upon bootup). Every post I read said that in Linux those buttons didn't matter. But as soon as I pushed mine after loading the ndiswrapper driver module...

Whalla!!! Everything works perfect! I have 54/Mb connection (or so my system says). I can browse all wireless networks. Everthing works perfectly!

Hmm..I wonder how many other people have made this mistake with their systems?...

vvlist
July 27th, 2006, 06:05 AM
Hello, I am helping a friend setup Dapper on his Gateway laptop. It has the 4318 in it. I installed the script at the beginning of this howto. Upon restart, networks are viewable with Network Manager (using GNOME). But when trying connect it times out and reverts back to the ethernet connection. I read through this howto, and did not get a straight forward answer to this issue, can anyone point me in the right direction?
Here is the lspci | grep Broadcom\ Corporation:
0000:05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)


Here is the iwconfig:
lo no wireless extensions.

eth1 no wireless extensions.

eth0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

This a fresh Dapper install, if anyone could help, I would be very grateful. Thanks.

hendri
July 27th, 2006, 11:03 AM
it work for my acer aspire 3002NLCI model
than' u very much, it wonderful tutorial

saif
July 27th, 2006, 05:24 PM
Hello,

Finally I got my broadcom to work, for some reason, I can't get it to connect unless I use NetworkManager, I was so excited it finally worked, but then, my mouse started behaving weirdly, I thought it was a synaptics touchpad driver, did everything to fix it, tried installed free86 driver for it, played with xorg.conf, nothing fixed it, so I thought maybe this is because of all my attempts to fix stuff, changing links and all that, so I decided to try from a clean install of ubuntu, the mouse worked fine after the install, but the minute I start using the bcm4318, the mouse start jumping around the screen, and then it h stops responding to clicks, if i go to tty1 and switch back to gnome, it starts working again for 1 minute or so, then it crashes again! has any1 had a problem like this?! it makes the pc unusable, really annoying, I am now using a prism54 network card, and i don't have any problems, so i guess the problem is with the bcm4318!

the machine is a HP Pavilion 5094, AMD64 running latelst x64 K8 kernel.

vvlist
July 27th, 2006, 10:49 PM
Hello, I am helping a friend setup Dapper on his Gateway laptop. It has the 4318 in it. I installed the script at the beginning of this howto. Upon restart, networks are viewable with Network Manager (using GNOME). But when trying connect it times out and reverts back to the ethernet connection. I read through this howto, and did not get a straight forward answer to this issue, can anyone point me in the right direction?
Here is the lspci | grep Broadcom\ Corporation:

Here is the iwconfig:
This a fresh Dapper install, if anyone could help, I would be very grateful. Thanks.

So no one has any idea? I'm trying to convert my friend to linux, no wireless is going to be a killer. :( I've tried this script, and found the files on the gateway site, and used them with ndiswrapper.

namityadav
July 28th, 2006, 07:27 PM
I also have the same problem. Wireless works just fine if I don't use NetworkManger. If I try to use NetworkManager for wireless, then although the manager shows all available networks, but it never connects (Times out) to them.

I really need to use NetworkManager to be able to switch between Ethernet / Different Wireless easily.

ps. I have a 4318 working through ndiswrapper. And I've checked my system for any other wifi application, and there are none

EDIT:

Guys,

I found one workaround (Till the good people at NetworkManager / ndiswrapper behave nicely with each other). I removed NetworkManager and installed netapplet instead (Obviously I had to enable the interfaces in /etc/network/interfaces again). It now lets me switch between eth0 and eth1 and lets me chose the wireless networks. Just what I wanted.

Hope this helps someone.

DougW
July 30th, 2006, 02:07 AM
Thank you. It worked perfectly. I thought I may have to buy another manufactures card just to make it work.

BustedChicken
August 2nd, 2006, 04:20 AM
Thanks, this worked great. I haven't read all the threads in this post yet, but does this support wpa. I didn't see an option for WPA.

astra2000
August 2nd, 2006, 11:41 PM
not working 4 me :(

acer ferrari 4000 amd64 (turion) on ubuntu 6.06

root@virus-laptop:~# lspci | grep Broadcom\ Corporation
0000:05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express (rev 11)
0000:06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
root@virus-laptop:~#

Danny Boy
August 4th, 2006, 03:58 PM
I cannot thank you enough, compwiz! I installed Ubuntu on my sister laptop a couple of hours ago and have been pulling my hair out trying to get the wireless card to work, 2 hours search and I found this thread. Your script works perfectly!

Now to convice her to drop Winblows :p

steveob
August 4th, 2006, 10:31 PM
Thank goodness I found this post. After hours of trying all sorts, took just 5 mins to get my Dell Inspiron 1300 going. Many thanks

Iandefor
August 5th, 2006, 01:47 AM
not working 4 me :(

acer ferrari 4000 amd64 (turion) on ubuntu 6.06

root@virus-laptop:~# lspci | grep Broadcom\ Corporation
0000:05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express (rev 11)
0000:06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
root@virus-laptop:~# Doesn't tell us much... care to share more? Because that command you ran worked perfectly.

astra2000
August 5th, 2006, 12:56 PM
ok, here is all the step's i made:



virus@virus-laptop:~$ lspci | grep Broadcom\ Corporation
0000:05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit E thernet PCI Express (rev 11)
0000:06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)



IF YOU DOWNLOAD THE ONE THAT INCLUDES NETWORK MANAGER, YOU MUST USE NETWORK MANAGER, IT IS NOT OPTIONAL.

* If you have no idea what you want, use this one here.

(I choose this one)


-------------------------------------------------------



virus@virus-laptop:~$ cd ~/Desktop
virus@virus-laptop:~/Desktop$ tar -xf bcm4318.networkmanager.tar.gz
virus@virus-laptop:~/Desktop$




virus@virus-laptop:~/Desktop$ sudo ./ndiswrapper_setup
Password:
Installing ndiswrapper...
(Reading database ... 85657 files and directories currently installed.)
Preparing to replace ndiswrapper-utils 1.8-0ubuntu2 (using ndiswrapper.deb) ...
Unpacking replacement ndiswrapper-utils ...
Setting up ndiswrapper-utils (1.8-0ubuntu2) ...

Extracting the drivers...
Deleting temporary files...
Changing driver permissions...
Changing working directory...
Removing previous attempts to use ndiswrapper, if any...please ignore errors in this section...
Driver bcmwl5a is not installed.Use -l to list installed drivers
Removing default driver...
ERROR: Module bcmxx does not exist in /proc/modules
Installing driver through ndiswrapper...
Installing bcmwl5
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Installed ndis drivers:
bcmwl5 driver present, hardware present
modprobe config already contains alias directive

Modprobing ndiswrapper...
Moving back to original working directory...
Deleting more temporary files...
Blacklisting bcm43xx...
Adding ndiswrapper to /etc/modules, so it should load on boot...
Removing excess entries from your network interfaces file...
Installing network-manager-gnome...
(Reading database ... 85657 files and directories currently installed.)
Preparing to replace network-manager 0.6.2-0ubuntu7 (using nm-i386.deb) ...
Unpacking replacement network-manager ...
Setting up network-manager (0.6.2-0ubuntu7) ...
* Reloading system message bus config [ ok ]
* Stopping NetworkManager daemon [ ok ]
* Starting NetworkManager daemon [ ok ]
* Stopping NetworkManager dispatcher [ ok ]
* Starting NetworkManager dispatcher [ ok ]

Installation completed.
Please restart your computer.
After the restart, please look for the network manager icon in the icon try (if you haven't messed with the gn ome panels, it is in the top right corner of the screen) and select the network you want to connect to.
If you have problems, please post on the forums for help.
virus@virus-laptop:~/Desktop$


-------------------------------------------------------------------------

Use the internet (you will have to open the System menu at the top of the screen, go to Administration, and then click Networking. Configure the interface eth1 or wlan0, and connect to your wifi network)

(I configure the wifi interface eth1) and it works:D : :D :D :D :D :D



tnks8)

tdwester
August 6th, 2006, 01:36 AM
Just wanted to say thank you it works great on my HP L2000 !!!!

nhepburn
August 6th, 2006, 03:29 AM
Doh!!!! This isn't working for me. The machine is a Presario V2000 (someone below on this thread successfully got a V2000 working with your solution so it should work). Here's the results of the iwlist and iwconfig scans:
eth1 Scan completed :
Cell 01 - Address: 00:13:46:A4:E9: DC
ESSID:"Xavier"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-47 dBm Noise level:-256 dBm
Encryption key: off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

neil@Rogue:~$
neil@Rogue:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key: off
Power Management: off
Link Quality: 0 Signal level:0 Noise level:0
Rx invalid nwid: 0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.


I made sure that the /etc/network/interfaces file doesn't have anything except the loopback device (they were removed by the ndiswrapper_setup script). However, if I go into System -> Administration -> Networking and enable the wifi card in there, it puts an entry in /etc/network/interfaces.

Anyhow, when I click on the network manager icon it shows my wireless network and correctly identifies the access point. However, when I click on the desired ESSID the icon just spins and spins and eventually times out. I've checked and wifi-radar is not installed.

Any help would be greatly appreciated.

machine.screw
August 6th, 2006, 11:16 AM
OK fallowed the instructions and every thing seems to work. Here is what makes me think things are working:

dmesg | grep ndiswrapper
[17179591.788000] ndiswrapper version 1.8 loaded (preempt=yes,smp=yes)
[17179591.880000] ndiswrapper: driver bcmwl5 (Broadcom,02/11/2005, 3.100.64.0) loaded
[17179591.888000] ndiswrapper: using irq 217
[17179593.044000] wlan0: ndiswrapper ethernet device 00:14:a5:7e:ef:f8 using driver bcmwl5, 14E4:4318:103C:1355.5.conf

and here:

dmesg | grep wlan0
[17179593.044000] wlan0: vendor: ''
[17179593.044000] wlan0: ndiswrapper ethernet device 00:14:a5:7e:ef:f8 using driver bcmwl5, 14E4:4318:103C:1355.5.conf
[17179593.044000] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK

the problem arises when i open System --> Administration --> Networking it shows:
Wireless Connection
The interface eth1 is not configured
and this is what shows up when the bcm43xx module is loaded.
Though lsmod | grep bcm43xx doesn't show that it's loaded
This is an mini pci card.

So what I want to know is, how do I get ndiswrapper to use eth1 or have the card come up as wlan0?

salsa95
August 6th, 2006, 02:53 PM
While the instructions are very good, the tar.gz pkg for 64bit systems seems to have a problem:

I'm on a HP dv500z, Turion64,

When I run the script, I get the following errors:

greg@newbielaptop:~/Desktop$ sudo ./ndiswrapper_setup
Installing ndiswrapper...
dpkg: error processing ndiswrapper.deb (--install):
package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
ndiswrapper.deb
Extracting the drivers...
Deleting temporary files...
Changing driver permissions...
Changing working directory...
Removing previous attempts to use ndiswrapper, if any...please ignore errors in this section...
./ndiswrapper_setup: line 14: ndiswrapper: command not found
./ndiswrapper_setup: line 15: ndiswrapper: command not found
Removing default driver...
ERROR: Module bcmxx does not exist in /proc/modules
Installing driver through ndiswrapper...
./ndiswrapper_setup: line 19: ndiswrapper: command not found
./ndiswrapper_setup: line 20: ndiswrapper: command not found
./ndiswrapper_setup: line 21: ndiswrapper: command not found
Modprobing ndiswrapper...
Moving back to original working directory...
Deleting more temporary files...
Blacklisting bcm43xx...
Adding ndiswrapper to /etc/modules, so it should load on boot...
Removing excess entries from your network interfaces file...
Installing network-manager-gnome...
(Reading database ... 72049 files and directories currently installed.)
Preparing to replace network-manager 0.6.2-0ubuntu7 (using nm-amd64.deb) ...
Unpacking replacement network-manager ...
dpkg: dependency problems prevent configuration of network-manager:
network-manager depends on libnl1-pre6; however:
Package libnl1-pre6 is not installed.
network-manager depends on libnm-util0; however:
Package libnm-util0 is not installed.
network-manager depends on dhcdbd (>= 1.10-0ubuntu2); however:
Package dhcdbd is not installed.
dpkg: error processing network-manager (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
network-manager
Installation completed.
Please restart your computer.
After the restart, please look for the network manager icon in the icon try (if you haven't messed with the gnome panels, it is in the top right corner of the screen) and select the network you want to connect to.
If you have problems, please post on the forums for help.

Of course, this sort of hoses up the wifi.... ](*,)

Any idea where I can get the 64bit NDISWRAPPER.DEB?