PDA

View Full Version : [ubuntu] Trying to upgrade from 11.10 to 12.04



Pacane
May 1st, 2012, 04:47 PM
When I logged in on my Ubuntu server I got the "new version available message", so I chose to upgrade. The process went fine and then I rebooted.

However, after the reboot, I still have the message about the "new version available". When I type do-release-upgrade (-d) it tells me there's no new version available.

Now, when I look at uname -r, I thought it should be something like 3.xxxx but I'm still at 2.6.39.1-x86_64

When I do:

lsb_release -a [11:40:17]
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
But when I do a sudo apt-get update it checks the sources on "precise" instead of "oneirc"

Did the upgrade go fine, or I'm still missing something?

And yes, I tried sudo apt-get update and upgrade.

Thanks.

jerrrys
May 1st, 2012, 07:12 PM
A long shot, but maybe your mirror has yet to update. Try another one.

And that (-d) wont work, just:

do-release-upgrade

Pacane
May 1st, 2012, 08:34 PM
Yeah well the (-d) meant that I tried with and without -d... Maybe it wasnt explicit enough :P

jerrrys
May 2nd, 2012, 01:01 AM
Yeah well the (-d) meant that I tried with and without -d... Maybe it wasnt explicit enough :P

Actually I was not explicit enough; -d don't work. Or don't think you will get offered 12.10 yet:)

Pacane
May 2nd, 2012, 03:06 AM
Well, here's the output:


sudo do-release-upgrade [15:46:32]
Checking for a new Ubuntu release
No new release found

jerrrys
May 2nd, 2012, 03:29 AM
You have looked at your sources.list and its all precise?

That kernel looks like a leftover from several upgrades ago.

Maybe you should try doing a full upgrade.

sudo apt-get dist-upgrade

But as you know Im sure, kernel upgrades can break things.

Pacane
May 2nd, 2012, 04:19 AM
Well I tried that too, here's the output :



o bin -> sudo apt-get dist-upgrade [23:18:43]
[sudo] password for joel:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
libboost-dbg libboost-dev libboost-iostreams-dev libboost-python-dev libboost-serialization-dev libboost-test-dev
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.