View Full Version : [ubuntu] How do I ditch workspaces in 12.04

April 30th, 2012, 07:14 PM
I find workspaces to be nothing but an annoyance. I'd like to remove the extra workspaces and remove the workspace switcher from the dash. How can I do this?

May 1st, 2012, 02:24 AM
I would recommend setting the number of workplaces to 1 and disabling the Expo short-cut key. You can't disable expo it self because the Unity plug-in depends on it. I don't have the faintest clue how to remove the Dash key. Probably somewhere out there in a file there is a line that specifies, but I don't know what it is.

Pardon me if you already know the below.
To do above use Compiz Config Settings Manager The package is ccsm if you like to install with apt-get. You can find it in the software centre by searching Compiz.

Compiz controls a large portion of your desktop, so you want to be careful. When you open it, it warns you about not touching stuff and it means it. If something goes horrible wrong open a terminal window (or if things are so terrible that you can't do that, press control-alt-F1) and enter unity --reset. That should fix everything.

To make there only one window, open Compiz Config Settings Manager and click on General settings. The last tab is desktop size. Change the horizontal and vertical size to 1.

To disable keyboard shortcut click on Desktop (above Effects) and click on Expo. Top choice is Expo key, click on the keyboard shortcut box and uncheck expo. Don't disable the plugin, bad things will happen.

May 1st, 2012, 07:56 PM
Thanks. Now if I can just get rid of that useless button...

May 1st, 2012, 08:24 PM
Thanks. Now if I can just get rid of that useless button...
If you are referring to the workspace switcher icon in the 'launcher' then after setting Ws's to 1 just log out/in. It will be gone

May 31st, 2012, 10:42 AM
Is there any other way to hide switcher? Spread no longer works after setting 1 workspace.