View Full Version : [ubuntu] Tried to upgrade from 10.04 to 12.04, now hanging at 'Ubuntu' screen, what can I do?

April 30th, 2012, 02:15 AM
I first made sure I had installed all available upgrades for 10.04, and checked that my Update Manager settings were right for showing the 12.04 upgrade, but I didn't see it. (I did this yesterday.) So I did a quick Google and found this page (http://http://askubuntu.com/questions/125392/no-new-release-found-when-upgrading-a-from-10-04-lts-to-12-04-lts), and ran update-manager -d from the command line. It went through the download, started installing, and at this point I wanted to make sure I didn't have any other processes running so I opened the system monitor from the taskbar, as well as a terminal. These opened, but I noticed that the windows no longer had the minimize-maximize-close buttons, and moreover I couldn't close them from the bar at the bottom. Nor at this point was I able to switch between desktops. The install proceeded until it came to a console prompt. I tried responding with the default (I.e., 'n' keyboard input) but the console didn't take the input; it was unresponsive. So I restarted the computer and the bootup procedure (from GRUB, only 10.04 is shown in the menu) appeared to hang on the low-res screen 'Ubuntu' and the 5 progress dots. So I've restarted and gotten to the command line in recovery mode. What to do now? :( NB gcc 4.6.3 is installed so I know the installation got at least that far.