View Full Version : [ubuntu] 12.04 upgade fails: GLIBC_2.14 not found

April 29th, 2012, 08:26 AM
The upgrade hung at the 'installing files' stage. Left it overnight and then did a restart this morning. Now won't boot.

AMD M2A-VM (memory checked and was fine approx 2 months ago)

Upgraded from Ubuntu 11.10 (11.04 was a clean install IIRC).

Any quick fixes or do I do a fresh install?

April 30th, 2012, 07:02 AM
Well no idea what caused this but I tried upgrading to LinuxMint 12. That initially worked but then I got various problems. My mac keyboard stopped working so I replaced it with another one and that was ok. The screen resolution was very low. I tried to install the NVidia driver but that failed (unfortunately I forgot to note the error in jockey.log but it wasn't very clear anyway).
Then I did the updates and then it wouldn't boot but instead went into a utility called 'Busybox'. The 2nd keyboard stopped working at that point.
Finally I created a new partition on the disk and did a clean install of LinuxMint. That's working fine. I can't find anything wrong with the hardware. The original files are all there (minus a few that were removed during the original failed update).

So it seems the problem is the update mechanism is broken. This is really annoying as I have 2 more machines with 11.10 that I would really like to upgrade to the new kernel.

May 2nd, 2012, 08:45 AM
Might want to check out:


Mostly worked for me, but I'm having other problems at the moment.

I found this as a reported, but it looked like unreproducible bug in the upgrade process.

I've also got this question unsolved at: