View Full Version : [SOLVED] 12.4 install and NO DESKTOP at all

April 29th, 2012, 04:17 AM
I've just pressed the button on the 12.4 install, and the result is a completely blank desktop.
WTF do I do now?

Hardware: Lenovo R61 laptop, x86_64, 4Gb.

1. The login screen is present, after bootup. Logging in looks kinda normal, though there are a few screen-scrambling errors after I enter the password.

2. After setting the BG color, there is NOTHING else. No taskbar, no menus, no icons of any sort.
No response to mouse clicks. Ctrl-alt-del does work to log me out, that's it.

3. I can log in on a console terminal (ctrl-alt-F1). As far as I can see, most of the user filesystem is as it should be.

4. ~/.xsession-errors contains 30k of lines like:
gnome-session[2032]: Gtk-WARNING: Theme parsing error: gtk-widgets.css:1515:46: Unrecognized image format
(gnome-settings daemon:2105) GLib-CRITICAL **: g_variant_new_string: assertion `string != NULL' failed.

5. /var/sys/syslog contains lines like
gnome-session[2032]: CRITICAL: We failed, but the fail whale is dead. Sorry....

April 29th, 2012, 04:41 AM
well have you tried to shut down and re boot using unity 2d and see if that gets you some where ???

April 29th, 2012, 04:43 AM
well have you tried to shut down and re boot using unity 2d and see if that gets you some where ???

No. How would I do that?

April 29th, 2012, 04:48 AM
No. How would I do that?

when you get where you put in the password just above the text box right side see little round gear now I mean just above not the top of the window

click the little gear the meno up you will see unity 3d unity 2d click 2d and password in and boot ..

it may not help b
for many it does because video card driver is not working right yet

April 29th, 2012, 05:16 AM
Thank you! There is no little gear (I think all icons are missing), but by waving the mouse in the region you described, I got something to highlight. Selected "Ubuntu 2d" (not "Unity 2d", but assuming it's the same thing) and I can log into something that's slightly less broken.

All icons still missing, but the toolbar is present with black squares for all my common apps. (And mouseover text works, so I can tell which is which.)

No window manager. Can't move anything around. Can't get at the menu bar for most apps, because windows come up at (0,0), and judging by the Desktop, there's no menus anyway, so it's all keyboard navigation.

No network, so hard to post logs.

I'm still at a loss as to what to try next. I've been poring over the syslog, but other than lots and lots of messages about "can't read image file", I don't see a smoking gun. I find it hard to believe that every single image file got corrupted, simultaneously.

Did the install leave a log somewhere, do you know?

April 29th, 2012, 05:42 AM
was this a new clean install or an up graded ??

the thing is things are not corrupt, what happens is at times not sure what triggers it package trys to install out of order and it starts cascade of dependently issues the files are there libraries not installed with many of the images ..

there are people here who can help with commands to type in the terminal window to get things going , its a matter of waiting it out, im pretty much new to this too only been using ubuntu a few months I can give help with issues I have ran into and read about ..

if you search enough you wil run across a thread with the help you need as well :)

April 29th, 2012, 02:11 PM
Thanks for your help. It was a (network) upgrade, which has worked on this machine since the 7.4 era.

April 29th, 2012, 02:38 PM
I've started poking around with apt-get -check.
Whole bunches of stuff depending on libjpeg8 (>= 8c) which is not installed.

I wonder if I've got a network if I boot into safe mode. Because I don't have one on this broken desktop, and if I don't have a net, I'll have to get an ISO somehow.

Nope, no network. Something is screwed up here too.
%ifconfig -a shows eth0 (wired) and eth1 (wireless)
%ifup eth0 says
ignoring unknown interface eth0=eth0.

April 29th, 2012, 04:32 PM
More poking around in /etc....

Does the presence of many files named <something>.dpkg-new , and a few named
<something>.dpkg-old indicate something? Like maybe an incomplete install?

But how do I restart an install without the network? Can I do that with an ISO?

April 29th, 2012, 11:20 PM
Did the install leave a log somewhere, do you know?

Answering my own question:
1. /var/log/installer/ does not contain anything from
updates/upgrades; I guess it is only written by complete installs.

2. /var/log/dpkg.log has (dpkg-ish) events from the upgrade, but there are no failure indications in here corresponding to the disasters recorded in syslog. I guess you're supposed to read the two side by side?

April 30th, 2012, 03:23 AM
Since so many of the missing dependencies seemed to revolve around libjpeg8, I decided to force its installation, then redo the package install again. That got things working enough to run the 2d desktop.

There are still a bunch of smaller problems remaining (flashplayer, sound,...) but they can get their own thread.

I'm sorry to say this, but Ubuntu installs have been getting more and more difficult since (approx) 9.10 or 10.4. This is going in the wrong direction.