View Full Version : [SOLVED] 12.04 Ubuntu upgrade, now i have bootup errors

April 29th, 2012, 03:32 AM
12.04 Ubuntu upgrade, now i have bootup errors

i've given myself a couple of days of searching and browsing this forum (and others) for an answer. i haven't quite found my situation nor deduced a solution.

my setup is not complicated. garden variety 32bit desktop machine. no dual boot. Ubuntu is the native OS. the upgrade to 12.04 happened without error. previous upgrades where great.

here's where i answer the questions of this post:
"I upgraded, and now I have this error..." http://ubuntuforums.org/showthread.php?t=1946145
1: yes, i guess this machine likes 12.04, but then i am having problems [insert snarky grin here]
2: yes, this machine has worked fine thru a few versions of Ubuntu (it's a 32bit HP Pavilion a1440n). i completely wiped the disks before installing Ubuntu. this is not a duel-boot machine.
3: no hardward problems. once i get past my boot problems the machine is quite useable, even under some heavy lifting.
4: i'm asking the forum now
5: i've backed up the important stuff.
6: plenty of room for the upgrade. i didn't have any upgrade errors.
7: this wasn't an installation just an upgrade when i got the pop-up saying that 12.04 was available.
8: i've not mucked around with anything like copying previous files or anything.

after i power on, i get the purple screen for longer than normal, then i get the following message:
"Serious errors were found while checking the disk drive for /"
i've learned it is best to chose "i" for "ignore" (otherwise things get messy)

then that immediately takes me to the error message:
"An error occurred while mounting /media/BigHDD"
i've learned to select "s" for "skip"

then that immediately takes me to the error message:
"An error occurred while mounting /media/ForWindows"
i've learned to select "s" for "skip"

then the system loads as normal, and i am able to use my machine like normal (with a couple of hiccups explained below).

here's my disk plan in plain english:
two disks... my primary disk (80gb) was set up by Ubuntu originally (ext4, with a part for swap)
the second disk (750gb) is one for massive storage. 80% is formatted in ext4, the rest in NTFS. (side note: i need a small corner for NTFS cause that's where my iTunes library is. i run iTunes (and nothing else) in a VirtualBox running WindowsXP. that ntfs spot allows both my virtual WindowsXP and my Ubuntu installation to access my music files. my virtual windows is rarely powered on, only to muck with stuff in iTunes.)

prior to my upgrade to 12.04, both these parts "ForWindows" (ntfs) and "BigHDD" (ext4) would mount automatically, and i could see them in the dash.

now after i get passed my errors and log in, neither are mounted. my shortcut to BigHDD is still there, and it will mount manually and i have full access to it without error. my "ForWindows" (ntfs) part shows in the Disk Utility in the graph. it's mount point is "not mounted". but when i click "Mount Volume" i get the error:
Error mounting: mount exited with exit code 1: helper failed with:
mount: according to mtab, /dev/sdb1 is already mounted on /
mount failed

as best as i know, i have applied all available updates according to the Update Manager after my jump to 12.04. none of these updates has helped me.

so i tried Boot-Repair. first i did just the report with no changes to anything:

then i tried the recommended fixes:
but when i went to reboot... the machine would never reboot, never shutdown. it would just hang on that purple screen with "ubuntu" in the center. after waiting a while, i had to power off the box. and when it came back up, it went into the safe mode boot menu thingie. i chose for the OS to load as normal. and my exact same issues remained. i had to "ignore", "skip", and "skip"

thought i would try Boot-Repair one more time (cause that's what lusers like me do):
same as before. machine won't power off, same boot up issues.

i will be very grateful for any help. thanks.

April 29th, 2012, 03:57 AM
try fsck from a live CD

then boot windows and do a defrag

otherwise, you will need to buy a disk utility like spinrite to check you hdd

April 29th, 2012, 04:11 AM
try fsck from a live CD

then boot windows and do a defrag

otherwise, you will need to buy a disk utility like spinrite to check you hdd

i'm confused. how do i boot Windows?... i don't have Windows installed. that one NTFS part is just storage. it has no OS files at all. just some MP3 files. i can't boot to it.

regardless. what about my errors with the mount for the ext4 volume?

April 29th, 2012, 05:24 AM
if it helps.... here's the output of fdisk -l
ian@Aisling:~$ sudo fdisk -l

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000001

Device Boot Start End Blocks Id System
/dev/sda1 63 188089019 94044478+ 7 HPFS/NTFS/exFAT
/dev/sda2 188089020 1465144064 638527522+ 83 Linux

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000494e3

Device Boot Start End Blocks Id System
/dev/sdb1 * 2048 152111103 76054528 83 Linux
/dev/sdb2 152113150 156301311 2094081 5 Extended
/dev/sdb5 152113152 156301311 2094080 82 Linux swap / Solaris

and here's what i have in /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda1 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=4e375212-c1ae-4066-b562-6e76e108979f none swap sw 0 0
/dev/sdb2 /media/BigHDD ext4 users,user,owner 0 0
/dev/sdb1 /media/ForWindows ntfs nls=iso8859-1,users,umask=000,user,owner 0 0

April 29th, 2012, 05:37 AM
additional information...

despite my boot errors, i was able to get to my "BigHDD" which is formatted as ext4. but i was cut off from my "ForWindows" (ntfs) partition.

i just tried this:
sudo mount.ntfs-3g /dev/sda1 /media/ForWindows

and now i can get to that partition just fine. playing music from it now.

so now i have:

ian@Aisling:/media$ sudo df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sdb1 73G 16G 54G 23% /
udev 1.8G 12K 1.8G 1% /dev
tmpfs 707M 936K 706M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1.8G 444K 1.8G 1% /run/shm
/dev/sda2 609G 165G 414G 29% /media/BigHDD_
/dev/sda1 90G 23G 67G 26% /media/ForWindows

April 29th, 2012, 05:49 AM
From ubuntu, open a terminal & run :

sudo apt-get update
sudo apt-get install -f

sudo dpkg-reconfigure -phigh -a
(can take a while, dont stop it)

sudo shutdown -r now
(force a fsck on next reboot)

If this has not fixed this issue, then start gparted to see if it warns about something (but dont use it, only open it)

April 29th, 2012, 06:10 AM
If you look at your results in post #4 your sda,sdb from fdisk don't jive with what fstab says, which is prob causing the mounting errors

now the commented section of the ftab output says it's better to use UUID's for mounting,
This is true because during reboots and restarts drive designations can change.
UUID designation will ensure consistency with mounting.

Sorry I am not skilled enough to guide you with that. Hopefully someone with that knowledge will appear.

April 29th, 2012, 07:48 AM
sudo blkid -n /dev/sda

will list all the partitions on /dev/sda and their UUIDs. You can then edit /etc/fstab and replace /dev/sdaX entries with the corresponding UUIDs. Note that blkid will return the UUID inside quotation marks, while /etc/fstab uses only the UUID strings themselves as the example above shows.

UUID=4e375212-c1ae-4066-b562-6e76e108979f none swap sw 0 0

If you have the ntfs-3g package installed, you can try using the ntfsfix utility to check an NTFS filesystem and fix whatever errors it can. However it's not a replacement for Windows chkdsk, which is the only reliable method for checking and fixing an NTFS filesystem. See "man ntfsfix" for details.

April 30th, 2012, 04:35 AM


i'm such a dope. i went cross-eyed and totally missed that /etc/fstab was just plain wrong with everything else. it must have gotten tweaked in the 12.04 upgrade.

i corrected it, rebooted.... and happiness.

i should have figured something like this cause my digital darkroom software (Bibble5, it basically manages, edits, imports, and exports image files) was very confused and had odd behavior. my "BigHDD" partition would show up in some places as "BigHDD" and at the same time as "BigHDD_" and i never made the "_" version. i guess it was an artifact of booting up and mounting with a mucked up /etc/fstab

thanks again everyone.

September 30th, 2012, 06:09 PM
Hi Guys,

I'm new to Ubuntu, in fact 12.04 is my very first install. I have windows XP on my system already and i created a new partition to install Ubuntu on. The Install went through fine but i have the exact same error that Ian discussed above. Looking at the solutions though, i want to confirm if this what i need to do. Any help is appreciated.

/$ cat /etc/fstab
/host/ubuntu/disks/swap.disk none swap sw 0 0

this is my blkid o/p:

sudo blkid -n /dev/sda
/dev/loop0: UUID="9b16030c-08f8-4f5d-b228-63e13bca7839" TYPE="ext3"
/dev/sda1: UUID="220CFF700CFF3D7B" TYPE="ntfs"
/dev/sda3: UUID="669427A7942778A7" TYPE="ntfs"
/dev/sda5: LABEL="New Volume" UUID="44B4447DB4447388" TYPE="ntfs"

please advise what my fstab should look like. Note that when i ignore the error on boot screen , i can log into Ubuntu and perform all the tasks very well.