View Full Version : [ubuntu] 12.04 upgrade didn't work, runs command-line only

April 27th, 2012, 07:05 PM
so I fell asleep while my upgrade was going, and when I woke up my computer was off. I turned it on, and my new 12.04 install is command-line only. I tried entering the command "unity" and I got some error about how it couldn't find the display. that was pretty much the limit of what I know how to do in command-line; I'm definitely a "casual" user. right now I'm running from an old 11.10 cd that I fortunately had laying around, and I'd like to reinstall the older version from the CD. My problem is that I'd like to back up my files first (didn't do it before upgrading, which was stupid I now realize). They (my files) are still intact, but they're "locked" if I try to access them from the CD, and I have no idea how to do something like that through command-line in my broken 12.04 install. some advice would be most appreciated!

April 27th, 2012, 08:54 PM
I am not sure why are they locked, since in live mode you should have permissions to backup from the hdd.

But if you wanna try to continue the upgrade, and it boots into command line, you can try with:
sudo dpkg --configure -a

That will finish the configuration of all downloaded packages.

April 27th, 2012, 09:00 PM
I have a oldish compaq cq60 that if the plug comes unpluged then the thing shuts off bang. So about 6 months ago or so I was upgrading from 11.10 to 12.04 alpha and my dog triped up the cord and It powered off. Not cool right. well I got to the command line after fussing with it for a bit ran do-release-upgrade again and it did its magic and I was fine. I would try to do that first.


April 28th, 2012, 04:05 AM
thank you both for the tips! I decided to try darkod's suggestion first because it seemed less drastic, and it appears to have worked like a charm! (currently posting from an apparently stable 12.04 installation). maybe I should re-do the upgrade anyway though due to the weird staggered way I got here.

April 28th, 2012, 10:58 AM
The upgrade goes in two stages, to try and avoid leaving you with broken system.
First it downloads everything from the internet, and only after it is sure it has all files downloaded locally, it starts the upgrade.

If it shuts down during the actual upgrade but all files were downloaded, running that command will simply finish off configuring all packages waiting to be configured. The system should be 100% working if this is what happened.

I would say wait and see how it runs few days, no need for another upgrade that can also get messed up somehow. In fact, if you are now on 12.04 there will be nothing to upgrade to, you already have the latest version.

May 3rd, 2012, 01:29 AM
HELP! How do I finish upgrading without a GUI!

I just ran into this same situation, still trying to finish the upgrade

currently it's stuck (both recovery console and normal boot), below is some of what appears on screen:

[ 1.848019] List of all partitions:
[ 1.848110] No filesystem could mount root, tried: ext3 ext4 fuseblk
[ 1.848402] Kernal panic - not syncing: VFS: Unable to mount root fs on unkno
[ 1.848503] Pid: 1, comm: swapper/0Not tainted 3.2.0-24-generic #37-Ubuntu
[ 1.849460] [(c157e37e)] kernal_thread_helper+0x6/0x10

I have a blinking cursor below this last line and I also have a blinking caps lock