PDA

View Full Version : [ubuntu] 12.04 install not showing existing partitions



mkowske
April 27th, 2012, 04:35 PM
Hello all,

I am trying to install 12.04 from CD and it is failing to find my existing partitions. When installing I only get two options 1) Erase everything and 2) Something else


Something else just shows me /dev/sda with the only option to create a new partition table. I don't want to do this. I have existing partitions I need to preserve. I know they are there because I can see them with fdisk.

This is coming after a failed upgrade from 11.10... so maybe that has something to do with it (see http://ubuntuforums.org/showthread.php?t=1965884 for that problem)

Please help... I need this for work. Thanks.


root@ubuntu:~# fdisk /dev/sda

Command (m for help): p

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd50fcf61

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 22530047 11264000 c W95 FAT32 (LBA)
/dev/sda2 22530048 190302200 83886076+ 7 HPFS/NTFS/exFAT
/dev/sda3 190304256 256194559 32945152 83 Linux
/dev/sda4 256194603 488408129 116106763+ f W95 Ext'd (LBA)
/dev/sda5 256196608 266727407 5265400 82 Linux swap / Solaris
/dev/sda6 266729472 488396799 110833664 7 HPFS/NTFS/exFATI also found the following in syslog, which looks like it maybe useful:



Apr 27 15:37:12 ubuntu ubiquity[12834]: Ubiquity 2.10.16
Apr 27 15:37:14 ubuntu ubiquity[12834]: log-output -t ubiquity laptop-detect
Apr 27 15:37:17 ubuntu ubiquity[12834]: switched to page language
Apr 27 15:37:18 ubuntu localechooser: info: debian-installer/language preseeded to 'en' (seen: false)
Apr 27 15:37:18 ubuntu localechooser: info: debian-installer/country preseeded to 'US' (seen: false)
Apr 27 15:37:18 ubuntu localechooser: info: debian-installer/locale preseeded to 'en_US.UTF-8' (seen: false)
Apr 27 15:37:18 ubuntu localechooser: info: Preseeded language ignored: unknown language code
Apr 27 15:37:19 ubuntu ubiquity[12834]: switched to page language
Apr 27 15:37:23 ubuntu localechooser: info: Language = 'en'
Apr 27 15:37:23 ubuntu localechooser: info: line=en;0;US;UTF-8;en_US.UTF-8;;console-setup
Apr 27 15:37:23 ubuntu localechooser: info: Set debian-installer/language = 'en'
Apr 27 15:37:23 ubuntu localechooser: info: Default country = 'US'
Apr 27 15:37:23 ubuntu localechooser: info: Default locale = 'en_US.UTF-8'
Apr 27 15:37:23 ubuntu localechooser: info: Set debian-installer/consoledisplay = 'console-setup'
Apr 27 15:37:23 ubuntu localechooser: info: Set debian-installer/country = 'US'
Apr 27 15:37:23 ubuntu localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Apr 27 15:37:23 ubuntu localechooser: info: System locale (debian-installer/locale) = 'en_US.UTF-8'
Apr 27 15:37:24 ubuntu ubiquity[12834]: debconffilter_done: ubi-language (current: ubi-language)
Apr 27 15:37:24 ubuntu ubiquity[12834]: Step_before = stepLanguage
Apr 27 15:37:25 ubuntu ubiquity[12834]: switched to page prepare
Apr 27 15:37:29 ubuntu dbus[1314]: [system] Activating service name='com.ubuntu.DeviceDriver' (using servicehelper)
Apr 27 15:37:29 ubuntu dbus[1314]: [system] Successfully activated service 'com.ubuntu.DeviceDriver'
Apr 27 15:37:31 ubuntu ubiquity: Additional Drivers
Apr 27 15:37:31 ubuntu ubiquity: Searching for available drivers...
Apr 27 15:37:31 ubuntu ubiquity[12834]: debconffilter_done: ubi-prepare (current: ubi-prepare)
Apr 27 15:37:31 ubuntu ubiquity[12834]: Step_before = stepPrepare
Apr 27 15:37:31 ubuntu ubiquity[12834]: Step_before = stepPrepare
Apr 27 15:37:31 ubuntu activate-dmraid: No Serial ATA RAID disks detected
Apr 27 15:37:32 ubuntu ubiquity: umount: /tmp/tmp.o2JDcHSy5a: not mounted
Apr 27 15:37:32 ubuntu ubiquity: umount: /tmp/tmp.D2tNPoXBcz: not mounted
Apr 27 15:37:32 ubuntu ubiquity: umount: /tmp/tmp.SidM51jvTG: not mounted
Apr 27 15:37:32 ubuntu ubiquity: umount: /tmp/tmp.tPPUkUIkYA: not mounted
Apr 27 15:37:32 ubuntu ubiquity:
Apr 27 15:37:33 ubuntu ubiquity[12834]: switched to page partman
Apr 27 15:37:51 ubiquity[12834]: last message repeated 2 times
Apr 27 15:37:51 ubuntu os-prober: debug: running /usr/lib/os-probes/50mounted-tests on /dev/sda1
Apr 27 15:37:51 ubuntu 50mounted-tests: debug: mounted using GRUB fat filesystem driver
Apr 27 15:37:51 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10freedos
Apr 27 15:37:51 ubuntu 10freedos: debug: /dev/sda1 is a FAT partition (mounted by GRUB)
Apr 27 15:37:51 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10qnx
Apr 27 15:37:51 ubuntu 10qnx: debug: /dev/sda1 is not a QNX4 partition: exiting
Apr 27 15:37:51 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20macosx
Apr 27 15:37:51 ubuntu macosx-prober: debug: /dev/sda1 is not an HFS+ partition: exiting
Apr 27 15:37:51 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20microsoft
Apr 27 15:37:51 ubuntu 20microsoft: debug: /dev/sda1 is a FAT partition (mounted by GRUB)
Apr 27 15:37:51 ubuntu 20microsoft: result: /dev/sda1:Windows Recovery Environment (loader):Windows:chain
Apr 27 15:37:51 ubuntu 50mounted-tests: debug: os found by subtest /usr/lib/os-probes/mounted/20microsoft
Apr 27 15:37:51 ubuntu os-prober: debug: os detected by /usr/lib/os-probes/50mounted-tests
Apr 27 15:37:51 ubuntu os-prober: debug: running /usr/lib/os-probes/50mounted-tests on /dev/sda2
Apr 27 15:37:52 ubuntu 50mounted-tests: debug: mounted using GRUB ntfs filesystem driver
Apr 27 15:37:52 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10freedos
Apr 27 15:37:52 ubuntu 10freedos: debug: /dev/sda2 is not a FAT partition: exiting
Apr 27 15:37:52 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10qnx
Apr 27 15:37:52 ubuntu 10qnx: debug: /dev/sda2 is not a QNX4 partition: exiting
Apr 27 15:37:52 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20macosx
Apr 27 15:37:52 ubuntu macosx-prober: debug: /dev/sda2 is not an HFS+ partition: exiting
Apr 27 15:37:52 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20microsoft
Apr 27 15:37:52 ubuntu 20microsoft: debug: /dev/sda2 is a NTFS partition
Apr 27 15:37:52 ubuntu 20microsoft: result: /dev/sda2:Windows Vista (loader):Windows1:chain
Apr 27 15:37:52 ubuntu 50mounted-tests: debug: os found by subtest /usr/lib/os-probes/mounted/20microsoft
Apr 27 15:37:52 ubuntu os-prober: debug: os detected by /usr/lib/os-probes/50mounted-tests
Apr 27 15:37:52 ubuntu os-prober: debug: running /usr/lib/os-probes/50mounted-tests on /dev/sda3
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: mounted using GRUB ext2 filesystem driver
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10freedos
Apr 27 15:37:53 ubuntu 10freedos: debug: /dev/sda3 is not a FAT partition: exiting
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10qnx
Apr 27 15:37:53 ubuntu 10qnx: debug: /dev/sda3 is not a QNX4 partition: exiting
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20macosx
Apr 27 15:37:53 ubuntu macosx-prober: debug: /dev/sda3 is not an HFS+ partition: exiting
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20microsoft
Apr 27 15:37:53 ubuntu 20microsoft: debug: /dev/sda3 is not a MS partition: exiting
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/30utility
Apr 27 15:37:53 ubuntu 30utility: debug: /dev/sda3 is not a FAT partition: exiting
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/40lsb
Apr 27 15:37:53 ubuntu 40lsb: result: /dev/sda3:Ubuntu 12.04 LTS (12.04):Ubuntu:linux
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: os found by subtest /usr/lib/os-probes/mounted/40lsb
Apr 27 15:37:53 ubuntu os-prober: debug: os detected by /usr/lib/os-probes/50mounted-tests
Apr 27 15:37:53 ubuntu os-prober: debug: running /usr/lib/os-probes/50mounted-tests on /dev/sda4
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: /dev/sda4 type not recognised; skipping
Apr 27 15:37:53 ubuntu os-prober: debug: os detected by /usr/lib/os-probes/50mounted-tests
Apr 27 15:37:53 ubuntu os-prober: debug: running /usr/lib/os-probes/50mounted-tests on /dev/sda5
Apr 27 15:37:53 ubuntu 50mounted-tests: debug: /dev/sda5 is a swap partition; skipping
Apr 27 15:37:53 ubuntu os-prober: debug: os detected by /usr/lib/os-probes/50mounted-tests
Apr 27 15:37:53 ubuntu os-prober: debug: running /usr/lib/os-probes/50mounted-tests on /dev/sda6
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: mounted using GRUB ntfs filesystem driver
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10freedos
Apr 27 15:37:54 ubuntu 10freedos: debug: /dev/sda6 is not a FAT partition: exiting
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/10qnx
Apr 27 15:37:54 ubuntu 10qnx: debug: /dev/sda6 is not a QNX4 partition: exiting
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20macosx
Apr 27 15:37:54 ubuntu macosx-prober: debug: /dev/sda6 is not an HFS+ partition: exiting
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/20microsoft
Apr 27 15:37:54 ubuntu 20microsoft: debug: /dev/sda6 is a NTFS partition
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/30utility
Apr 27 15:37:54 ubuntu 30utility: debug: /dev/sda6 is not a FAT partition: exiting
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/40lsb
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/70hurd
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/80minix
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/83haiku
Apr 27 15:37:54 ubuntu 83haiku: debug: /dev/sda6 is not a BeFS partition: exiting
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/90bsd-distro
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/90linux-distro
Apr 27 15:37:54 ubuntu 50mounted-tests: debug: running subtest /usr/lib/os-probes/mounted/90solaris
Apr 27 15:37:54 ubuntu ubiquity[12834]: switched to page partman

oldfred
April 27th, 2012, 05:18 PM
If file system is corrupted then the partitioner has issues trying to see it.


root@ubuntu:~# fdisk /dev/sda

Command (m for help): p

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd50fcf61

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 22530047 11264000 c W95 FAT32 (LBA)
/dev/sda2 22530048 190302200 83886076+ 7 HPFS/NTFS/exFAT
/dev/sda3 190304256 256194559 32945152 83 Linux
/dev/sda4 256194603 488408129 116106763+ f W95 Ext'd (LBA)
/dev/sda5 256196608 266727407 5265400 82 Linux swap / Solaris
/dev/sda6 266729472 488396799 110833664 7 HPFS/NTFS/exFAT

The end of your extended partition is beyond the end of the drive.

First backup partition table, use your drive for sdX or sda, sdb etc.
sudo sfdisk -d /dev/sdX > parts.txt


Fixparts - Repair broken partition tables (not overlapping issues) & delete Stray gpt data from MBR drives
http://ubuntuforums.org/showthread.php?t=1705325
http://www.rodsbooks.com/fixparts/

mkowske
April 27th, 2012, 06:11 PM
Oh boy.. that doesn't sound good.

I did have some corruption on the drive that was fixed with a low level scan about a year ago. And now this.. I'm thinking this hard drive might not last too much longer.

What's the chance of data loss when using fixpart?

oldfred
April 27th, 2012, 06:28 PM
Never any guarantees on partition edits, and good backups are always important before any system changes.

But many users have reported good results with fixparts. And all you really are doing is editing a number in the partition table.

You can manually do it also with sfdisk by changing the text file you save and rereading it back in. So I think it is a lower risk change.