View Full Version : [SOLVED] 12.04 w/ OMSA, checked by Nagios

April 27th, 2012, 02:52 PM
Alright, I've been able to freshly install 12.04 on a Dell R310. I've installed OMSA 6.5
(http://linux.dell.com/repo/community/deb/latest/) using the methods described on the link. At this point, I can open the web manager and view the hardware, however I have two issues:

1) I can't get Nagios w/ check_openmanage to see the server. If I run the script from the command line, it gives the following error:

# ./check_openmanage -H <IP of R310> -C <SNMP string>
ERROR: (SNMP) OpenManage is not installed or is not working correctly

Now I found an older blog article that explained a possible fix (http://www.jebriggs.com/blog/2010/02/dell-openmanage-and-check_openmanage-update-problems-on-linux/), but the path still works in 12.04, so the check should work.

2) The storage controller doesn't show up. In a different thread, I found people were saying if they used this method (http://lists.us.dell.com/pipermail/linux-poweredge/2011-November/045543.html) it would work with 3.1 kernels. Has anybody tried this with the 3.2 kernel that's included in 12.04?

I've also found this thread that stating SNMP wasn't setup correctly, but I tried this and it didn't fix anything either. (http://ubuntuforums.org/archive/index.php/t-1628304.html)

Basically, has anybody tried this setup yet (Nagios w/ check_openmanage and OMSA)with 12.04 and has succeeded?

April 27th, 2012, 06:54 PM
Ok, found the fix for issue #1:

Basically, I didn't have the connector protocol setup to allow the OMSA to talk to SNMP. Now that I've put the entry in /etc/snmp/snmpd.conf, I can query using the check_openmanage.

Sweet, one down, one to go!

April 27th, 2012, 08:27 PM
I've tested the wrapper and it still works! Therefore, all my issues were resolved. As soon as a get a few minutes, I'll put together a guide with all of the steps so hopefully if anybody else runs into the same issues, they'll be able to work through them.

April 27th, 2012, 10:02 PM
This is how I did this. If you see anything that I might've missed or have overdone, please don't hesitate to let me know and I can edit the entry! I'm mostly copying all of the steps/information from multiple sources. Please feel free to visit them as I've posted the links at the bottom of the doc.

Overview: The Dell OMSA (Open Manager Server Administrator) is a good way to monitor the hardware of your Dell server. A couple of years ago, they released a version that would work in Linux. This document will show you how to setup the Dell OMSA to work with check_openmanage, a great plugin for Nagios.

Assumptions: Nagios server setup with check_openmanage installed and a freshly installed and patched Ubuntu 12.04 64-bit OS on a Dell server (I did this on an R310)


Create apt source

Create a new file ending in 'sources.list' in the '/etc/apt/sources.list.d' directory.

echo 'deb http://linux.dell.com/repo/community/deb/latest /' | sudo tee -a /etc/apt/sources.list.d/linux.dell.com.sources.list

Generate keys

To authenticate OMSA packages, add the repository key to apt

gpg --keyserver pool.sks-keyservers.net --recv-key E74433E25E3D7775
gpg -a --export E74433E25E3D7775 | sudo apt-key add -

Get the update

sudo apt-get update

Install Dell OMSA

I prefer to install the entire package, so here's the command you would run:

sudo apt-get install srvadmin-all

Setup Web Interface Users

Open /opt/dell/srvadmin/etc/omarolemap and edit that to include the users you wish. I didn't add any, but you may.

Add web service to run at startup

sudo update-rc.d dsm_om_connsvc defaults

Edit SNMPD config

Remove '-I -smux' from /etc/default/snmpd from line:

SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -g snmp -I -smux -p /var/run/snmpd.pid -c /etc/snmp/snmpd.conf'

Make sure /etc/snmp/snmpd.conf has the following in it:

# Allow Systems Management Data Engine SNMP to connect to snmpd using SMUX
smuxpeer .

Get wrapper application

Wget http://mirror.linux.org.au/linux/kernel/people/ak/uname26/uname26.c

Move and compile the code

mv uname26.c /usr/bin
gcc -o uname26 uname26.c

Change function (/etc/init.d/dataeng)


dataeng_supt_daemonstart "${DENG_DAEMON_FILE}" "${DENG_DAEMON_OPTS}"

dataeng_supt_daemonstart /usr/bin/uname26 "${DENG_DAEMON_FILE}"

Restart the server

At this point, you will have setup your Ubuntu box to report it's hardware to Nagios, grats!

Dell OMSA - http://linux.dell.com/repo/community/deb/latest/
OMSA CLI User Guide - http://support.dell.com/support/edocs/software/svradmin/6.5/en/CLI/HTML/index.htm
OMSA Role File Editing - http://support.dell.com/support/edocs/software/svradmin/6.5/en/UG/HTML/setup.htm
Remove smux from default snmpd - http://ubuntuforums.org/archive/index.php/t-1628304.html
Add smuxpeer - http://lists.us.dell.com/pipermail/linux-poweredge/2005-April/020245.html
Uname26 usage - http://mirror.linux.org.au/linux/kernel/people/ak/uname26/README
Editing dataeng - http://lists.us.dell.com/pipermail/linux-poweredge/2011-November/045543.html

April 28th, 2012, 02:26 AM
The documentation of your solution is excellent.

+1 for "Sources"

May 8th, 2012, 08:11 AM
Thank you very very good howto.

This should be in the wiki.

Perfect for me.

I only changed 1 thing, /usr/bin/uname26

should be /usr/local/bin/uname26 since it's not a system file.
this way its easier to backup.

nether less.. THANK YOU !!!

=D> =D> =D>