View Full Version : [ubuntu] All default program got removed

April 14th, 2012, 10:47 AM
Hi all,
I run the following command on the terminal and all of my default software such as Libreoffice etc got removed.

sudo apt-get install gtk

i ran the above command and eveything is gone. Does any one know how to get back all those program??

even ubuntu sofware centre and setting are gone..

why should install command removed my software ?????

April 14th, 2012, 01:35 PM
What version of Ubuntu and what desktop are you using? If you are using Unity, it should be sufficient to re-install the package ubuntu-desktop, since that would pull all the default programs.

April 20th, 2012, 05:51 AM
i am using ubuntu 11.10
how can i reinstall ubuntu desktop ??

April 21st, 2012, 12:41 AM
sudo apt-get install gtk

That command will do nothing. No such package.

Try this:

sudo apt-get install -f

That will attempt to fix broken packages. get any errors?

April 21st, 2012, 12:52 AM
As well as Jerrys's suggestions, try:

sudo apt-get install --reinstall ubuntu-desktop