PDA

View Full Version : Cannot get Gedit LateX plugin to work



souravc83
April 11th, 2012, 05:41 AM
I am trying to get Gedit latex plugin to work.
I have tried
1. installing it using Ubuntu Softwar Center. Software Center shows gedit-latex-plugin installed.
2. I have manually put the files (one folder and one file) in the different directories that people have suggested.
These are:
a)~/.gnome2/gedit/plugins
b)/usr/lib/gedit-2/plugins
c) /usr/share/gedit-2/plugins

However, I still do not see the Latex plugin when I go to Gedit Edit->Preferences->Plugins.

I am using using Gedit 3.2.3, Ubuntu 11.10, and Gnome 2.32.1.

I must mention I am not using the Unity Desktop, but the Gnome Desktop, although I don't know if that makes any difference.

Any solutions?

souravc83
April 11th, 2012, 08:51 AM
With a little bit of google search, it seems that the LaTeX plugin does not work with gedit 3.
Is it then advisable to go back to gedit 2?

http://live.gnome.org/Gedit/LaTeXPlugin

souravc83
April 12th, 2012, 07:39 AM
Okay, I tried a few things here and there.
I removed Gedit 3.2 which came with my ubuntu, and tried to install Gedit 2.9 from source and then from the Debian package.
That doesn't work because the Gedit 2.x required Gtk 2.0, while Gnome 3 uses Gtk 3.0, so this doesn't quite work.

So, then I went back to Gedit 3.2 and tried to install a version of the latex plugin, that should work for Gnome 3 (although I am not sure it is the official one, since the Gnome website still says that the LaTeX plugin does not work with Gedit 3). I followed the links here.

http://jaliste.blogspot.com/2011/09/gedit-latex-has-been-ported-to-gedit-3.html

I could get a latex plugin allright, but once I enable the plugin, and load a tex document, Gedit crashes. So, no go for me.


So, my question is, is nobody using the LaTex plugin at this moment, after the upgrade to Gnome 3 and Gedit 3? The LaTeX plugin is pretty popular, so I am quite surprised to see that I could not find any known workaround.

Let me know if I am missing something.

AntoineT
April 13th, 2012, 03:21 PM
https://launchpad.net/~gaspa/+archive/ppa works on my machine (Oneiric 64bit) with gedit 3.2.3

stfields
April 30th, 2012, 11:21 PM
I use this plugin every day, but as of late it has gotten pretty painful. Installing from
https://launchpad.net/~gaspa/+archive/ppa
worked for me as well with gedit 3.2.3. However, there are plenty of bugs, especially with respect to bibtex integration.

cristianrosa
May 15th, 2012, 12:36 PM
I was also being frustrated with the state of gedit-latex-plugin in 11.10.
I found that you can install a newer version of the plugin (3.4) using the deb package from precise that you can find here (http://launchpadlibrarian.net/100908720/gedit-latex-plugin_3.4.0-1_all.deb).
I might improve stability.