View Full Version : [SOLVED] Problem hibernating a netbook in Xubuntu 12.04 Beta 2

April 10th, 2012, 08:40 AM
Whenever I try to do so, a window shows up with the message "Failed to hibernate the session - not authorized" (I'm not sure what is the exact wording in a English language system) and sends me to the Xscreensaver screen, in which I need to type my password to return to the desktop. I also can't set hibernate in the Power Manager.

I'm running a up-to-date Beta 2. Not sure if it's revelant, but the netbook has a 2gb swap partition. Curiously the hibernate function worked fine in 11.10.


April 11th, 2012, 07:19 PM
It could be a bug. I m using 2g swap on a htpc and shows the error.

April 23rd, 2012, 05:43 AM
Unfortunately it isn't a bug, its a "feature". At least in xubuntu you get a warning, in kubuntu nothing happens when you select "suspend to disk" in the shutdown menu.
What happens is that hibernate has been disabled by default in ubuntu. You need to edit a obscure policy file to get it to work. See the discussion here (http://www.ubuntuvibes.com/2012/04/hibernation-disabled-by-default-in.html) and the "bugs" here (https://bugs.launchpad.net/ubuntu/+source/policykit-desktop-privileges/+bug/812394) and here (https://bugs.launchpad.net/ubuntu/+source/kde-systemsettings/+bug/976654).

For me, this decision is one of the WTF moments of the year, but the ubuntu devs seem set on watering down ubuntu, and unfortunately that path also breaks kubuntu, xubuntu and all the other derivatives.

April 23rd, 2012, 05:52 PM
Thanks for clarifying. The ability to hibernate comes handy in my systems and is used every single day. Also will try to follow your links so I get it to work on the HTPC that is running Xubuntu 12.04.

Im sorry to said that regarding choice and customization, Ubuntu and Gnome3 are working hard on trying to prevent users to make their own decisions on how to run our systems.

One of the things that attract me to Gnu/Linux is the fact that we freely choose what we want, and when I try to look forward in time let said 10 years from now, what I see in that future environment at least in Ubuntu, is the lack of that freedom.


May 2nd, 2012, 06:04 PM
Thanks, jbernardo. I don't keep up with the news, so wasn't aware of this "feature".

Followed these setps (https://help.ubuntu.com/12.04/ubuntu-help/power-hibernate.html) and I now hibernation is working properly.

May 6th, 2012, 01:26 AM
Hibernate works fine in 10.04, my last version installed in this computer. Now it doesn't work, even after following this page: https://help.ubuntu.com/12.04/ubuntu-help/power-hibernate.html

Any idea who got this working?

May 6th, 2012, 03:00 AM
Most likely you downloaded the beta to beat the crowds to avoid slow specs when updating to Xubuntu 12.04.
Now I recommend that you update to the final version this way it might fix your problem. If not you can go into settings under power management and enable Hibernate and Sleep mode. This is what I had to do on my Xubntu 12.04 LTS Laptop.