PDA

View Full Version : [ubuntu] Ugly arial bold font



napsy
April 6th, 2012, 10:54 AM
Hello.

I have a font issue. The bold weight of 'arial' gets really ugly and is stretched too much, compared to normal font weight.

Example. The bolder text should't be so stretched.
http://i.imgur.com/sX1aB.png

Frogs Hair
April 6th, 2012, 03:08 PM
What version of Ubuntu ? I am running 11.10 and both arial fonts look much better in Libre Office than yours . I have made no adjustments and installed the MS core fonts from the software center .

Arial Bold Font


Arial Normal Font

napsy
April 16th, 2012, 10:31 AM
Running 12.04 with latest updates ... but with one difference: I can't install the core fonts from apt(there's something wrong with my ISP and can't download the fonts from sourceforge) but installed a custom arial .TTF font in my ~/.fonts directory.

Frogs Hair
April 16th, 2012, 02:40 PM
I am now testing 12.04 since my last post and used the installer for the MS core fonts from the software center moments ago. I have not had to download anything from Sourceforge. I have the medibuntu repository installed, so if the installer is not in your software center that may be the reason. I don't know if the installer was there prior to adding the repository .

mcduck
April 16th, 2012, 02:57 PM
I am now testing 12.04 since my last post and used the installer for the MS core fonts from the software center moments ago. I have not had to download anything from Sourceforge. I have the medibuntu repository installed, so if the installer is not in your software center that may be the reason. I don't know if the installer was there prior to adding the repository .

The installer itself downloads the fonts from sourceforge, because of the restrictions on the licence under which Microsoft released those fonts, they can't be included in the package itself and instead the package available in the repositories is just a downloader script that downloads and installs the fonts for you.

Frogs Hair
April 17th, 2012, 03:25 PM
The installer itself downloads the fonts from sourceforge, because of the restrictions on the licence under which Microsoft released those fonts, they can't be included in the package itself and instead the package available in the repositories is just a downloader script that downloads and installs the fonts for you.

Thanks , I didn't know the fonts were hosted on Source Forge and I know the installer is not the fonts package.

schtufbox
April 17th, 2012, 05:25 PM
Something is definitely wrong there, should look more like this...

napsy
April 19th, 2012, 12:39 PM
So it's not just me but a real bug. Anyone reported yet?

Frogs Hair
April 19th, 2012, 01:55 PM
So it's not just me but a real bug. Anyone reported yet?

I had no problem in 11.10 and the MS core fonts look great in 12.04 also . Problems related non official packages don't get much attention on Launchpad.

napsy
April 19th, 2012, 01:59 PM
The problem is in the upcoming 12.04 version of Ubuntu.

Frogs Hair: did you dist-upgrade to 12.04 or was it a clean install?

Frogs Hair
April 19th, 2012, 02:05 PM
The problem is in the upcoming 12.04 version of Ubuntu.

Frogs Hair: did you dist-upgrade to 12.04 or was it a clean install?

I always preform a clean installation .

napsy
April 20th, 2012, 12:10 PM
I tried putting this in my ~/.fonts.conf


<match target="font">
<test name="weight" compare="more">
<const>medium</const>
</test>
<edit name="autohint" mode="assign">
<bool>false</bool>
</edit>
</match>


Should disable auto-hinting for bold fonts which should fix the wide bold fonts problem but it doesn't. Any other suggestions?

Frogs Hair
April 20th, 2012, 03:22 PM
Other than experimenting with the hinting and antialiasing options in advanced settings I have no suggestions. I was thinking there may have been something carried over from the 11.10 .fontconfig that is causing the problem, but I don't know my way around that folder. I don't if it is safe to delete that folder and restart in order to create a new configuration. I have done that in the past with other hidden folders , but not fonts.

napsy
April 23rd, 2012, 09:13 AM
Nevermind, I solved the issue by overwriting the font configuration files and the fonts with those from my arch linux installation and now the fonts look as they should. Don't know what went wrong back then. Anyway, thanks for the help.

Frogs Hair
April 23rd, 2012, 02:08 PM
Glad its solved . :)