View Full Version : [ubuntu] Could not perform immediate configuration

March 22nd, 2012, 03:07 PM
I am attempting to upgrade from natty to oneiric on a server with no gui. Editing my sources list and running apt-get update worked with no problems. Apt-get upgrade errors out with:

E: Could not perform immediate configuration on 'util-linux'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

It continues to do so despite my best efforts, which I list below.

1) sudo apt-get install dpkg
2) sudo apt-get install aptitude
3) sudo apt-get install apt

The above three updated with no problems, please note.

4) sudo apt-get -f install


Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 564 not upgraded.

5) sudo aptitude update && aptitude -y safe-upgrade

This had no output.

Anyone know where I should go from here?

March 22nd, 2012, 06:42 PM
Do you have enough free space on the partition?

March 22nd, 2012, 10:45 PM
I just got exactly the same error message in 12.04. My search found an old post in the forums with this solution. It seems upstart does not get installed in order and this has occurred in many versions, but not too common.

sudo apt-get install upstart-job
sudo apt-get dist-upgrade -y