PDA

View Full Version : [SOLVED] Compiling?



linktopower
March 19th, 2012, 06:28 PM
Yeah hello. Now I have no idea about any of this, but I was wondering could I get someone to compile this http://www.linuxant.com/drivers/dgc/archive/dgcmodem-1.13/dgcmodem-1.13.tar.gz
and if its possable to make it into a .deb for a Linux kernel 3.0.0.12 I believe thats the kernel for ubuntu 11.10.

I mean only if its possible to do. If not could a mod delete this.
I just have no idea about compiling this...or if you can even compile this...

wolfgangmcq
March 19th, 2012, 06:47 PM
Have you tried http://www.linuxant.com/drivers/dgc/archive/dgcmodem-1.13/dgcmodem_1.13_i386.deb.zip ? It's a precompiled DEB package of the same thing.

linktopower
March 19th, 2012, 07:59 PM
Yeah but it didn't work. so I thought i might see if someone could compile this one where it would work with a newer kernel.

The one you linked says it has no modules built for linux kenel 3.0.0.12.
So I thought it might need to rebuilt for a newer kernel.

wolfgangmcq
March 19th, 2012, 09:19 PM
Have you tried following the instructions under METHOD C in the INSTALL file of the TGZ?

linktopower
March 19th, 2012, 09:46 PM
No...But I guess I can try that :). I'll post my results in awhile.
I hope this works.

linktopower
March 19th, 2012, 10:55 PM
Okay, I did the

make install And got it installed. and it says to run this

dgcconfigto finish the install but when I do that I get this.

benji-desktop benji # dgcconfig
Conexant DGC USB modem driver, version 1.13

If you need assistance or more information, please go to:
http://www.linuxant.com/

When reporting a problem for the first time, please send
us the file generated by "dgcconfig --dumpdiag".

No pre-built modules for: Debian-wheezy/sid linux-3.0.0-12-generic i686-SMP

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?
[/lib/modules/3.0.0-12-generic/build] Now I'm not to sure On what to do here but I hit enter and I get this

Building modules for kernel 3.0.0-12-generic, using source directory
/lib/modules/3.0.0-12-generic/build. Please wait...

ERROR: Module build failed!
Please examine the log file "/tmp/dgcconfig-buildlog.txt" to determine why.And I look at the log and it says this

(cd /lib/modules/3.0.0-12-generic/build && make "CNXT_KERNELSRC=/lib/modules/3.0.0-12-generic/build" "M=/usr/lib/dgcmodem/modules" "CC=gcc" clean)
make[1]: Entering directory `/usr/src/linux-headers-3.0.0-12-generic'
make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-12-generic'
rm -rf *.o GPL/*.o *.ko GPL/*.ko *.mod.c GPL/*.mod.c .*.cmd GPL/.*.cmd .tmp_versions .tmp_versions /lib/modules/3.0.0-12-generic/build/.tmp_versions/dgcusbdcp.mod Modules.symvers GPL/hda/Modules.symvers Module.symvers GPL/hda/Module.symvers modules.order GPL/hda/modules.order Module.markers GPL/hda/Module.markers
(cd /lib/modules/3.0.0-12-generic/build && make "CNXT_KERNELSRC=/lib/modules/3.0.0-12-generic/build" "M=/usr/lib/dgcmodem/modules" "CC=gcc" modules)
make[1]: Entering directory `/usr/src/linux-headers-3.0.0-12-generic'
CC [M] /usr/lib/dgcmodem/modules/mod_dgcusbdcp.o
/usr/lib/dgcmodem/modules/mod_dgcusbdcp.c:263:36: error: 'SPIN_LOCK_UNLOCKED' undeclared here (not in a function)
make[2]: *** [/usr/lib/dgcmodem/modules/mod_dgcusbdcp.o] Error 1
make[1]: *** [_module_/usr/lib/dgcmodem/modules] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-12-generic'
make: *** [all] Error 2No after all that I', left clue less on what to do...So what do I do?

linktopower
March 20th, 2012, 02:10 AM
Okay I got it :). Just went ahead and downgraded my Kernel. and now my modem works great :D

wolfgangmcq
March 20th, 2012, 12:36 PM
Modems are one of the few things in Ubuntu which are a real pain. I've had mixed results with them myself.

If you want to use the latest version of the kernel, you may need to install the linux-source and linux-headers-generic packages. These provide the source of the kernel, needed to compile kernel modules. After you install them, you should be able to

make clean
make install
dgcconfigwithout any errors. (The `make clean` will clean out any old compiled files--generally a good idea when recompile.)
You may also want to look into dkms, which will automagically recompile the kernel modules when a new kernel comes out.

linktopower
March 20th, 2012, 04:12 PM
Okay thanks for the added Info. I'm going to be trying to recompile the driver with the new Kernel on my laptop. all I have to do is get the source of Linux kernel 3.0.0.12. And the headers and I should be on a roll :).

volitan23
May 11th, 2012, 05:28 PM
I am also trying to compile the pakage with linux-deaders and source but i coulndt figure it out. How did you downgrade your kernel and to which one?

Thank you in advance...

wolfgangmcq
May 14th, 2012, 02:39 AM
Why do you need to downgrade to compile with linux-headers? Just set your kernel to the latest version and get the newest linux-headers package.

gausie
August 28th, 2012, 01:19 PM
What kernel did you downgrade to? Can you tell me how to get past the


ERROR: Module build failed!
Please examine the log file "/tmp/dgcconfig-buildlog.txt" to determine why.

error?

Thanks! Gausie

wolfgangmcq
August 29th, 2012, 02:03 AM
It would help if you posted the contents of said file. It's hard to tell what went wrong with an error message that tells you to look somewhere else.