PDA

View Full Version : [ubuntu] help with the so-called "snap windows" feature in Ubuntu Natty (11.04)



booksmart
March 18th, 2012, 05:07 PM
I recently installed Ubuntu 11.04 on a virtual machine, and the window snap feature isn't working. I am logging in to Ubuntu Classic (not the "no effects" version), and I've read that the feature should be a default. I did try downloading compiz settings configuration manager to use the command/edge binding system, but had little luck with that.

Since I'm completely new to Linux, I would appreciate some direction. Any help the community could offer would be greatly appreciated.

sandyd
March 18th, 2012, 05:49 PM
I recently installed Ubuntu 11.04 on a virtual machine, and the window snap feature isn't working. I am logging in to Ubuntu Classic (not the "no effects" version), and I've read that the feature should be a default. I did try downloading compiz settings configuration manager to use the command/edge binding system, but had little luck with that.

Since I'm completely new to Linux, I would appreciate some direction. Any help the community could offer would be greatly appreciated.
What VM are you using?
Virtualbox? VmWare?

booksmart
March 18th, 2012, 06:09 PM
vmware player: version 4.0.2 build-591240

sandyd
March 18th, 2012, 06:43 PM
vmware player: version 4.0.2 build-591240
Snap requires compositing.
Did you enable the "3d effects" under the display section of the virtual machine's settings?

booksmart
March 18th, 2012, 08:26 PM
That's good to know. The 3D graphics option was being disabled at startup due to an out-of-date driver. I updated and enabled, but the snap feature still doesn't work.

Do you think I somehow disabled the default? Alternatively, is there something else I should check? Thanks for the help, sandyd!