View Full Version : [lubuntu] 11.10 on Sony Vaio P-Series

March 15th, 2012, 10:57 AM

I am trying to get Lubuntu to work on my Vaio P-series laptop, which has "interesting" hardware. I remember getting Ubuntu to work on it some time ago, but when I try the Lubuntu Live USB, it can't even start an Xorg session. (The reason I'm going for Lubuntu is because it's lightweight and don't want to bog my system down with too much.)

It boots fine, but then falls back to the command line. If I run startx, it complains. My presumption is that the GMA500 drivers aren't installed and, from what I've found by Googling, they're not the most stable things in the world: some sources say they're in active development, others say they've been abandoned... Anyway, installing whatever driver does exist also proved to be problematic, because I couldn't connect to my WiFi router.

I ran the wpa_supplicant configuration; connecting to an AP with WPA-PSK AES security. When I try to connect, using the wext driver, it seems to be able to at least find the AP and attempt to authenticate, but it always fails. It complains that my PSK "could be incorrect", despite me generating it using wpa_passphrase. Also, in the logs, there are a lot of ioctrl errors, which mean nothing to me... So, without Internet access, I can't hope to get other things working.

Any advice?...

March 16th, 2012, 09:00 PM
I tried 10.04 and that's working. Indeed, I am using it right now to write this.

However, it is ridiculously slow :( Presumably, again, due to the GMA500 drivers... Ah well, back to Windows for the time being :P