View Full Version : [SOLVED] Can't boot 11.10 anymore

bob brazie
March 13th, 2012, 02:31 AM
It was working fine for months and now it won't boot into the gui.

I can't take a screen shot so I took a picture. <g>

Mentions sata quite a bit. Hard drive?

Any help would be greatly appriciated.

Thanks in advance. Bob.

March 13th, 2012, 04:32 AM
Hi ,
Its seems that something wrong here with your partitions. Try something :
Boot from Ubuntu LiveCD and " Try Ubuntu" .
Open terminal and do
sudo fdisk -l
sudo fsck -f -p dev/sd? where dev/sd? must be your linux partition. From fdisk -l output you can locate linux patrition by number 83
Good Luck

bob brazie
March 13th, 2012, 02:14 PM
Thanks I will try this afternoon. (usa pst) When I installed Ubuntu was the only partition. Will this matter?

March 13th, 2012, 04:19 PM
When I installed Ubuntu was the only partition. Will this matter? I don't think so. That you have only Ubuntu partitions will do thinks less tricky. I mentioned the number 83 , because you will see 82 number also. But 82 is swap memory and fsck will not check or repair it.
From screenshot seems that you have problem with Ext4 filesystem . So 83 number refers either to /home or /root partitions. Try to Check them and repair them with fsck.

bob brazie
March 13th, 2012, 11:40 PM
OK it is 83.

What is the command to use.

sudo fsck -f -p 83

Thanks, Bob.

bob brazie
March 14th, 2012, 12:54 AM
OK sorry.

I enter fsck -f -p dev/sd2 and all it tells me:

fsck from util-linux 2.19.1

Help! <g>


bob brazie
March 14th, 2012, 01:35 AM
OK, sorry again.

The command is: fsck -f -p /dev/sda2

Linux is on 1 so I tried fsck -f -p /dev/sd1 and it said the system clock was set sometime in the future and it said it fixed that. Still can't boot.

I have a /dev/sda 1,2 and 5. 5 is the swap file. No 4 is shown.

Any ideas?

Thanks, Bob.

March 15th, 2012, 10:54 PM
Hi ,
Please , try again

sudo umount /dev/sda1
sudo fsck -p /dev/sda1

bob brazie
March 15th, 2012, 11:52 PM
I was desperate to get back up and running so I did another clean install and in the end lost some data that was not backed up.

Live and learn I guess.