View Full Version : [SOLVED] 11.10 - Tried EVERYTHING!! Cannot play DVDs

March 12th, 2012, 12:31 AM
Really frustrating. I have followed the Ubuntu Community page for support on DVD playback, installed libdvdcss2 and everything that needs to be installed, and still I cannot play DVDs. In Movie Player, it used to complain about encryption, but it stopped. Now, however, it just freezes. VLC will go to play it, but the orang pilon will not go away. Any help with this?

March 12th, 2012, 01:17 AM
have you instatted the restricted extras for ubuntu. if not open the software center and search for restricted and install for ubuntu. just a though

March 12th, 2012, 02:17 AM
I already have restricted extras installed.

March 12th, 2012, 02:24 AM
Found out what the problem was.

If DVD playback is noticeably choppy or burning a CD/DVD is slower than it should be, then you may need to enable DMA transfer for the DVD drive. See the DMA (Direct Memory Access) page for details. The other (quicker) fix for this is to delete the ~/.dvdcss/ folder, if you have attempted to play a DVD without everything set up perfectly the incorrect CSS key will always be used. Deleting this folder causes the key to be rebuilt.

Works perfectly after removing the ~/.dvdcss/ folder. Tested a few DVDs just to make sure.:D

April 20th, 2012, 01:17 AM
Same problem - installed extras, VLC - still no video playback. Searched for dvdcss folder in the file manger using the search tool and come up with nothing. Where is it located?

April 20th, 2012, 01:28 AM
...the ~/.dvdcss/ folder.

The ~/ means /home/username. If your user name were, for instance, john, the folder would be at

The point at the start of the folder name means that it is hidden. You have to got to the view menu in the file browser and enable "view hidden files" to be able to see it.

April 20th, 2012, 01:29 AM
I think this is the article the OP was referring to: https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

April 20th, 2012, 01:52 AM
OK thanks, everything seems to be working now.