View Full Version : [gnome] gnome shell: battery indicator disappeared

March 11th, 2012, 12:33 PM
after some updates 2 days ago (including a kernel update) the battery indicator of the gnome shell disappeared. I installed an alternative indicator applet, this is neither showing up in the applet bar, while being activated in extended settings.

Has anyone an idea? Is this a problem due to the kernel update?


March 11th, 2012, 08:42 PM
Well why not boot from an earlier kernel?

March 11th, 2012, 10:57 PM
I checked and it's not a kernel problem. Since the last updates, the icons in the applet bar seem to "overlap" each other. I deactivated some and the battery indicator was visible again.

I couldn't find any solution to this problem neither. Is it possible to resize the area for gnome shell applets? There is enough free space in the top bar...

Frogs Hair
March 11th, 2012, 11:35 PM
I had a dual panel glitch last night and it was solved when I changed the wallpaper . What ever caused it occurred when I used appearance preferences to change the wall paper . When I selected a wallpaper from my pictures folder the secondary panel vanished.. It was strange because the time on the other panel was one hour earlier . I too received Gnome Shell updates last week .

March 27th, 2012, 02:22 PM
I had this problem for a while, thinking it was a gnome-shell bug, but instead it was the sytem-monitor extension (http://www.webupd8.org/2011/10/gnome-shell-system-monitor-extension.html), which in its latest iteration (updated automatically from the webupd8 repo) offers an improved battery icon, and by default hides both the default system icon and the new one.

November 4th, 2012, 02:59 AM
This long-standing bug remains a problem, even in current releases. (See the 12.10 bug report (https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1037676), the 12.04 bug report (https://bugs.launchpad.net/ubuntu/+source/indicator-power/+bug/997758), the 11.04 bug report (https://bugs.launchpad.net/ubuntu/+source/ubuntu-mono/+bug/801180), or even the ... well, you get the idea.)

There is a simple work-around, but first, if battery indicator is not visible, check that the daemon is running:
ps -ef | grep gnome-settings-daemon should return lines something like:
foo 1750 1309 0 15:12 ? 00:00:05 /usr/lib/gnome-settings-daemon/gnome-fallback-mount-helper
foo 20001 1 0 20:06 ? 00:00:00 /usr/lib/gnome-settings-daemon/gsd-printer (the "gnome-fallback-mount-helper" line if logged into a GFB session).

If no gnome-settings-daemon lines, first be sure the indicator is installed and not corrupt:
sudo apt-get purge indicator-power
sudo apt-get install indicator-powerLogout, back in and check again. If still no gnome-settings-daemon, set gconfig:
gsettings set org.gnome.settings-daemon.plugins.power active trueNow ready to apply the work-around.

First, test that battery indicator can be forced to display without problems. When it's not visible, run:
killall gsd-printer
ps -ef | grep gnome-settings-daemonSee that there is only one instance (one line) with "gsd-printer" and after a display blink (more noticeable on older machines), the battery indicator reappears.

Test again until satisfied that the method works, then daemonize by pasting the following into gedit (or favorite text editor) and saving as battery-indicator-temporary-workaround.sh (for example) in ~/.local


# Battery-indicator-temporary-workaround.sh
# For info, see: http://ubuntuforums.org/showpost.php?p=11797391&postcount=6
# This script is a temporary fix to keep the battery indicator visible. Remove when battery indicator no longer disappears.

while :; do
killall gsd-printer
sleep 10
exit 0Make executable by clicking to allow execution on Permissions tab of Properties dialog, or by:
chmod +x ~/.local/battery-indicator-temporary-workaround.shIf satisfied that battery indicator disappears for a maximum of 10 seconds (adjust 'sleep' as desired), set to auto-start in Applications | System Tools | Preferences | Startup Applications (or search Startup in Dash if in Unity).

Remember to watch for the disappearing behavior to itself disappear when the source of the problem is corrected. Then this fix-utility can be removed from Startup and deleted.

If this work-around is satisfactory, pille02, please mark this thread as 'solved'.

November 29th, 2012, 02:55 PM
Quick update to note:

The flashing/blinking display in 12.10 got to be too much and I decided to let the rival programs battle it out on others' machines. Re-installed 12.04 -- problem solved. No more need for funky workarounds.