View Full Version : [ubuntu] Flash won't upgrade

March 8th, 2012, 02:35 AM
I am a player of Castleville on Facebook. It says I need an updated version of flash. I tried reinstallng but nothing worked. Help me please :(

I use Firefox

I used

sudo apt-get install flashplugin-installerI still get errors of not being up-to

March 9th, 2012, 01:27 AM
Click on the link in my sig below "Help With Flash"

Flash Aid will probably cure the issue.

Hope this helps

March 9th, 2012, 02:05 AM
I still have a problem. Here is a screen shot of my problem.


March 9th, 2012, 02:12 AM
Did you install and run Flash aid then restart Firefox?

March 9th, 2012, 02:35 AM
Yes I did :(

March 9th, 2012, 07:13 AM
what version does it show when you go here:


if it tells you have the latest, the contact the authors of that game and tell them to update their software and use the latest flash version.

are you on x86 or 64 bit?

March 9th, 2012, 10:52 AM
Check to see if you can see the moving image and text here:


and try viewing a video on youtube.

If these are working then you might need to clear your browser cache.

First though try to access the game by bypassing the cache as follows:

get to the loading screen where it tells you you need to update flash, then press
control + shift + R (this will reload the page but without using the cache)

Sometimes just pressing
Control + F5 does the same thing.

Try these and if the game loads then you will need to clear you browser cache by going to
Edit > Preferences > Privacy and select the "clear all current history" option. This will allow you to select what you want to clear.

Hope this helps.

March 9th, 2012, 07:23 PM
Youtube runs just fine.

The movie pops up just fine, too.

Edit: I think it's just facebook... everything else works just ifne. This works on my Windows partition though... I don't want to boot into Windows every time I login :-(