PDA

View Full Version : [ubuntu] 11.04 not displaying on TV unidentified by get-edid with or without xorg.conf



jabrown65
March 5th, 2012, 11:15 AM
I had fully functioning MythTV Frontend running on an EPIV VIA EN12000 fanless motherboard running 10.04LTSS for years, except it wouldn't render HDTV. Clearly time to upgrade.

I now have a EPIA M720 motherboard running 11.04 (no video drivers available yet for 11.10).

On an LCD VGA Computer monitor it works fine.

On my LCD widescreen TV (which of course is where it needs to work) it doesn't work, either on VGA or HDMI. Sticking with VGA for now, using the xorg.conf attached it seems to work at first, in that after a (long) while it arrives at the proper looking login screen, but it is PAINFULLY slow, such that if you move the mouse the pointer either doesn't move, or moves in spurts accorss the screen with long gaps in between (both in time and position). Note that it works fine in failsafe recovery mode, except that it only shows part of the screen.

I've tried several things but nothing has worked. Importantly the xorg.0.log shows it rejects my screen resolution 1366*768 (either with or without the modeline command) because the TV supposedly doesn't support reduced blanking. However, it worked for years on that TV before I upgraded everything. I have read that the "doesn't support blanking" result is an assumption made because it can't get the proper information fom the monitor (see the get-edid output) and in fact LCDs run with no blanking (correct?). Could this be the cause of my problems? If so, what do I need to put into xorg.conf to force it to assume that the monitor is a VGA-LCD and blanking is not requred? Or could it be somthing quite different causing the problem?

I am using the manufacturer's video driver "via" and via_chrome9, which worked fine 'out of the box' on my LCD monitor, but I can't get it working on my TV and I think the problem is with whatever is configuring the computer from xorg.conf, rather then the drivers.

Hopefully this makes sense!

I attached xorg.conf, Xoeg.0.log and get-edid_output all with .txt extensions

Any suggestions would be appreciated.

Thanks,

John


PS< for all those who want to lett me to use openchrome, which used to be the conventional wisdom with Via, I tried but couldn't get X to launch at all. While the people on the openchrome mailing list were very helpful, it seemed that a lot needed to happen before I'd get a functioning display. So I am sticking with via_chrome9 for now. At least it works on my computer monitor.