PDA

View Full Version : [SOLVED] font control



weezyrider
February 23rd, 2012, 09:13 PM
It seem Ubuntu desktop has decided it will override font choice in printing and applications.
I am using Firefox, and to get FF fonts to where I want them - I have to tweak the desktop etc, fonts.

I am not trying to use a non-system font, just what came with 11.04. Normally, if the font is in the system, the application will use the font of choice. Ubuntu is overriding selected fonts in both Firefox and Opera.

To get the menu bar fonts to a reasonable size in Firefox, I had to change the application size in the system appearance to 8 pt. FF will not change them. I have tried.

It is also messing up printing. I cannot chose to "use my own" for colors, fonts, etc in FF. So if the document I'm trying to print from the web is in a sans serif, and the HP Laserjet is trying to change that font to a serif, it takes forever to print. Since Ubuntu seems to be the controlling factor, I'm asking here first.

I really want the programs to control the size and whether bold, italic IN THE SYSTEM FONTS.

I had to mess with the fonts in this text box to even read them!

Rodney9
February 23rd, 2012, 11:03 PM
Firefox and Chromium use their own fonts, you can get them to use whatever font you want.


For How-To's, Information and Screen-Casts on Lubuntu go to the
Lubuntu One Stop Thread -

Lubuntu One Stop Thread (http://ubuntuforums.org/showthread.php?t=1844755)

Rodney

Frogs Hair
February 23rd, 2012, 11:08 PM
Open Firefox preferences > content > fonts > advanced and turn off the option to allow web pages to use their own fonts . That may help with the printing from a page web problem .

Ignore screen the screen shot ,it's Ubuntu

weezyrider
February 24th, 2012, 12:33 AM
Open Firefox preferences > content > fonts > advanced and turn off the option to allow web pages to use their own fonts . That may help with the printing from a page web problem .

Ignore screen the screen shot ,it's Ubuntu

Tried that - it helped with printing but not with the desktop. If I leave desktop/application fonts at default - the text in the FF toolbars is too damn big. The content menu in FF will NOT set to another system font or size. Its default is what Ubuntu is using. I made sure I was selecting a system font just in case. FF simply won't resize or change the weight. Neither will Opera. I uninstalled Chrome so I can't check it.

weezyrider
February 24th, 2012, 06:12 PM
I fixed it. There's a new extension for Firefox that integrates with Unity. I disabled that and have desktop back to normal