View Full Version : [SOLVED] Can't load an iPod from Rhythmbox Music Player

February 22nd, 2012, 03:09 AM
OK I give up, I've searched and found that Rhythmbox Music Player can load an iPod.

I drag & drop, wait for it to synchronize, eject safely ..the tunes show on the iPod but no music ..what gives ?

February 22nd, 2012, 04:48 AM
This exact thing started happening to me on Banshee and I got so fed up I switched to Rhythmbox and now it seems to work. Only thing I hate is that it takes FOREVER to transfer music. It probably takes the same amount of time to transfer 2 songs to my iPod using Rhythmbox as it would transferring an entire album using iTunes.

I guess you could try Banshee and see if that works.

February 22nd, 2012, 10:01 AM

so is the easiest/cleanest solution to download iTunes into Windows and do it that way ?

February 22nd, 2012, 10:57 AM
When I had an ipod I found it would work intermittently with Rhythmbox and Banshee, and eventually I worked out that it wouldn't delete things properly, and then when it was full (though I couldn't see any files) it would stop. Anyway, I ended up downloading gtkpod ipod manager and that worked fine, though the interface is perhaps a bit odd. So I would recommend trying that.

February 22nd, 2012, 11:06 PM
I downloaded and used gtkpod ..after a bit of tinkering everything worked, so thanks to you joetait I can mark this thread 'Solved'