PDA

View Full Version : [SOLVED] 10.04 - Can't log in to KDE



Zeikcied
February 21st, 2012, 08:18 PM
My mom has had Kubuntu 10.04 for over well over a year now, and hasn't had many issues. Last night she did something, and we don't quite know what, that has caused some problems.

I got to the KDE login screen and put in her password. The login process starts, and it shows the hard drive icon. Then it waits, and waits. Then it kicks me back to the login screen without showing the next icon in the process.

I tried a package upgrade, and even though it came with a new kernel, it didn't help. I used recovery mode to try and fix any broken packages, and while it seemed to do something, it didn't help. Oddly, the failsafex option in recovery mode didn't work.

But I know X starts. I couldn't get the KDE login screen if X didn't work. I even get the KDE-skinned mouse.

She did a series of things, then she tried to open Firefox. It seems Firefox crashed, but then KDE stopped responding. She says she could move the mouse just fine, but no windows would respond, the KMenu wouldn't respond, nothing. She manually shut down the computer by pressing the button on the front.

Now I can login via the tty1 terminal. I can do ls and see the drive contents. I can move around to .kde and other folders. So the system works. Everything seems okay. I just can't get KDE to load properly.

roelforg
February 21st, 2012, 08:22 PM
I'm gonna ask you to press CTRL-ALT-F1 to get a console,
login with your username/password
And run:


sudo dpkg-reconfigure kde

Note: if it errors out, try it with kde-full instead off kde.
I'm afraid i can't help you very much as i don't use kubuntu.
These instructions work most of the time, you just need to make sure that you replace the kde in the command with the package name of your kde Desktop Environment

Zeikcied
February 21st, 2012, 08:59 PM
I ran dpkg-reconfigure on kdebase, kdebase-bin, kdebase-apps, and kubuntu-desktop, and it didn't help.

I didn't try kdebase-runtime or kdebase-workspace, so I don't know if that would do any good.

Zeikcied
February 21st, 2012, 10:53 PM
Ok, none of the dpkg-reconfigure things I tried worked.

My mom says that Gwenview froze while she was viewing the images. She couldn't close it, so she just opened the images again, presumably in a new instance of Gwenview, and then she was able to close the first window that had frozen. This was shortly before everything froze when she tried opening Firefox.

She was also having problems with Firefox and cookies, but that might be unrelated.

Zeikcied
February 22nd, 2012, 04:37 AM
I hope people are still reading this.

I was able to stumble upon some error information. I can't copy/paste since it's on a terminal on another computer. So I tried taking a photo.

There's some "failed command: READ DMA" lines in there, and it ends with:

end_request: I/O error, dev sda, sector 34127047

That surprises me, as I can navigate the partition just fine. I can move files and folders with no problems. So why is KDE throwing I/O errors?