PDA

View Full Version : [ubuntu] Wireless on Toshiba Satellite L300D-10B



shirocz
February 18th, 2012, 11:24 PM
Hi,

I'm having a problem with Ubuntu. I've tried several versions but this haven't worked in any of them so far, I'm running 11.10 now.

The problem is that the system keeps saying that the "wireless is disabled by hardware switch", even though it's PERMANENTLY ON! (Can't even turn it off, it's stuck and the wi-fi works PERFECTLY fine in Windows 7).

I tried following this http://www.saunalahti.fi/~anmodino/toshiba_l300d/ , installed the latest wireless drivers but it hasn't changed anything at all.

Any idea how to fix that? It's driving me crazy, I need to run Linux but it is useless without wireless for me.

I installed the system with wubi, I couldn't get it to boot with usb stick (was only getting "Boot Error" right after I tried to boot it, like if it was broken, but don't believe it would solve this problem anyway).

I will appreciate any kind of help!
Thanks

shirocz
February 20th, 2012, 09:29 PM
No clue anyone? The wireless card is Realrek SemiConductor RTL8187B Wireless Adapter, it says it is DISABLED after doing lshw and that the driver is rtl8187...