PDA

View Full Version : [SOLVED] SSH error: Bad packet length



octopus22
February 15th, 2012, 10:17 AM
ssh user@example.com
Bad packet length 1885434739.
Disconnecting: Packet corrupt

Server is up and running, web sites working ok, i can even chroot it using resque system.
All users got same error.

Grenage
February 15th, 2012, 10:28 AM
OpenSSH is installed on the server (which is where I assume the problem lies).

What happens when you try and connect using:


ssh -1 host

octopus22
February 15th, 2012, 10:29 AM
Same story: Disconnecting: Bad packet length 1885434739

Grenage
February 15th, 2012, 10:36 AM
Are you using openssh on the server?

octopus22
February 15th, 2012, 10:43 AM
Yes.
Ubuntu server x64, ISP manager 4.4, LAMP, openssh, memcached, mongodb.

SSH stop working without any updates or installations from my side.
Have no idea what to check.

Grenage
February 15th, 2012, 11:10 AM
While I've never seen this, reading suggests that data corruption is a possibility, so let's rule things out. If you plug the server directly into a client PC (crossover cable), does it still happen? If you don't have a crossover cable, do you have another switch or router that you can use?

octopus22
February 15th, 2012, 01:51 PM
This server is placed in data center, no router problems. Other connections with server is ok, just corrupted ssh.

I can chroot to get and look into any config, but don't know where to start from. Google doesn't help with that.

Tech support advice to make full reinstall and data migration, but this is last thing i want to deal with.

Grenage
February 15th, 2012, 03:44 PM
Unfortunately I don't know what to suggest; the little information I found suggested routers/cables/etc as the faulty candidates. Hopefully someone who has soon it will come by this post.

octopus22
February 15th, 2012, 03:48 PM
thank you for helping anyway. at least we know this is not ssl2 issue.

octopus22
February 15th, 2012, 04:16 PM
I can dig and publish any config or whatever on this machine.

Grenage
February 15th, 2012, 04:18 PM
Are you able to SSH from the server to another machine?

octopus22
February 17th, 2012, 11:39 AM
Yes, server can make ssh connection to another machine without problems!

octopus22
February 29th, 2012, 09:40 AM
Finally, it was a rootkit with advanced shields and security. Config was OK, SSH was blocked in some other way.
Moving data to other server, clean install.