View Full Version : [SOLVED] E: Unable to locate package

February 13th, 2012, 07:50 AM
i am relatively new to ubuntu and also the network simulations.
now i require to work with GTNetS - Georgia Tech Network Simulator
so i have somehow installed it seeing guidelines provided in GTNetS official website
and now having installed i am trying to use it by executing examples given in

after executing
$ make debug
it has generated executables with .dbg file extension
now when i am trying to execute the nms-dbg.dbg using command
sudo apt-get install nms-dbg
it is throwing an error - E: Unable to locate package nms-dbg

i am coping the whole code below for reference

sravan@ubuntu:~/GTNetS/EXAMPLES$ sudo apt-get install nms-dbg
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nms-dbg

anticipating help
Thanks & Regards

February 13th, 2012, 08:32 AM
Try this link: http://www.opennms.org/documentation/InstallUnStable.html#preparing-for-install

Ubuntu is a Debian-based distro.

February 13th, 2012, 09:29 AM
thank you for the reply this is my first day first post on ubuntuforums and ur my first friend here with first reply

i think i was not clear in my query my exact problem is with using the .dbg files being created as output of make with GTNetS Example programs.
now i am trying to use the .dbg files so as to see and analyze the output

thanks & regards

February 13th, 2012, 09:37 AM
You've tried installing 'nms-dbg' which is not in the repositories. The link above explains how to get it.

PS: Welcome to the forums :~).

February 14th, 2012, 06:09 AM