PDA

View Full Version : [SOLVED] .swp file recovery?



geomarsh
January 30th, 2012, 06:57 PM
Using ubuntu 10.04 on a dell lap top. I had to close the pc and run. Now I want to resume edit on my file but it save with .swp. I tried to do vi -r but it failed. I tried recover but don't have a clue what the root passwd is. What can I do to get this file back? Or how can I change my root to something new.

ajgreeny
January 30th, 2012, 08:23 PM
There is no root password, unless you have set one at some point; for root permissions you use "sudo command" or "gksudo application-name" eg "gksudo gedit" for gnome applications.

I am not sure what you mean by "it save with .swp." but I imagine you are talking about the laptop going into suspend mode. If you are being asked for a password when coming out of suspend, try the user password that you set at installation time. If you don't know that you have a problem and will probably lose the file you were editing, though you should be able to get the machine running again simply by hard rebooting it, or holding the Right-Alt +Print-Sxcreen and slowly typing "r i e s u b" with two or tree seconds between each keypress.