View Full Version : [ubuntu] Keyboard goes insane and then just stops working

January 29th, 2012, 09:28 PM
Last night while surfing the web I noticed that my keyboard was behaving strangely. Entering a "j" produced "ju", the backspace key didn't work and other keys produced doublets of characters as well. I also noticed that, unbeknownst to me, the keyboard shortcut utility had opened and was lurking under all the Chrome windows. Unfortunately, I saw this only after I had instructed the machine to shut down thinking maybe a reboot would fix it. It didn't. I looked around for information about how to restore the keyboard defaults but couldn't find what I wanted. The machine was overdue for an upgrade to 11.10 so I logged in from my macbook and did that. Now the keyboard is simply not working at all. The keyboard is an old PS2 style one but it worked fine under 11.04 and all previous versions. I don't have Windows so I cannot check if it works under Windows. My next move is just to nuke the whole installation from orbit and install from DVD. It's the only way to be sure.


January 30th, 2012, 01:43 AM
Well, this looks like a giant NEVERMIND issue. I tried the keyboard on my mom's computer and hers on mine and hers works fine on my machine while my keyboard is just as dead for her as for me. She's letting me borrow it until tomorrow when I'll get a new one for myself. :D

PS. at least this encouraged me to finally upgrade to 11.10