View Full Version : [SOLVED] Problem installing libapache2-mod-php5

January 22nd, 2012, 05:32 AM
So I was installing LAMP (I installed everything separately). Problem is, I keep getting stuck at this message while installing libapache2-mod-php5:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libapache2-mod-php5 : Depends: php5-common (= 5.3.5-1ubuntu7) but 5.3.5-1ubuntu7.4 is to be installed
E: Broken packagesI found some solutions via Google, like apt-get update, and using the -f option. Nothing has worked so far. I'd appreciate any help. :)

I'm using Natty.

January 22nd, 2012, 08:32 AM
open your synaptic manager and at the bottom read message . then try to fix that broken packages from there .


in terminal

sudo apt-get install -f

give me that output here

thank you.

January 23rd, 2012, 12:20 PM
Hi! Sorry for the late reply.

I don't get any message as I open the Synaptic Package Manager.

Sudo apt-get install -f gives this output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
git-man liberror-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


January 23rd, 2012, 04:55 PM
ok now try again to install that required package .

let us know what you got .

January 23rd, 2012, 04:56 PM
look for that required dependencies packages from ubuntu packages and install them

sudo dpkg -i name.deb

January 23rd, 2012, 06:03 PM
So I guess the problem was that the dependency php-common was the one conflicting. I removed it from synaptic, and tried again, and there was no problem! :D

Thanks for helping me out!