PDA

View Full Version : [ubuntu] Ubuntu 11.04 & NVIDIA 8400GS dual monitor freezes



RefinersFire
January 19th, 2012, 06:48 PM
I have been searching for hours for a solution to my problem. No one else's issue seems to be like mine.

I am running ubuntu 11.04, and I have an NVIDIA Geforce 8400GS set up as dual monitor. I am using NVIDIA's current recommended proprietary drivers (nvidia-173 & nvidia-current).

IF I only use one of the two monitors, ubuntu works great. No issues whatsoever. Doesn't matter if it is the DVI or D-Sub. I cannot have both monitors plugged in or the desktop freezes upon login. Doesn't matter if I use Unity or Gnome (I prefer gnome).
IF I log in using Ubuntu Classic (No Effects), both monitors work, but the desktop is on the wrong monitor, and I cannot switch it. When I check Additional Drivers in the Administration menu, NVIDIA's drivers are not being used.

The dual monitor works on Windows XP Professional SP2, Windows Vista Home Basic, and Windows 7 Home Premium. So the card is good. (multiple boot. I like to compare Operating Systems)

I have updated my system, reinstalled the NVIDIA drivers, tried running the system with NVIDIA's drivers uninstalled, disabling all Compiz effects, logging in with one monitor unplugged then plugging it in, etc.

I am lost now. I searched the forums, and a Google search.

When I log in using gnome, I get my background on the left monitor, and two grey panels (top and bottom) that have no menus or objects (frozen). Right click doesn't work on anything, keyboard shortcuts do not work. I cannot even alt+Ctrl+Del to reboot.

Help!

RefinersFire
January 22nd, 2012, 08:22 PM
Any ideas?