PDA

View Full Version : [SOLVED] Ubuntu 10.04 and CD/DVD drives



ibates
January 17th, 2012, 08:19 AM
For months and months now, users have been posting about their 10.04 LTS machine not recognising CD/DVD drives, let alone media inserted in those drives.

I have read probably hundreds of these posts. But never have I seen any serious result-producing advice to actually address the problem.

I am yet another Ubuntu user (of several years now) who has to revert back to Windows whenever I want to reliably read from or write to a CD or DVD. And as this forms a major part of my usage, having Ubuntu is merely adding to my workload, not offering anything better which I believed it should.

Like many Ubuntu converts, I dislike having to revert to Windows at least once in each and every session. But it cannot be avoided as attempting to use CD/DVDs in Ubuntu is simply too unreliable, even if, by chance, one is actually able to get a CD or DVD up and running. Halfway through the operation, when a file is called from the CD/DVD it is just as likely as not that the thing will have been rejected by the system leaving no alternative but to start again, back in Windows.

My question is simply; is there a solution to this problem, or does this ultimately mean the end of the road for Ubuntu after battling with it for several years now? That would be a shame, because there are many obvious advantages to Linux over Windows, but if one can't get the system to do daily required tasks, and not even of an extraordinary nature, it is more trouble than it is worth.

Any assistance would be appreciated.

ibates
January 17th, 2012, 10:41 AM
When the two CD/DVD devices were installed initially, I was advised to set the jumpers on both devices as Cable Select. It now appears that was not good advice.

The jumper on the connector on the end of the interface cable has now been set to Master and the jumper on the device connected to the middle connector on the cable has been set to slave.

The interface cable has in turn been connected to the motherboard at Sec IDE connector, as it in fact always was.

Discs have been popped in and ejected (for testing purposes) since this adjustment has been made, and for the first time in memory it now appears that things might be working correctly.

Curious how this problem never manifested itself when running Windows XP.

But whatever, the problem seems, for the moment at least, to be solved.