View Full Version : [ubuntu] Ubuntu 11.10 wipes grub when it boots

January 11th, 2012, 01:20 PM
Hi, I have been coming to this forum for advise for a while, but never needed to ask a question as most of my questions had already been asked and answered, until now.
I decided to change from Ubuntu 10.4 to Ubuntu 11.10 through a fresh install. Everything seemed to go well until I tried to boot, then I got the message error: symbol 'grub_xputs' not found. With the live cd I reinstalled the grub following these directions (http://ubuntuforums.org/showpost.php?p=9836539&postcount=5). Success! I thought, as after reboot it worked perfectly. But then I turned the pc off, and when I tried to start it again I only got a black (slightly lilac on the corners) screen, with no message and no HD activity, or so it seemed. I did the process of reinstalling the grub again and again it worked until I turned it off. So it looks like I have to reinstall the grub everytime and then reboot, not very practical...Does somebody have any advise?
Thank you for your help

January 11th, 2012, 01:29 PM
Try https://help.ubuntu.com/community/Boot-Repair

January 12th, 2012, 07:42 PM
Thank you. I tried and it said successfuly repaired, but when after reboot the screen was still black. I tried to install it all over again to see if something had gone wrong in the process, but it's the same. Just this black/lilac screen.