PDA

View Full Version : [ubuntu] 10.04 LTS NVIDIA Graphics Drivers(best known working)



BenjaminL
January 2nd, 2012, 10:04 AM
I tried out the new Ubuntu 11.10 and read up on posts saying the gnome 3 was glitchy and it has been making the video drivers and such not work correctly(mine weren't either, a lot of the info on it said "unknown" and such).
So, I went back onto 10.04 LTS and I would like to know which NVIDIA drivers are best currently working for it.
A while back I had NVIDIA drivers installed and such and things were working great, but I don't remember which drivers I had installed.(The HDD has been reformatted since then.)
(GPU GeForce 9600 GT 1024MB)
I've done went through 3 or so drivers and nothing seems to work.
I've went through the terminal, did a purge for "NVIDIA", restarted, tried to install another version, and nothing seems to work.

Thanks ahead of time.

(Forum Hardware&Laptops seems to be the only category near my issue, sorry if I do create this thread in the wrong spot.)

tjoff
January 2nd, 2012, 11:35 AM
I am using Ubuntu 10.04 (64bit version) on a Dell Precision M4300. The grapics card is a Quadro FX 360M. The NVIDIA Driver version 195.36.24 works fine for my needs (3D visualization, dual monitors, no gaming).

crazy bird
January 2nd, 2012, 12:00 PM
What about this PPA: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates.
This PPA allows you to install the latest stable upstream release of the Nvidia driver.

BenjaminL
January 2nd, 2012, 01:21 PM
What about this PPA: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates (https://launchpad.net/%7Eubuntu-x-swat/+archive/x-updates).
This PPA allows you to install the latest stable upstream release of the Nvidia driver.

I already have that on my software list. I just recently tried 290.10(through "nvidia-current") and I still can't turn on the visual effects, and NVIDIA X Settings.

crazy bird
January 2nd, 2012, 01:45 PM
I already have that on my software list. I just recently tried 290.10(through "nvidia-current") and I still can't turn on the visual effects, and NVIDIA X Settings.

Try this:
- open a terminal
- type this command: nvidia-config
- press enter
- if asked for, type your password and press enter again

In the directory / etc/X11 file a file called xorg.conf will be created and the videocard settings can be changed using the NVIDIA X Server Settings shortcut.